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Preface

This documentation describes how to use the WebFOCUS InfoAssist application. It is intended
for users that need to create, modify, and run reports.

Contact your local Information Builders account manager to learn how to license and enable
this new capability.

Note: The WebFOCUS toolset generates the rich FOCUS fourth generation language. While
this language is very extensive, the WebFOCUS toolset only supports a subset of the language
and only specific syntax constructs. While the user can manually modify the content of these
WebFOCUS procedures and files, there is no guarantee that the user will be able to open
the modified procedure in the tool.

How This Manual Is Organized

This manual includes the following chapters:

Chapter/Appendix Contents

1 Introducing InfoAssist Describes the benefits of the InfoAssist ad hoc
reporting tool, how to access it, and how to use its
start-up screen.

2 Getting Started With Describes how to start working with each version of
InfoAssist the InfoAssist application and how to set your user
preferences.
3 Navigating the InfoAssist Describes how to use the elements that make up the
Interface application window.

4 Creating and Customizing Describes how to create, customize, and style
Reports reports, and provides an overview of output formats.

5 Creating and Customizing Describes how to create and customize charts, and
Charts provides an overview of the available chart types and
output formats.

WebFOCUS InfoAssist User's Manual 9



Documentation Conventions

Chapter/Appendix Contents

6 Creating and Customizing Describes features of documents and Document view,
Documents which enables users to add text, images, reports,

and charts to create documents in InfoAssist.

7 Creating Active Describes how to create a report, chart, or dashboard
Technologies Reports, that is enabled for Active Technologies using
Charts, and Dashboards InfoAssist.

With InfoAssist

8 Using Slicers Describes the functionality of slicers, the dynamic

selection criteria available from the Slicers tab.

9 Building InfoMini Describes how to create InfoMini applications that
Applications have embedded analysis functionality that is available

at run time.

A Glossary Describes key concepts in this manual.

Documentation Conventions

10

The following table describes the documentation conventions that are used in this manual.

Convention

Description

THI' S TYPEFACE
or

this typeface

Denotes syntax that you must enter exactly as shown.

this typeface

Represents a placeholder (or variable) in syntax for a value that
you or the system must supply.

under score

Indicates a default setting.

this typeface

Represents a placeholder (or variable), a cross-reference, or an
important term. It may also indicate a button, menu item, or
dialog box option that you can click or select.

this typeface

Highlights a file name or command.

Key + Key

Indicates keys that you must press simultaneously.

WebFOCUS
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Convention Description

{ } Indicates two or three choices. Type one of them, not the braces.

[ 1] Indicates a group of optional parameters. None are required,
but you may select one of them. Type only the parameter in the
brackets, not the brackets.

Separates mutually exclusive choices in syntax. Type one of
them, not the symbol.

Indicates that you can enter a parameter multiple times. Type
only the parameter, not the ellipsis (...).

Indicates that there are (or could be) intervening or additional
commands.

Related Publications

To view a current listing of our publications and to place an order, visit our Technical
Documentation Library, http;//documentation.informationbuilders.com. You can also contact
the Publications Order Department at (800) 969-4636.

Customer Support
Do you have any questions about this product?

Join the Focal Point community. Focal Point is our online developer center and more than a
message board. It is an interactive network of more than 3,000 developers from almost
every profession and industry, collaborating on solutions and sharing tips and techniques.
Access Focal Point at http;//forums.informationbuilders.com/eve/forums.

You can also access support services electronically, 24 hours a day, with InfoResponse
Online. InfoResponse Online is accessible through our website,
http://www.informationbuilders.com. It connects you to the tracking system and known-
problem database at the Information Builders support center. Registered users can open,
update, and view the status of cases in the tracking system and read descriptions of reported
software issues. New users can register immediately for this service. The technical support
section of www.informationbuilders.com also provides usage techniques, diagnostic tips,
and answers to frequently asked questions.

WebFOCUS InfoAssist User's Manual 11
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Information You Should Have

Call Information Builders Customer Support Services (CSS) at (800) 736-6130 or (212) 736-
6130. Customer Support Consultants are available Monday through Friday between 8:00
a.m. and 8:00 p.m. EST to address all your questions. Information Builders consultants can
also give you general guidance regarding product capabilities and documentation. Please
be ready to provide your six-digit site code number (xxxx.xx) when you call.

To learn about the full range of available support services, ask your Information Builders
representative about InfoResponse Online, or call (800) 969-INFO.

Information You Should Have

12

To help our consultants answer your questions effectively, be prepared to provide the following
information when you call:

A

o

Your six-digit site code (xxxx.xx).
Your WebFOCUS configuration:
4 The front-end you are using, including vendor and release.

4 The communications protocol (for example, TCP/IP or HLLAPI), including vendor and
release.

4 The software release.

< Your server version and release. You can find this information using the Version option
in the Web Console.

The stored procedure (preferably with line numbers) or SQL statements being used in
server access.

The Master File and Access File.
The exact nature of the problem:

<4 Are the results or the format incorrect? Are the text or calculations missing or
misplaced?

4 Provide the error message and return code, if applicable.
4 |s this related to any other problem?

Has the procedure or query ever worked in its present form? Has it been changed recently?
How often does the problem occur?

What release of the operating system are you using? Has it, your security system,
communications protocol, or front-end software changed?

Is this problem reproducible? If so, how?

WebFOCUS
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4 Have you tried to reproduce your problem in the simplest form possible? For example, if
you are having problems joining two data sources, have you tried executing a query
containing just the code to access the data source?

4 Do you have a trace file?

4 How is the problem affecting your business? Is it halting development or production? Do
you just have questions about functionality or documentation?

User Feedback

In an effort to produce effective documentation, the Documentation Services staff welcomes
your opinions regarding this manual. Please use the Reader Comments form at the end of
this manual to communicate suggestions for improving this publication or to alert us to
corrections. You can also use the Documentation Feedback form on our website,
http;//documentation.informationbuilders.com/feedback.asp.

Thank you, in advance, for your comments.

Information Builders Consulting and Training

Interested in training? Information Builders Education Department offers a wide variety of
training courses for this and other Information Builders products.

For information on course descriptions, locations, and dates, or to register for classes, visit
our website (http://www.informationbuilders.com) or call (800) 969-INFO to speak to an
Education Representative.

WebFOCUS InfoAssist User's Manual 13
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Information Builders Consulting and Training
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Introducing InfoAssist

InfoAssist provides business users with
the most advanced, yet simple to use,
ad hoc reporting features needed to
create intricate reports and perform
insightful analysis.

InfoAssist provides a robust, user-friendly
solution that helps companies overcome
traditional ad hoc reporting challenges.

InfoAssist is available in the following
versions:

4 InfoAssist. Complete version of this
powerful report-generation tool.

-1 Personal InfoAssist. Self-service
version of InfoAssist.

- InfoAssist Basic. Limited version of
InfoAssist provided to existing Report
and Graph Assist customers.

- InfoMini. Applications built from an
InfoAssist report that contain a
subset of InfoAssist functionality at
run time.

WebFOCUS InfoAssist User's Manual

WebFOCUS

Topics:

4 InfoAssist

4 Personal InfoAssist
4 InfoAssist Basic

4 InfoMini

J

Accessibility Compliance With
InfoAssist

15



InfoAssist

InfoAssist

InfoAssist is the web-based ad hoc reporting tool in WebFOCUS.
With InfoAssist, you can quickly and easily:

4 Generate highly complex reports, charts, dashboards, and documents from any enterprise
information source without IT intervention.

4 Complete tasks, such as building a report, with minimal clicks.
4 Convert reports to charts, or charts to reports, in a single click.

4 Analyze multiple reports and charts simultaneously, using advanced tiling options to view
data from multiple perspectives.

4 Browse more than 300 enterprise-information sources, including multi-dimensional
sources.

< Qutput report and chart data in a variety of formats, including HTML, HTML5 (charts only),
active reports, active Flash®, PDF, active PDF, Excel®, and PowerPoint®.

InfoAssist is a Rich Internet Application (RIA) that uses AJAX (Asynchronous JavaScript and
XML) technology. It delivers its cutting-edge functionality using a familiar Microsoft Windows®
ribbon interface. This highly intuitive environment shields users from the underlying technical
complexities associated with ad hoc reporting features, while providing access to all the
functionality needed to address mission-critical information requirements.

This powerful ad hoc reporting tool enables rapid and efficient design and deployment of
reports and charts. It uses an interactive and fully-customizable WYSIWYG (What You See
Is What You Get) development environment. Users receive instant feedback throughout the
development process to ensure that reports and charts are properly built.

Personal InfoAssist

16

Personal InfoAssist is available outside the Bl Portal (Managed Reporting) environment. Any
application can call and open Personal InfoAssist. This feature enables you to integrate
InfoAssist into your own self-service applications.

With Personal InfoAssist, you can browse for saved reports (procedures) on your local desktop.
You can also save reports to the local desktop and restore them from the desktop. You
execute reports only within InfoAssist. There is no facility that allows query execution outside
the tool.

All functionality of InfoAssist is provided in Personal InfoAssist, except the following;:
4 Customizing InfoAssist by modifying user preferences.

< Drilling down to a procedure.

WebFOCUS
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4 Applying custom themes.
< Running reports in deferred mode.

d  InfoMini.

InfoAssist Basic

InfoAssist Basic is a modern web-based facility that provides comparable functionality to
legacy reporting tools. InfoAssist Basic contains many of the features of InfoAssist, while
still allowing you to create and edit reports and charts as you would with a legacy tool.

InfoAssist Basic is an advanced, yet simple to use, ad hoc reporting tool that offers dynamic
features for creating intricate reports and performing insightful analysis.

Using InfoAssist Basic, you can create a customized report, organize report output with
sorting, change a column heading and format, add a page heading and footing, enhance the
appearance of the report, create a matrix report, and validate and test your work.

InfoAssist Basic does not include the following capabilities found in InfoAssist:
<4 General Features
4 Creating dashboards and documents
4 Live Preview
4 Publishing
4 InfoMini
- Slicers
<4 Cube Browser
4 Chart to Report conversion
<4 Home tab
4 Format group
<4 Format tab
4 Destination group
4 Reference Lines
4 Annotations
4 Format Horizontal Grid Lines - Color Bands tab and Frames tab

4 Format Vertical Grid Lines - Color Bands tab and Frames tab

WebFOCUS InfoAssist User's Manual 17



InfoMini

4 Gauges
1 Format Vertical Axis - Frames tab
1 Format Horizontal Axis - Frames tab
d Format Legend - Fill tab, Border Styles tab, and Shadow tab
<1 Field tab
4 Sorting
- Series tab
-1 Data Position
<4 Trendlines
4 Equation
4 Smooth Line
4 Marker Shape
4 Pie Expand
-1 Pie Hide
4 Qutput Types
-1 PowerPoint
-1 active PDF
- active report
-1 active Flash

<4 Excel

InfoMini

Business analysts can use InfoAssist to build InfoMini applications that enable their non-
technical end users to modify reports without having to learn a tool or rely on IT for support.

InfoMini enables business analysts and end users to choose the information they receive
from their Bl system with the click of a button, displaying only the information specific to
their needs for faster, more informed decision-making.

With InfoMini, a business analyst can easily build an application to customize or filter a
report into any format an end user needs.
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1. Introducing InfoAssist I

This tailored interactivity feature allows specific conditional styling, formatting, or functionality
to be applied to any individual report without manual coding.

Business analysts can also build and publish gadgets (or mini-applications similar to an
iGoogle® widget) that connect directly to the Bl system to pull customizable information and
reports.

Accessibility Compliance With InfoAssist
InfoAssist is Section 508 compliant with the following end-user configuration:
4 Internet Explorer® Version 7 or 8.

1 JAWS® Version 11.0 or later. See the Freedom Scientific® website,
http;//www.freedomscientific.com, for browser requirement information.

For more information on specific accessibility requirements for InfoAssist, see the WebFOCUS
Accessibility Guide.

WebFOCUS InfoAssist User's Manual 19
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Getting Started With InfoAssist

You can quickly access each of the
versions of InfoAssist using the
information provided in the following
sections.

Once you get started with InfoAssist, you
can easily change your user preferences
to customize the way that InfoAssist
behaves when you are creating reports
and charts and generating output.

You can customize the InfoAssist
interface by selecting a particular theme
that styles all menus and dialog boxes.
In addition, you can style your reports
and charts with a distinctive document
theme.

WebFOCUS InfoAssist User's Manual

Topics:

4 Accessing InfoAssist

4 Accessing Personal InfoAssist
4 Accessing InfoAssist Basic

4 Accessing InfoMini

-1 Creating a New Procedure

4 Accessing InfoAssist Options
J

Changing User Preferences
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Accessing InfoAssist

To access InfoAssist, type valid credentials in the User Name and Password text fields and
click Sign In. The WebFOCUS Sign In page is shown in the following image.

WebFOCUS

Language Public Access Enable Accessibility Help

WebFOCUS Sign In: Visit the WebFOCUS website:

User Name: * Get a product overview

= See a list of product advantages and features

= Find out how to get product support.
Password:

‘ | Questions? Need Help? Our online help website has the
- answers:

‘ SignIn | | Reset | | e — * Obtain information on the latest product updates

= Get tips, technigues, and best practices from the forum

Accessing Personal InfoAssist
To access Personal InfoAssist, type the following URL in a web browser.
http://host name[ : port]/wf_cont ext_root/ M/l Al ?I Bl C server=server][ & Bl APP_app=app]
where:

host nane[: port]
Is the name of the host where the WebFOCUS application is deployed. Specify the optional
port number only if you are not using the default port number.

wf _cont ext _root
Is the site-customized context root for the WebFOCUS application deployed on your
application server. The default value is ibi_apps.

server
Is the optional Reporting Server to use.
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app
Is the optional application path name to search.

Accessing InfoAssist Basic

To access InfoAssist Basic, type valid credentials in the WebFOCUS Sign In page and click
Sign In. InfoAssist Basic has a unique license code that distinguishes it from the complete
version of InfoAssist.

Accessing InfoMini

You have the option to activate InfoMini when you create a report in InfoAssist. When you
run a report with InfoMini activated, an InfoMini application is launched. An InfoMini
application contains a subset of the functionality available to a full InfoAssist report. You
can limit or expand the functionality that is available to the user at run time when you build
the report in InfoAssist.

An InfoMini application opens in its own browser window if it is running from InfoAssist.
Otherwise, InfoMini opens wherever you have it, such as a container in the Business
Intelligence (Bl) Portal.

Creating a New Procedure

After you have signed in to Bl Portal, you can work with an existing folder, or create a new

folder in the tree to store your reports, charts, dashboards, and documents. Once you have
identified the folder you want to use, right-click it, point to New and then click Report, Chart,
Dashboard, or Document to open InfoAssist. The Select a data source dialog box opens.

Select the data source that you want and click OK to close the dialog box. You can also
double-click a data source to open it and close the dialog box in one step. If the data source
that you want is not in the default directory, select a different directory using the Look in
drop-down list.

Once you select your data source, the InfoAssist application window opens.
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Accessing InfoAssist Options

In this section:
Getting Started
Help

On the InfoAssist application window, click the Application button to open the InfoAssist
application main menu of procedure-related commands. When you click New a splash screen
that contains all available options opens. The splash screen is shown in the following image.

The available options are grouped into Getting Started and Help.

InfoAssist

YWehF O ion 8.0

Getting Started Help
k| Build a Report #| InfoAssist Help
k| Build a Chart ¥ Online Forum

w

Build a Document

v

Open Existing ltem

L

Change Default Options

k| Close Application

Note: When you launch InfoAssist Basic, this splash screen indicates that the application
is InfoAssist Basic and displays the available options.

Getting Started

The following Getting Started options are available in InfoAssist:

'd Build a Report. Opens the Select a data source dialog box, where you can select a data
source for your report.

24 WebFOCUS



2. Getting Started With InfoAssist |

-1 Build a Chart. Opens the Select a data source dialog box, where you can select a data
source for your chart.

-1 Build a Document. Opens the Select a data source dialog box, where you can select a
data source for your document.

41 Open Existing ltem. Opens the Open dialog box, where you can select an existing item.

41 Change Default Options. Opens the Options window, where you can change the default
settings to reflect your preferences. For more information, see Changing User Preferences
on page 25

1 Close Application. Closes and exits the application.

Help

The Help options provide help for the new user. The following Help options are available
when you open InfoAssist.

4 InfoAssist Help. Opens the online documentation window for InfoAssist.

-4 Online Forum. Opens the Focal Point website in a new browser window.

Changing User Preferences

In this section:
Startup Options
Layout

View

Format

Environment and Styling

You can change the default user preferences to customize the way that InfoAssist behaves
when you create reports and generate output. You can customize the InfoAssist interface,
including all menus and dialog boxes, by selecting an application theme that applies the
styling that you want.

Additionally, you can style your reports by selecting a document theme independent from
the interface. On the InfoAssist application main menu, click Options, or on the InfoAssist
Options dialog box, click Change Default Options.
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The Options window, as shown in the following image, opens to provide you with a user-

friendly interface for customizing the InfoAssist application.

Customize your InfoAssist environment

M ul Layout
Page Size | Letter |Z|
| El Orientation | Fortrait |Z|
—I\a"le_wl M Format
Design View | Live Preview E| Report output type | HTML E'
Preview Method | Preview with Source Data El Chart output type | HTML IZ|
Record Limit | 500 IZ| Document output type | FOF |Z|
Data Panel | Logical El
Query Panel | Tree IZ|
Output Target | Mew Tab IZ|
rEnviranment and Styling
Application Theme | Portal - Information Builders |E|
Document Theme

|ENBIue_Medium1. sty

| | Browse

i T
Cancel

If any of the options are unavailable, contact your administrator for assistance.

You can also select a document styling theme through the ribbon. Go to the Home tab, then
in the Report group, click Theme. For more information, see Home Tab on page 39.

Startup Options

Note: The Startup Options are disabled because in WebFOCUS 8 you can choose the mode

of InfoAssist directly from the Resource Tree in the Bl Portal.

Layout

The Layout area provides settings for printing reports and charts.

1 Page Size. Values are A4, A3, A5, Letter, Tabloid, and Legal. The default value is Letter.

1 Orientation. Values are Portrait and Landscape. The default value is Portrait.
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View

The View area provides settings for establishing the design view in which you will work, the
type of data you will use when you preview your output, the limit you need to set on your
record input, how your data and query panels will look, and the output target that you will
use.

1 Design View. Values are Interactive and Query. Select Interactive to activate the Preview
Method drop-down menu. The default value is Interactive.

4 Preview Method. Values are Preview with Source Data and Preview with Sample Data.
This menu becomes active when you select Interactive from the Design View drop-down
menu. The default value is Preview with Source Data.

4 Record Limit. Values are All records, 1, 10, 50, 500, or you can type a numeric value
directly in the menu. The default value is 500.

41 Data Panel. Values are Logical, List, and Structured. The default value is Logical.

4 Query Panel. Values are 2x2 (2 columns by 2 rows), 1x4 (1 column by 4 rows), and
Tree. The default value is Tree.

1 Output Target. Values are Single Tab, New Tab, Single Window, and New Window. The
default value is Single Tab.
Format
The Format area provides settings for the output types for reports, charts, and documents.

4 Report output type. Values are HTML, PDF, PowerPoint, Excel 2007, Excel, active
report, active Flash, and active PDF. The default value is HTML.

1 Chart output type. Values are HTML, HTML5, PDF, PowerPoint, Excel, active report,
active Flash, and active PDF. The default value is HTML.

4 Document output type. Values are HTML, PDF, PowerPoint, Excel, active report, active
Flash, and active PDF (for documents containing only reports). The default value is PDF.
Environment and Styling

The Environment and Styling area provides Application Theme settings to apply styling to all
InfoAssist interfaces, menus, and dialog boxes. It also provides settings to apply styling to
reports and charts.

-1 Application Theme. Select an Application Theme, for example, Graphite or High Contrast,
to apply styling to all interfaces, menus, and dialog boxes.

4 Document Theme. Select a Document Theme to apply styling to reports and charts.
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You can use the default style sheet or select from a list of available themes. Click the
Browse button to open the Templates - Browse predefined template files dialog box in
which you can search for an existing WebFOCUS StyleSheet.
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Navigating the InfoAssist Interface

InfoAssist provides an intelligent, flexible layout for creating reports, charts, dashboards, and documents.

The application window provides intuitive menus and toolbars, a versatile ribbon that provides access to
specialized groups for different functional areas of report design, a taskbar for selecting output, and a

status bar for directing output.

The application window also provides a resources area for selecting and sorting data, and a multi-faceted
results area that can display report design, a preview of report output, or actual report output.

Topics:

4 InfoAssist Application Window
4 Application Main Menu

4 Quick Access Toolbar

-1 Ribbon

4 Home Tab

4 Insert Tab

4 Format Tab

4 Data Tab

WebFOCUS InfoAssist User's Manual

Slicers Tab

Layout Tab

View Tab

Field Tab

Series Tab

Understanding the Resources Panel
Understanding the Results Panel
Using the Navigation Taskbar

Using the Status Bar

29
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InfoAssist Application Window

30

The components of the InfoAssist Application window are shown in the following image.

The InfoAssist main interface components are annotated as follows:

1.

Application button. Provides access to the application menu of procedure-related
commands.

. Quick Access Toolbar. Displays frequently-used commands, such as New, Open, Save,

Undo, Redo, View code, Run, and Preview, in a toolbar that remains visible. For more
information, see Quick Access Toolbar on page 35.

. Ribbon. Displays the commands you need to create reports, charts, and documents. It

also displays the Help menu. For details, see Ribbon on page 36.

. Help. Provides access to the online documentation window for InfoAssist and the Focal

Point website in a new browser window.

. Resources panel. Displays the fields from the selected data source in the Data pane.

Also displays the Query Design pane below the Data pane, except in Query Design view.
For more information, see Understanding the Resources Panel on page 99.

. Results panel. Displays the Query Design pane, Layout canvas, or Output window.
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4 The Query Design pane appears when you select Query Design view.

4 The Layout canvas appears in Live Preview mode when you create or modify a report.
In Live Preview mode, the Results panel displays a preview of the report as you create
the report.

4 The Output window appears when you execute a report.
For more information, see Understanding the Resources Panel on page 99.

7. Navigation taskbar. Displays groups and icons that provide different views and quick
access to all active reports and report output. For details, see Using the Navigation
Taskbar on page 131.

8. Status bar. Provides an output format button that you click to see the selected format
and an output target button that you click to view the selected option for displaying new
output windows or tabs. For more information, see Using the Status Bar on page 133.

Application Main Menu
1A)

In the upper-left corner of the InfoAssist interface, click the 1A button to open the

Application main menu, as shown in the following image.

J - Recent Items

all Chartl

Documentl

=| Reportl
Save
B Save As
%’} Run

} Run Deferred

u Close
- Wopios X Ext |

You can run the following commands from the Application main menu:

)

v
E
WRE
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4 New. Creates a new report, chart, dashboard, or document. The exact functionality of
the New command depends on your current InfoAssist session.

If you open a Reporting Object through InfoAssist, and then click New, a new report is
generated from the Reporting Object. You are prompted to choose the type of report you
want to create from the Reporting Object.

When you open a new session of InfoAssist and then click New, a new report is created.
You are prompted to choose a data source, as shown in the following image.

Select a data source O x

Look in: |E| Reparting Server IEI & El-
Mame |Type |Appliation MName | &
& BROKERS WebFOCUS ibisamp
@ cn WebFOCUS ibisamp e
@ caroLap WebFOCUS ibisamp
& castrLOw WebFOCUS ibisamp 5
& course WebFOCUS ibisamp
é DMLOCS Fixed-format sequential ibisamp
é DMSTARTERM Fixed-format sequential ibisamp
& DMvPy WebFOCUS ibisamp
& EDUCFILE WebFOCUS ibisamp
& EMPDATA WehFOCUS ibisamp
& evrLOYE2 WebFOCUS ibisamp
& evPLOYEE WebFOCUS ibisamp

ﬁ ETl EMRTD Fivad.farmat caniiantizl ihizrnm -
File name: |
Files of type: El

L o v oJ o

Open. Opens an existing item.

Save. Saves a report, chart, dashboard, or document.

background while you continue to work on other tasks.

Run. Runs a report, chart, dashboard, or document immediately.

Save As. Saves a report, chart, dashboard, or document with a new name.

Run Deferred. Submits a report, chart, dashboard, or document for processing in the

4 Close. Closes the currently active report, chart, dashboard, or document.
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4 Recent Items. Displays recent reports, charts, dashboards, and documents and those
items that have been pinned to the menu. The Recent Iltems area of the InfoAssist
Application main menu is shown in the following image.

J - Recent Items

B Save As

3 Run
} Fun Deferred

u Close
- Wopons X Bk

Pinned reports, charts, dashboards, and documents are represented by a blue pin ¢
icon. Pinned items appear at the top of the list in alphabetical order.

Recent reports, charts, dashboards, and documents are represented by a sideways blue

pin —® jcon. Recent items appear below the separator bar in the order in which they
were created, with the most recently created item at the top.

You can pin important reports, charts, dashboards, and documents to the top of the
Recent Reports section of the Application main menu for quick and easy access. To
promote a recent report to pinned report, click the sideways blue pin icon. The icon turns

upright and the report is moved to the pinned report area of the Recent Items window,
where it stays until it is unpinned.

To demote a pinned report, click the blue pin icon. The icon turns sideways and the report
is moved below the separator bar.
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Reports also have a context menu that you can access by right-clicking a report in the
Recent Iltems section of the Application main menu. The menu is shown in the following
image.

Recent Items

all Chartl P

E] Documentl -
@ Open

#  Pintolist

£ Remove from list

" Clear unpinned list

The options in the menu are:
4 Open. Opens the selected report, chart, dashboard, or document.

4 Pin to list. Pins a recent report, chart, dashboard, or document to the pinned reports
list above the separator bar.

(]

Remove from list. Unpins a pinned report, chart, dashboard, or document from the
pinned reports list.

U

Clear unpinned list. Clears all reports, charts, dashboards, or documents from the
Recent Items list.

1 Options. Opens the Options window to customize your user preferences. For more
information, see Changing User Preferences on page 25.

4 Exit. Exits the application.
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Quick Access Toolbar

The Quick Access Toolbar, as shown in the following image, provides access to the most
commonly used functions. It is located to the right of the Application main menu button and
is always visible no matter which options are selected. In addition to the New, Open, Save,
and Run commands discussed in Application Main Menu on page 31, you can access the
Undo, Redo, and View code commands. The Quick Access Toolbar contains a Run menu of
commands. In addition to the Run command, the Run menu contains the Preview, SQL Trace,
and SQL Preview Trace commands.

_E.i ﬂ‘ Run

<4 Undo and Redo. The Undo i icon undoes your last action. The Redo & icon repeats
your last action.

The Undo icon is enabled (blue) when there is an action to undo. Otherwise, the icon is
unavailable (gray). The Redo icon is enabled (blue) when there is an action to redo.
Otherwise, the icon is unavailable (gray).

For example, assume that your first action when creating a report is to add a database
field to the report. After you add the database field, the Undo icon turns blue. You can
now click the Undo icon to remove the database field from the report. The Undo icon
turns gray, and the Redo icon turns blue. To restore the field to the report, click the blue
Redo icon.

You can also press Ctrl+Z to undo an action, or Ctrl+Y to redo an action.

You can undo and redo up to 25 actions per session. InfoAssist maintains the undo and
redo list of actions even when you switch between reports.

When a dialog box is open in the application window, you cannot use the Undo and Redo
icons. However, when you click OK and close the dialog box, the icons become available
for use. With a single click of Undo, you can undo all the actions that you performed in
the dialog box, and you can reinstate them with a single click of Redo.

4 View code. View the underlying code for the report.

<4 Run. Click the Run button to run a report, chart, dashboard, or document immediately.
Click the down arrow to open the Run menu, which contains the following additional
options:

4 Preview. Runs the report, chart, dashboard, or document in the selected format with
the limited number of records as set in the Design group on the Home tab. For more
information, see Design Group on page 41.

4 SQL Trace. Returns the SQL commands for the request.
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1 SQL Preview Trace. Returns the SQL commands for the Live Preview run.

Ribbon

The ribbon is a rectangular area of distinct groups of buttons that spans the top of the
InfoAssist application window. The ribbon, with the Home tab selected, is shown in the
following image.

icers Layout View Fizld

The ribbon is made up of nine tabs. Each tab contains a subset of InfoAssist functionality
organized in logically-related groups of controls and commands graphically represented by
distinctive icons.

The tabs are:
Home
Insert
Format
Data
Slicers
Layout
View

Field

£ U v U v oJ v od o

Series (when creating a chart)
The Home tab is selected by default when you first open InfoAssist.

When you select a tab, the tab opens a particular view of the ribbon by exposing groups of
controls and commands related to the task that you are performing.
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The ribbon contains two types of arrow-based buttons. The first type of button opens a menu
when you click it. The Orientation button on the Layout tab, in the Page Setup group, is an
example of this type of button. Clicking the Orientation button opens a menu of options, as
shown in the following image.

*  Portrait

Landscape

The second type of button is a split button. Clicking the left side of the split button performs
a default action. Clicking the down arrow on the right side of the button opens a menu of
options. The Header & Footer button on the Home tab, in the Report group, is an example
of a split button. It is shown in the following image.

Clicking the Header & Footer button on the left opens the Header & Footer dialog box, shown
in the following image.

%Header &t Footer
Feport Header

Trebuchet M5 =

Enter text here

“Cancel | i Apply
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Clicking the down arrow on the right opens a menu of options shown in the following image.

Report Header

Page Header
Page Fooker
Feport Fooker

Some options open dialog boxes of additional commands and option lists.

The ribbon displays all controls and commands using different sized icons and groups,
depending on the size of the monitor and application window. In the following example, the
Features group is fully expanded and all its icons are visible.

et FOrmal Data  Sicers Layout View  Fisld

53 A W
v  Excel Infol

PowerPaint

When you reduce the size of the application window, some groups are collapsed into single
icons as determined by the amount of available space. The following image shows the
Features group, from the Format tab, collapsed into a single icon.

When a group is collapsed into a single icon, the individual icons are removed from view,
but are still available. Clicking a collapsed group icon restores the group to its normal full
size and displays all of the individual icons.

When expanding a collapsed group, the ribbon collapses a neighboring group to make enough
room to expand the selected group.

When an icon, button, or option in a menu or dialog box appears dimmed, that functionality
is not available for that report as it currently exists. Some functionality is available for reports
only, charts only, or documents only.

In some situations, selecting one or more options makes other options incompatible with
the previously selected ones. As a result, the incompatible options are dimmed and
unavailable for selection. InfoAssist automatically makes incompatible options unavailable
as you create and modify a report.
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The following image shows an example of an option that is unavailable because it is not
compatible with the selected output type. In the example, PDF has been selected on the
Format tab, in the Feature group, as the output type for the report. You cannot create an
Accordion report with a PDF output, therefore, the Accordion button appears dimmed and is
unavailable.

Lull]4 Destination  Mawvigation Title
Types

e
Ponun

Note: If you do not have access to a particular option, contact your administrator.

Home Tab

In this section:
Format Group

Design Group

Filter Group

Report Group

Report Style Dialog Box
Color Dialog Box

The Home tab contains the most commonly used commands and options from the Format,
Design, Filter, and Report groups. It is shown in the following image.

Format Group

The Format group displays a menu of output formats and buttons to toggle between creating
a report (default) or a chart. It also contains a menu from which you can create an image
file from a chart.

4 Current Output Format. Displays a drop-down menu of all supported output formats.
4 HTML (the default for charts and reports)
4 HTML5 (only available for charts)
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4 active report (default for dashboards)

- active Flash

4 PDF (the default for documents)

- active PDF

4 Excel 2007 (reports designed in Live Preview and Query Design views only)

- Excel

4 Excel Formula (reports designed in Live Preview and Query Design views only)
4 Excel Pivot (reports designed in Live Preview and Query Design views only)

4 PowerPoint

When you run a report, the output is created in the format that is currently selected. You
can also select output format options on the Format tab, in the Output Types group, and
on the status bar, from the output format drop-down menu.

Note: If you are running InfoAssist Basic, your output format options are limited.
PowerPoint and active PDF are not supported for charts and reports. PDF, Excel, active
report, and active Flash are not supported for charts.

Report or Chart. Determines whether report-specific or chart-specific functionality is
available in the InfoAssist tool. The default name ReportX or ChartY is given for each new
report or chart created in a given InfoAssist session. X and Y are numbers that start at
1 and increase by 1 for each report or chart created. For more information on switching
between multiple reports, see View Tab on page 78.

When Chart is selected, as shown in the following image, you are able to access the File
menu in the Format group. However, if you select Report, the File menu is unavailable.

3" A _!,:ij Chart
J b |§j Report
HTML P

; File -

Format

File. Creates an image file from a chart. In order to create the image file, you need to
execute the procedure. When the File menu is selected, or if you click Select a location
and format from the drop-down menu, you are able to name the file and select the output
type. The available output types are PNG, GIF, SVG, and JPEG. Once the File menu is
selected, output type selection is unavailable. If you do want to disable the File menu,
click the File menu again.
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Note: The File menu is not available in InfoAssist Basic.

Design Group

The Design group contains commands to select the design mode for creating reports, and
design preview options for accessing data. The Design group is shown in the following
image.

& Data from Source

B us Sample Data

Crocurment Records: =

Design
The design preview options are:

1 Query (Design view). Displays the Query Design pane in the Results panel. The Query
Design pane provides a large work area for creating the report.

1 Live Preview (Design view). Displays the report in the Results panel as you create the
report. You can use the Live Preview to add, remove, and arrange fields, as well as style
the report.

Note: This is not available in InfoAssist Basic.

d Document (Design view). Opens the document on the Layout canvas in the Results
panel. You use the Layout canvas to add text, images, lines, reports, and charts to create
dashboards and documents. For more information about Document view, see Accessing
Document View on page 356.

Note: This is not available in InfoAssist Basic.
The design options are:

1 Data from Source. Uses the selected data source to display a live preview of the output
in the Results panel.

4 Use Sample Data. Displays sample data, which reduces processing time by eliminating
the need to access the actual data source.

1 Records. Limits the number of rows retrieved from the data source when Live Preview
is selected. This feature is useful in reducing response time if you are working with a
large amount of data. Type the number of rows that you want directly in the Records field,
or use the drop-down menu to select one of the preset record limits. The preset choices
are All rows, 1, 10, 50, 100, 500, 1000, 2000, 5000, and 10000.
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Note: In Live Preview, an exclamation point is placed next to fields that are too large to
be displayed within the space allotted. The allotted space is determined by the page-level
styling. Page-level styling includes page size, orientation, margins, and font size.

There is no way to define a limit for the number of characters that will fit on a page. This
limit varies by the selected page and font styling. The bigger the page size and smaller
the font, the more characters that can fit.

Filter Group

The Filter group contains commands for creating filters. It is shown in the following image.

II ¥ Exdude
Filter .
Filter

The commands are:

< Filter. Opens the Filter dialog box for creating filters. Filters enable you to select only
the data that you want and to exclude unwanted data.

In the Filter dialog box, you can create simple filters using the Values, Prompt, and
Relational Operators menus. For more information, see Field Tab on page 85. For more
information on creating advanced filters, see Data Tab on page 62.

4 Exclude. Turns off a filter.

< Include. Turns on a filter.

Report Group

42

The Report group contains commands to enhance a report including Theme, Style, Banded
(reports only), Header & Footer, Column Totals (reports only), and Row Totals (reports only),
as shown in the following image.

q. ,n,',f E;_.] E% = Column Totals
|~ - == Ql& ~ E¥Row Totals
Theme  Style Banded Header &

Footer

Report

g

4 Theme. Opens a dialog box where you can select a theme to style your report or chart.
You can use the default stylesheet by clicking the Use Default Stylesheet button.
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You can also select a document styling theme or an application theme to style all reports
created in InfoAssist. Use the Environment and Styling section of the Options window,
which is accessible by clicking Options in the Application main menu.

4 Style. Opens a Report Style dialog box for applying global styling to the entire report.
For more information about the Report Style dialog box, see Report Style Dialog Box on
page 45. For more information about styling reports, see Styling Reports on page 139.

<4 Banded. Opens a Color dialog box for choosing a color that provides an alternating color
scheme for the report. The report output displays alternating rows of data, using a white
background for one row and a background of the selected color for the next row. This
pattern continues throughout the report. For more information about the Color dialog box,
see Color Dialog Box on page 46. For more information about banded styling, see How
to Style Rows of Data With Alternating Colors in a Report on page 148.

4 Header & Footer. Opens the Header & Footer dialog box, from which you can add and
style headings and footings.

' For a report, you can add and style report headings, page headings, page footings,
and report footings. In the dialog box, the tab for Report Header is active by default.

4 For achart, you can add and style page headings and page footings. For a chart, Page
Header is active by default.

< You can drag fields from the Data pane into the Header & Footer dialog box.
The following image shows the Header & Footer dialog box with Report Header active.
. E4Header & Footer o x

E:t] Report Header % Page Header % Page Footer %] Report Footer

=

TrebuchetMs |~ 14|w| B | F U

it

Enter text here‘

" OK “Reset S cancel | R apply

WebFOCUS InfoAssist User's Manual 43



Home Tab

a4

Another way to access the Header & Footer dialog box is to click the down arrow next to
the Header & Footer button. It opens a drop-down menu from which you can select the
heading or footing that you want to work with (Report Header, Page Header, Page Footer,
Report Footer). After you make your selection, the Header & Footer dialog box opens,
and the heading or footing that you selected is active.

From the Header & Footer dialog box, you can add and style the active heading or footing,
or choose a different heading and footing to work with by selecting the applicable tab.
You can switch among tabs, but InfoAssist does not save changes made on the tabs
until you click Apply or OK. If you click Apply, the Header & Footer dialog box remains
open. If you click OK, the dialog box closes.

You can style a selected heading or footing using the options on the styling toolbar. From
left to right, you can customize the font type, font size, and font style (bold, italic, or
underline). You can justify text (left, center, or right), select the font color and background
color, and restore styling settings to their default value from the template.

You can also insert quick text into a heading or footing. Quick text is supplied for you. It
includes information that is typically useful in identifying a report or chart. From the
preformatted text drop-down menu, you can select:

4 Draft

4 Page X of Y

4 Confidential

4 Date (multiple formats)
4 Time (multiple formats)

4 Created by (followed by a name)

For charts, an icon |I“ T on the far right of the styling ribbon is enabled. This icon
provides two options for controlling the way in which the page heading and page footing
are rendered. The default option, Create Header and Footer as Text, renders the heading
and footing as text elements that are separate from the chart image. The option, Embed
Header and Footer in the Chart, renders the heading and footing text as part of the chart
image.

Once you have added a heading or footing to a report or chart, you can double-click it on
the canvas in design mode to reopen the Header & Footer dialog box. You can also right-
click an existing heading or footing in design mode and click Edit from the menu to open
the dialog box.

For more information on adding and styling headings and footings, see How to Add
Headings and Footings to a Report on page 145 and Formatting Page Headings and Page
Footings on page 342.
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4 Column Totals. (Reports only) Adds a grand total row to the bottom of the report to sum

numeric data in each column. For more information, see How to Add Column Totals to a
Report on page 163.

4 Row Totals. (Reports only) Adds a grand total column to the right side of the report to
sum numeric data in each row. For more information, see How to Add Row Totals to a
Report on page 164.
Report Style Dialog Box
The Report Style dialog box, shown in the following image, provides options to style your
report.
_f‘a Report Style ¥
Trebuchet M5 - 9 - I"xﬁ
B/ U|lE== B& sl =&
— Preview

Trebuchet M5 9

o« OK (8 Cancel | & Apply !

The Report dialog box options are:

-

d

-

Font. Use the drop-down menu to change the font.
Font size. Use the drop-down menu to change the numeric value for the font size.
Font style. Click the appropriate button (bold, italic, underline) to style the selected text.

Text alignment. Click the appropriate button (left, center, right) to align the selected
text.

Font color. Click the button to open the Color dialog box, where you can select the font
color. For more information, see Color Dialog Box on page 46.

Background. Click the button to open the Color dialog box, where you can select the
background color for the report.

Font color. Click the button to open the Color dialog box, where you can select the font
color.
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d Currency symbol. Click the button to access the following currency symbols US dollar,
British Pound, Japanese Yen, Euro, New Israeli Shekel. Note: The New Israeli Shekel
currency symbol can be displayed with the following settings only:

1 Server codepage = 1255, 65001, 424, or 65002.
4 Client codepage = 1255 or 65001.
1 Application server encoding = Cp1255 or UTFS8.

1 Font name = Lucida Sans Unicode or Arial Unicode MS.

1 Reset to template style. Click the button to reset all settings to the default settings
from the template. Note: Reset only works while the Report Style dialog box is open.
Once you click OK, all changes are committed. To undo global styling after it has been
committed, you must use the Undo command on the Quick Access Toolbar.

Color Dialog Box

The Color dialog box, shown in the following image, provides options for working with color

in your report.

Color
|
I
HEON NN
e
HEENEN
HE NN
Hue: 0= Red:
Sat: ] Green:
Lum: 100 ° Blue:
Selected Color:

[] Transparent

The Color dialog box options are:

25

(52}

255

255

L[

Cance

1 Standard Color Swatches. Provides a set of 48 predefined colors from which to choose
on the left side of the dialog box. Your selection appears in the Selected Color field.

46

WebFOCUS



3. Navigating the InfoAssist Interface I

1 Custom Color Palette. Provides a palette on the right side of the dialog box to define
a custom color. Your selection appears in the Selected Color field.

-1 Luminosity bar. Drag the slider to change the luminosity (relative lightness or darkness)
of a color. The corresponding numerical value appears in Lum.

4 Hue. Indicates the hue value of your selected color. You can enter a value, or increase
or decrease the hue value by using the up and down arrows, respectively.

41 Sat. Indicates the saturation value of your selected color. You can enter a value, or
increase or decrease the saturation value by using the up and down arrows, respectively.

4 Lum. Indicates the luminosity (lightness or darkness) of your selected color. You can
enter a value, or increase or decrease the luminosity value by using the up and down
arrows, respectively.

4 Red. Represents the numeric value of red (O to 255).

1 Green. Represents the numeric value of green (0 to 255).
4 Blue. Represents the numeric value of blue (0 to 255).

4 Selected Color. Displays the color that you selected.

41 Transparent. Makes the color transparent.

Insert Tab

In this section:
Reports Group
Objects Group

Active Technologies Dashboard Prompts Group

The Insert tab contains options to add reports, charts, existing reports, text, images, and
active form controls (for active report, active PDF, and active Flash outputs only) to a canvas
in Document view. It is shown in the following image.

sl 2 Yo D B o I @

Report Chart Existing Text Image Drop List Checkbox Radio Text
Report Box Down Button
Reports Objects Active Dashboard Prompts
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The Insert tab is only available in Document view. It is not available in Query Design view or
in Live Preview, as shown in the following image.

DDH ﬂw% = Run

Home Format Data Slicers Layout View

Reports Group

The Reports Group contains commands to insert reports, charts, and existing reports into
your document. You can add multiple reports and charts to a single canvas with these
buttons. The Reports group is shown in the following image.

all &4
Repart Chart Existing
Report

Reports

d Report. Inserts a report placeholder on the canvas.

4 Chart. Inserts a chart placeholder on the canvas.

4 Existing Report. Opens an Open dialog box where you can browse to the report that
you want to insert in the upper-left corner of the canvas.

Objects Group

The Objects group contains commands to insert text and images into your document. The
Objects group is shown in the following image.

[a) =

Text Image

Objects

4 Text. Inserts an inline text object in the upper-left corner of the canvas.

4 Image. Opens an Open dialog box where you can browse to the image that you want to
insert in the upper-left corner of the canvas.
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Active Technologies Dashboard Prompts Group

The active dashboard prompts group contains commands to insert active form controls into
your document. You can add multiple controls to a single canvas with these buttons. This

group is only visible when the output format of the document is set to active report, active
PDF, or active Flash. The active dashboard prompts group is shown in the following image.

d

;_“lggr@h

Drop List Checkbox Radio
Down Button

Active Dashboard Prompts
Drop Down. Inserts a drop-down control placeholder in the upper-left corner of the canvas.
List. Inserts a list control placeholder in the upper-left corner of the canvas.
Checkbox. Inserts a check box control placeholder in the upper-left corner of the canvas.

Radio Button. Inserts a radio button control placeholder in the upper-left corner of the
canvas.

Text. Inserts a text area control placeholder in the upper-left corner of the canvas.

For more information on inserting active form controls, see Creating an Active Technologies
Dashboard on page 408.

WebFOCUS InfoAssist User's Manual 49



Format Tab

Format Tab

50

The Format tab contains different options for selecting output formats and other reporting
features, depending on whether you are creating a report or a chart. For reports, the Format
tab provides access to the Output Types, Destination, Navigation, and Features groups. It
is shown in the following image.

For charts, the Format tab provides access to the Output Types, Destination, Chart Types,
Features, and Labels groups, as shown in the following image.
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Output Types Group

In this section:
HTML5
Enabling Additional Output Types

The Output Types group contains commands to create output in any of the supported formats
listed in the following table. When you run a report, the output is created in the format that
is currently selected. You can also set output format options by going to the Home tab, and
in the Format group, selecting from the menu of output options. In addition, you can select
an output from the output format button in the status bar. For more information on the
additional Excel formats available for reports, see Report Outputs on page 138.

Format Reports Charts Dashboards and
Documents
HTML Available Available Available
(default) (default)
HTML5 Not Available Available Not Available
active Report Available Available Available

(dashboard default)

active Flash Available Available Available

PDF Available Available Available
(document default)

active PDF Available Available Available
(requires Adobe®
Reader® 9.0 or

later)

Excel formats Not Available Available Available
PowerPoint Available Available Available
PDF/GIF Not Available Available Not Available

(must be set to
display in InfoAssist
Properties)
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Format

Reports Charts

Dashboards and
Documents

PNG

(must be set to
display in InfoAssist
Properties)

Not Available Available

Not Available

GIF

(must be set to
display in InfoAssist
Properties)

Not Available Available

Not Available

JPEG

(must be set to
display in InfoAssist
Properties)

Not Available Available

Not Available

SVG

(must be set to
display in InfoAssist
Properties)

Not Available Available

Not Available

The following image shows the Output Types group for reports.

™ =k

HTML HTHILS

3" 2

HTML HTMLS

Ockive Ezxccel
POF

Cukpuk Types

PowerPoint

PowerPoirt
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The following image shows the Output Types group for documents.

;: E’ . '3 PDF FEI ﬂ :

HTML HTFLS  Active  Active PDF Active  Excel PaowerPoint
't Flash POF

Cukpuk Types

HTML5

The HTML5 output format allows you to render a chart in the browser using a built-in JavaScript
engine. Charts with this output format utilize the very latest capabilities of the HTML5 web
standard, including animation, high-quality vector output and attractive alpha-channel and
gradient effects.

=R

ST

Enabling Additional Output Types

The output types of PNG, GIF, JPEG and SVG do not appear in the Output Types group by
default. You can enable them by opening the WebFOCUS Administration Console, selecting
Utilities, and then InfoAssist Properties.

If these formats are not enabled and you try to open an existing procedure with PNG, then
HTML becomes the output. In addition, the following warning messages could open:

' When opening an existing procedure with JPEG, GIF, or SVG, a warning message opens
indicating that the request is not allowed with the current configuration and that the
procedure will be converted to HTML output.

' When opening an existing procedure with PDF or GIF, a warning message opens stating
that the request is not allowed with the current configuration and that the procedure will
be converted to PDF output.

When you run a report, the output is created in the format that is currently selected. You
can also set output format options from the output format button in the status bar.
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The following image shows the Output Types group with all output formats for charts enabled.

Eﬁ JE ) a ) X 6]

Active PowerPaint
Report  Flash PDF

Output Types

Destination Group

The Destination group contains commands to create a report or a chart, change a chart to
an image file, and create an InfoMini application, as shown in the following image.

m’l Chart
- @Repurt

File -

Destination

When a chart is selected, the File button becomes available. Clicking the File button or
selecting Select a location and format from the File drop-down menu, opens the Request
dialog box shown in the following image.

% Request O x
‘:: |:\E_'..E€-: | "

* Temporary Mame Size | Type Last Modified Title

Request

» Ubaseapp
> LJFoomdﬂe
> LJibinocen
» Uibisamp

< [am b € i | b

File name: File1 B | PNG (*.png) Izl

| Save | | Cancel
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In the Request dialog box, you are able to name the file and select the output type. The
available output types are PNG, GIF, SVG, and JPEG. In order to create the image file, you
need to execute the procedure.

Once the File button is clicked, Chart, Report, and InfoMini are disabled, as shown in the
following image. If you want to disable the File button, click the File button again.

!‘,.!: Chart
- Repart
InfoMini -
; Eie i~
Destination

Note: The File button is not available in InfoAssist Basic.

4 InfoMini. Enables the creation of an InfoMini application. For more information on using
InfoMini, see Building InfoMini Applications on page 455.

Note: InfoMini is not available in InfoAssist Basic.

4 Report. Makes report-specific functionality available in InfoAssist. If you switch from
Report to Chart all selected options specific to each type of report are maintained during
the current session until you save the report. When you save a report, chart-specific
options are not maintained.

Note: The Report to Chart, or Chart to Report conversion options are not available in
InfoAssist Basic.

<4 Chart. Makes chart-specific functionality available in InfoAssist. If you switch from Chart
to Report all selected options specific to each type of chart are maintained during the
current session until you save the chart. When you save a chart, report-specific options
are not maintained.

Note: The Report to Chart or Chart to Report conversion options are not available in
InfoAssist Basic.

Navigation Group (Reports Only)

The Navigation group contains commands to customize output display and navigation. They
are Table, Table of Contents, Freeze, Pages On Demand, and Auto Drill & Analysis.
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Note: You can only choose one option from this group. The Navigation group is shown in

the following image.
)

Freeze  Pages On Auto Drill &
Demand Analysis

Mavigation

Table is selected by default and generates standard WebFOCUS browser output.

1 Table of Contents. Generates output by displaying a table of contents icon in the
upper-left corner where report output typically appears. Clicking Table of Contents opens
a menu that enables you to select (view) individual values of the first Sort By (By) field,
one value at a time. You can also select options to view the entire report or remove the
table of contents. For more information, see How to Create Table of Contents Reports on
page 173. The Table of Contents option is activated only when HTML, active report, Excel,
or PowerPoint output format is selected.

Note: You cannot use the Table of Contents with the Accordion feature. For more
information, see How to Create Accordion Reports on page 177.

4 Freeze. Generates output with column titles that freeze (remain in view) when you scroll
through pages of the report output. For more information, see How to Freeze Column
Titles in a Report on page 175.

4 Pages On Demand. Displays one page of output at a time. This option provides a menu
bar at the bottom of the report output where you can choose to view additional pages of
output. For more information, see How to Create Pages On Demand Reports on page 176.
The Pages On Demand option is available only when HTML or active report output format
is selected.

< Auto Drill & Analysis. Generates output which invokes OLAP processing. For more
information, see How to Create OLAP Reports on page 171. The OLAP option is activated
only when HTML output format is selected.
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Features Group (Reports)

The Features group for reports contains commands to select specialized reporting features,
including Title Popup, Accordion, Repeat Sort Value, Stack Measures, active report Options,
and Accessibility. The Features group is shown in the following image.

- =)
Tite Popup  Accordion Repeat Sort Stack Active Report Accessibility
Value Measures Options
Features

4 Title Popup. Displays pop-up titles when the mouse pointer hovers over a column title
in the report output. For more information, see How to Add Pop-Up Titles to a Report on
page 165.

4 Accordion. Creates expandable views of data for each vertical sort field. This option
displays data values only for the first vertical sort field when you first view the output.
You can manually expand your view to expose the data values of lower-level sort fields.
For more information, see How to Create Accordion Reports on page 177.

Note: You cannot use the Table of Contents with the Accordion feature. For more
information, see Navigation Group (Reports Only) on page 55.

1 Repeat Sort Value. Displays all repeated sort values instead of blanks in the output
after the first instance of a new sort value, which is the default behavior.

4 Stack Measures. Displays all numeric measure field names in a column of the report
output with the corresponding numeric data values. For more information, see How to
Implement Stack Measures on page 178.

-1 active report options. Opens the active report options dialog box where you can configure
your active report options such as menu items, graph engine, and colors. For more
information, see Creating an Active Technologies Report on page 392.

4 Accessibility. Allows a title to be added to a report, chart, or document that is Section
508-compliant.

The following table lists the output for which each feature is available. Yes means the output
is available for the feature. No means that the output is not available for the feature.

HTML HTML5 | active active | PDF active | Excel PowerPoint
report Flash PDF

Title Popup

yes no no no no no no no
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HTML HTML5 | active active | PDF active | Excel PowerPoint
report Flash PDF
Accordion yes no yes no no no no no
Repeat Sort Values yes yes yes yes yes yes yes yes
Stack Measures yes no no no no no no no
active report options no no yes yes no yes no no
Accessibility (reports, | yes no no no yes no no no
charts)
Accessibility no no no no yes no no no
(documents)

Features Group (Charts)

The Features group for charts contains commands to select custom chart features, including
3D Effect, Rotate, Reference, Annotate, Grid, Frame & Background, Gauges, active Report
Options, and Accessibility. It is shown in the following image.

-
-y
-

Robate Reference Annotate
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Features

3D Effect. (Default.) Sets the three-dimensional view to on or off. The 3D Effect feature
is disabled for 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel
chart types.

Rotate. Toggles between a vertical display or horizontal display of a chart. For more
information, see How to Rotate a Chart on page 348. The Rotate feature is disabled for
pie, scatter, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel
chart types.

Reference. Opens a drop-down menu that provides the Add Reference Line to Y-axis
and Add Reference Line to X-axis options. Selecting one of these options opens the
appropriate Reference Line dialog box, where you can set the specific X-axis or Y-axis
value, type the text that you want, and position the reference line on a chart. For more
information, see How to Display Reference Lines on page 349. The Reference feature is
disabled for pie, 3D, stock, gauge, gauge thermometer, Pareto, spectral map, and funnel
chart types.

Note: The reference line option is not available in InfoAssist Basic.
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4 Annotate. Opens a drop-down menu that provides the Add an annotation option. Selecting
this option opens the Annotation dialog box, where you can type the text that you want
and position the annotation on a chart. For more information, see How to Display
Annotations on page 352.

Note: The annotation option is not available in HTML5. The annotation option is not
available in InfoAssist Basic.

<4 Grid. Opens a drop-down menu allowing you to expand options for Horizontal or Vertical
Gridlines. Both selections allow you to enable or disable Major and Minor Gridlines.
Clicking More Options opens the Format Grid Lines dialog box. For more information, see
Formatting Gridlines on page 267.

4 Frame & Background. Opens the Frame & Background dialog box where you can edit
the background style and frames for charts. The dialog contains different options
depending on the chart type selected. For more information, see Formatting a Frame and
a Background on page 298.

4 Gauges. Opens the Gauge dialog box where you can edit your gauge chart. This button
is only available when a gauge chart type is selected. For more information, see How to
Style a Gauge Needle on page 339.

Note: Gauge options are not available in InfoAssist Basic.

4 active report Options. Opens the active report options dialog box where you can
configure your active report options, such as menu items, graph engine, and colors. This
button is available when the output type is set to active report, active Flash, or active
PDF.

Note: Annotate is not available in HTML5.

4 Accessibility. Allows a title to be added to a report, chart, or document that is Section
508 compliant. This option is only available for reports and charts when the output type
is HTML or PDF. For documents, the output type must be set to PDF.

Note: The chart features are unavailable when designing a chart that will be output in
active report, active Flash, or active PDF formats.
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The Chart Types group contains the most commonly used chart types, Bar (default), Pie,
Line, Area, and Scatter. You can also click Other to select additional chart types. The Charts
Types group is shown in the following image.

MONHTJ

Pie Line: frea  Scatter  Other

Chart Types

Click Other to open the Other Chart Types dialog box, shown in the following image. Across
the top of the dialog box are tabs which are depicted by icons. Each tab represents a chart
type category. The left-most tab represents the bar chart category, which is selected by
default. When a tab is selected, it displays thumbnail images of the bar chart variations that
are supported by InfoAssist.
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In this example, the Vertical Percent Bar chart type is selected. A description of the selected
chart type is provided beneath the images.

Other Chart Types O x

Y @ € 5 ¢ [ v

0%
E0%

Vertical Percent Bars: A bar version of a pie chart. Each group caloulates the percent of
the total required for each series.

For more information on the chart types that you can choose from, see Selecting a Chart on
page 183.

Labels Group (Charts)

The Labels group for charts contains the Axes and Legend buttons drop-down menus. It is
shown in the following image.

Axes Legend

Labels |
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4 Axes. Opens a drop-down menu, where you can enable, stagger, and rotate horizontal
and vertical axis labels. You can also edit the axis labels by clicking More Horizontal Axis
Options or More Vertical Axis Options. For more information, see Formatting Axis Labels

on page 284.
Note: The Axes option to change data labels position is not available in InfoAssist Basic.

4 Legend. Opens a drop-down menu, where you can select the Show Legend option to
display the legend on the chart, or clear your selection to hide the legend, change the
default legend position, and change the default legend orientation. For more information,

see Format Legend Dialog Box on page 256.

Data Tab

In this section:
Calculation Group
Join Group

Filter Group
Display Group

Data Source Group

The Data tab contains data manipulation and data display options in the Calculation, Join,
Filter, Display, and Data Source groups. It is shown in the following image.

Detail summary Join Advanced Missing Data Add Switch
{Define) {Compute)
Calculation Join Filter Display Data Source

Calculation Group

The Calculation group contains the Detail (Define) and Summary (Compute) commands to
define Define and Compute fields, respectively. It is shown in the following image.

-

Dretail SUMMMAry
(Define) (Compute)
Calculation
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DEFINE fields and COMPUTE fields are two different types of temporary fields. A temporary
field is a field whose value is not stored in the data source, but can be calculated from the
data that is there, or assigned an absolute value. A temporary field takes up no storage
space in the data source, and is created only when needed.

When you create a temporary field, you determine its value by writing an expression. You
can combine fields, constants, and operators in an expression to produce a single value.

You can specify the expression yourself, or you can use one of the many supplied functions
that perform specific calculations or manipulations. In addition, you can use expressions
and functions as building blocks for more complex expressions, as well as use one temporary
field to evaluate another.

A virtual field (DEFINE) is evaluated as each record that meets the selection criteria is retried
from the data source. The result of the expression is treated as though it were a real field
stored in the data source.

A calculated value (COMPUTE) is evaluated after all the data that meets the selection criteria
is retrieved, sorted, and summed. Therefore, the calculation is performed using the
aggregated values of the fields.

4 Detail (Define). Opens the Detail Field (DEFINE) dialog box, where you can create a
defined field, type a name for the field, and enter a format. A Define field is added to the
actual data. The Detail (DEFINE) dialog box is shown in the following image.

¥x| Detail Field (DEFINE) O x
Field | BT || Format ||D12.2 | = -zl E - F 3
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g
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L= Lo J[ - J[v] 5 B Mot (sses)

£ Day,(Sales)
= 3 Time (Shipped)
<4 Summary (Compute). Opens the Summary Field (COMPUTE) dialog box, where you can
create a computed field, type a name for the field, and enter a format.
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The Field dialog boxes, which open when you click Detail or Summary, provide similar
functionality, including options to display data source fields in a Tree, Dimension, or List
view. You can also view a complete set of functions, instead of data source fields, by
clicking the Functions button. The Summary (COMPUTE) dialog box is shown in the following

image.
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Join Group
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The Join group contains the Join button to open the Join dialog box, where you can create
a new join, edit or delete existing joins, and add data sources to a join. The Join group is

shown in the following image.

Note: The Join group is not available when working with Reporting Objects or SAP® Business
Information Warehouse (SAP BW), Oracle Essbase®, or Microsoft® SQL Server® Analysis

Services cubes.
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The following image shows the Join dialog box with two data sources joined by the common
ID_AGE indexed field.
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7 add New M Remove Filker

- WE_RETALL @\ ReTAL AGE T

Mame & Mame
B ID_TIME_SALES > B ID_AGE
B ID_TIME_SHIPPELI=] Bl AGE_RAMGE
B ID_TIME_DELIVEF B AGE_GROUP
B ID_TIME_EDD B AGE
B ID_CUSTOMER
B ID_AGE —
B ID_GEOGRAPHY _
«m 3 «m 3

Using conditional joins, you can establish joins based on conditions other than equality
between fields. In addition, the host and cross-referenced join fields do not have to contain
matching formats, and the cross-referenced field does not have to be indexed.

Note: You can edit the description of a Join by clicking Edit in the Join dialog box and typing
in the Description section. You can only use letters, numbers, and underscores in your
description. No special characters are allowed.

The conditional join is supported for FOCUS and all relational data adapters. Because each
data source differs in its ability to handle complex conditional criteria, the optimization of
the WHERE syntax differs depending on the specific data sources involved in the join and
the complexity of the conditional criteria.
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For FOCUS data sources, if the host and cross-referenced join fields do not have common
matching formats, the following message appears.

Where-Based (Join

P The total length of host fields format
\“"\r’; should match the length of target

field format!
Do you want to create a Where-Based
Jain?

Yes Mo

Note: If you click Yes, the Advanced Filter dialog box opens, where you can create a Where-
Based Join.

If the cross-referenced join field does not have an index, the following message appears.

\tgere-Based Join

9 Target field is not indexed!

\‘_#
Do you want to create a Where-Based
Join?
Yes Mo

Note: If you click Yes, the Advanced Filter dialog box opens, where you can create a Where-
Based Join.
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To create a Where-Based Join, create a filtering condition, as shown in the following image.

_‘. Create a filtering condition O x

= ¥ WHERE
WF_RETAIL.DIM_CUSTOMER.ID_AGE Equal to WF_RETAIL_AGE.DIM_AGE.ID_AGE
= ¥ WHERE

WF_RETAIL_AGE

Mame Title Alias e
B REGION Region |REGI™
B STATECODE State,... | STAT
B CITY City CITY

0 PRODUCT_CATEG... |Produ... |PROI
0 PRODUCT_SUBCAT... | Produ... | PROL

B MODEL Madel MOD
B PRODUCT_MAME Produ... |PRCI
£l TIME_YEAR vear,(... | TIME -
] rE P
- 0K @'Cancel

Filter Group

The Filter group contains the Advanced Filter button to open the Advanced Filter dialog box
to set advanced filtering options. Advanced filter options include Where, Where Total, the
And conjunction, and the Or conjunctions in a single expression.

When creating a report, you refer to fields in several parts of the request. For example, in
display commands (PRINT, SUM), in sort phrases (BY, ACROSS), and in selection criteria
(WHERE, WHERE TOTAL, IF).

The WHERE phrase selects records from the data source to be included in a report. The
data is evaluated according to the selection criteria before it is retrieved from the data
source. You can use as many WHERE phrases as necessary to define your selection criteria.

In WHERE TOTAL tests, however, data is selected after all the data has been retrieved and
processed.
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You can group conditions and expressions within Simple Filter criteria. In addition, you can
apply functions and calculations within criteria. This option provides more functionality than
the Filter dialog box. For more information on the simple filter, see Field Tab on page 85.
The Filter group is shown in the following image.

\
E
Advanced

Filter

In the Advanced Filter dialog box, you can create Where and Where Total filters, as shown
in the following image.

+f Create a filtering condition 0o x
,4'! Mew Filter | Insert Before Insert After Group Ungroup |
| |
K | & H | |
= ¥ WHERE
Double-click or press F2 to edit!
o 0K (5} Cancel

You can change between Where and Where Total by double-clicking WHERE.

Double-clicking the Double-click or press F2 to edit! text opens drop-down menus for Fields,
Operators, and Values. You can retrieve fields and values from the Master File and data
source.

The Field drop-down menu provides a field list from the Master File.

The Equal to (default) drop-down menu provides the following operators:
4 Equal to
4 Not equal to

d  Greater than

68 WebFOCUS



3. Navigating the InfoAssist Interface I

4 Less than

4 Greater than or equal to
d Less than or equal to
< In literal list

4 Not in literal list

4 Missing

4 Not missing

<4 From-To

4 Not From - To

< Includes literal list

4 Excludes literal list

<4 Contains characters
<4 Omits characters

4 Like character mask

4 Not like character mask
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The Value drop-down menu opens a dialog box with multiple options, as shown in the following

image.
r'rCrede a filtering condition O x
,1;:? Mew Filter ' J Insert Before 'Klnsert After ' = Group Ungroup
X ¥ 1O i
= ¥ WHERE
<Field= Equal to E::‘.-'alue} "
. Type: Constant -
Value: Mutiple Val.. « w X
Get Values~
: [
| K {5 Cancel

0K (8 Cancel

The type drop-down menu contains the following options:

4 Constant. Enables the entry of a literal constant value.

<4 Parameter. Enables you to specify a parameter by entering a name and description in
the provided text input areas, as well as selecting the type of parameter (Simple, Static,

Dynamic).

4 Field. Enables the specification of a field name to compare against.

The value area contains a text input box that you can use to manually insert values. It also
contains a Get Values drop-down menu, which supplies the following options.

< AllL Retrieves all the values from the selected field.

d First. Retrieves the first value from the selected field.

d Last. Retrieves the last value from the selected field.

4 Minimum. Retrieves the minimum value from the selected field.

4 Maximum. Retrieves the maximum value from the selected field.
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d From File. Retrieves a value that you specify. Selecting this option opens a browse dialog
box.

Note: The Get Values drop-down menu is only accessible if you have already selected a
field.

After selecting the values that you want, you can move them into and out of the Multiple
Values area with the left and right arrows. You can also change the value order and delete
values with the up and down arrows and the Delete icon.

After creating a condition, you can insert additional conditions before and after the selected
condition by using the Insert Before and Insert After buttons at the top of the Advanced Filter
dialog box. You can use either the And or the Or conjunction to link conditions and the Group
and Ungroup buttons to nest and organize conditions.

You can create additional filters by clicking the New Filter button at the top of the Advanced
Filter dialog box.

V' Create afiltering condition

= F WHERE
Region Equal to Central
AMD
Product,Category Equal to Televisions

After creating the filters that you want, click OK to save and apply the filters. You can access
them from the Filter pane of the Resources panel.
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Display Group

The Display group contains the Missing Data menu, which contains options to control the
display of missing data values in a chart. The Missing Data menu is shown in the following
image.

by
I -

Missing Data
Display

<4 Missing Data. Displays the following options Gap, Zero, Interpolated Line.
4 Gap. Displays missing values as a gap in bar, line, and area charts.

4 Zero. Displays a bar on the zero line in a bar chart. Displays a solid line that connects
the missing value with the succeeding value in a line chart. Displays an area on the zero
line in an area chart.

4 Interpolated Line. Displays missing values as a interpolated dotted line that connects
the plot points preceding and succeeding the missing value in a line chart. Displays
missing values as an interpolated bar in a bar chart. Displays missing values as an area
in an area chart.

Data Source Group

The Data Source group contains the Add command and the Switch drop-down menu to add
and switch data sources. The Data Source group is only available in Document mode. The
Data Source group is shown in the following image.

Note: The Data Source group is not available when working with Reporting Objects.

a4 3.

Add Switch

Data Source
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4 Add. Opens the Select a data source dialog box, where you can add additional data
sources to a document, enabling you to insert reports from different data sources into
the same document. The Select a data source dialog box is shown in the following image.

Select a data source O x

Loak in: |[E| Reporting Server El P -
Mame |Descri|:|h'on |T5-'pe |App|ir.3ﬁon Mame | it
“ cusT X¥FOC hyperstagetesting
“ CUSTHOLD Comma-delimited hyperstagetesting 3
ﬁ DAILY_PRICES Hyperstage hyperstagetesting
ﬁ HOLD Comma-delimited hyperstagetesting n
# LOCALAWGES MS Analysis Server 2005 localcube
é MOVIES Hyperstage hyperstagetesting
“ PORTFOLIO Hyperstage hyperstagetesting
“ QUOTES_2B Hyperstage hyperstagetesting
ﬁ QUOTES_IB Hyperstage hyperstagetesting
ﬁ RETAIL_FLAT Hyperstage hyperstagetesting
@ saes XFOC hyperstagetesting
é SALES_FLAT_RAMDOM Hyperstage hyperstagetesting

_ﬂ CALEC EIAT SODTNY Hunaretzn, hunarctanatactng -
File name: | |
Files of type: | Master Files |Z|

4 Switch. Opens a drop-down list of all the data sources that have been added. You can
choose which data source is currently active and being used to create new reports.

You can also switch data sources by selecting a report that is using a data source different
from the one that is currently active.
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Slicers Tab

In this section:
Options Group
Record Limit Group

Group Number Group

The Slicers tab provides the ability to create and edit slicers. Slicers are dynamic filters that
you can use with reports, charts, dashboards, and documents. For more information on
Slicers, see Using Slicers on page 437. The Slicers tab is shown in the following image.

DL}H@W@ = Fun

Home Format Data Slicers  Layout  View ca @)
I_Zﬁ Dew Gaup Preview 500 -
ﬁ[ﬂear Slicers Dwmm fo
Run Ti Creafe Sicers
q[Rr‘ Update Preview L Hime Al -
Options ™= Record Limit Fa Group 1 i

Note: The slicer capabilities are only available in the full version of InfoAssist. They are not
available in InfoAssist Basic.

Options Group

The Options group contains the New Group, Clear Slicers, and Update Preview commands.
<4 New Group. Creates a new group of similar slicers.
4 Clear Slicers. Resets all slicers so that no filtering is done.

4 Update Preview. Applies slicers to preview.

Record Limit Group

The Record Limit group contains the Preview and Run Time drop-down menus.

d Preview. Sets the number of records retrieved from the data source for preview. The
options are:

4 All
41
4 10
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50
100
500
1000
2000
5000
10000

4 Run Time. Sets the number of records retrieved at run time. The options are:

d

]

d

d

All

50
100
500
1000
5000
10000
50000

Group Number Group

The Group Number group contains a group for each Slicer group that is added. Group 1 is
the default slicer group to which you can drag fields to create slicers.
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Layout Tab

In this section:
Page Setup Group
Size & Arrange Group
Report Group

The Layout tab provides access to page display and layout options from the Page Setup,
Size & Arrange, and Report groups. It is shown in the following image.

— - Height 2.5 ") Aspect Ratio | 57, Relative Position
[ A o] # ¢ = 4 ]
- ‘e - - *  Width 1.93 AutoFit — - =
Margins Crientation Size Units Page ST o a o Cell Padding Autofit
Mumbers il Auto Cverfiow |~ Align Column
Size & Arrange £} Repart

Page Setup

Page Setup Group
The Page Setup group contains the Margins, Orientation, Size, Units, and Page Numbers

(reports only) commands to customize the page setup for the output of your report.

4 Margins. Enables you to set margin values by choosing Normal (1 inch all around), Narrow
(.5 inch all around), Moderate (.5 inch left or right), Wide (1.5 inch left or right), or Custom.
Choosing Custom opens the Margins dialog box, as shown in the following image, where

you can set specific margins as needed.

D Margins x
Top: 0.0 inches  govom: 0.0 inches
Left: 0.0 inches Right: 0.0 inches

W« 0K W Rezet | €8 cancel

4 Orientation. Enables you to set the orientation of your report to portrait or landscape.

- Size. Enables you to select the size of the paper for printing output. You can choose A3,
A4, A5, Letter, Tabloid, Legal, PowerPoint, or Large Size.
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4 Units. Enables you to select the unit of measurement used for customizing the dimensions
of your report or chart. You can choose Inches, Centimeters, or Points.

<4 Page Numbers. (Reports only). Enables you to select page numbering options. You can
choose one of the following:

4 No Lead (no space for headers)
<4 On (page numbers only in headers)
1 Off (space for headers, but no page numbering)

The Page Numbers value is overridden by header and footer text options.

Size & Arrange Group

The Size & Arrange group contains commands to size charts and document components.
The Size & Arrange group contains the Height and Width, Auto Overflow, Aspect Ration,
Autofit, Align, and Relative Position commands. The Size & Arrange group is available when
working with charts and documents.

For more information on using the options available in the Size & Arrange group to lay out
components in a document, see Editing Components in a Document on page 374.
Report Group

The Report group contains commands to customize report spacing settings. Cell Padding
and Autofit Column are for reports only.

<4 Cell Padding. Opens the Cell Padding dialog box, where you can set specific values to
control the amount of space inserted between rows and columns in a report. For more
information, see How to Use Cell Padding in a Report on page 152.

4 Autofit Column. Limits the width of columns in a report to be no wider than the largest
value in each column. Autofit Column is selected by default.
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View Tab

In this section:
Design Group
Show/Hide Group
Data Panel Group
Query Panel Group
Output Window Group
Report Group (Reports)

The View tab provides access to report design viewing options in the Design, Show/Hide,
Data Panel, Query Panel, Output Window, and Report groups. It is shown in the following
image.

R " - gl S

Home Inszri Format Data Slicers Layout

Design Group

For more information, please see Design Group on page 41.

Show/Hide Group

The Show/Hide group contains the Resources, Ruler, and Grid commands for choosing
different viewing options while working with reports and output. It is shown in the following
image.

d

Resources

L
i S —
= Pelationships

Show II'Hilei

The default view in InfoAssist shows both the Resources panel and the Results panel at the
same time.
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J4 Resources. Minimizes the Resources panel and expands the size of the Results panel
to also occupy the area where the Resources panel typically appears. The Results panel
can display a preview of a report, output of a report, or the Query Design pane.

4 Ruler. Displays a ruler above the canvas and to the left of the canvas for a document.
4 Grid. Displays a grid as a visual aid for aligning objects in a document.
<4 Relationships. (Document only) Shows the relative positioning relationship among
objects.
Data Panel Group

The Data Panel group contains commands to display data source fields in the Data pane
(Resources panel), using different views that are labeled Logical (default), List, and Structured.
All three views provide options for displaying each data source field as a Title, Description,
Field, or Alias. The List view also includes options to show the Alias, Format, and Reference
of each field. The Data Panel group is shown in the following image.

= —
;\tﬂ - t - ol dal 4 -
Logical Lisk Structured
Daka Panel

The following is an example of the default Logical view, displaying the Title of each field.

- @ WF_RETAL .
= 4 Dimensions
= 4 Geography
1 E Region
= 4 Product
+ B Product,Cateqory
& Tme (Sales)
0 Year,(Sales)
4 Time (Shipped)
B Year,(Shipped)
& Time (Delivery)
1 Year,(Delivery)
= Time (Estmated Delivery)
+ B Year,(Estimated Delivery)
= ¥ Education

m
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The following is an example of the List view, displaying the (data source) Field Name of each

field.
MName Title alias Format |Segment Filename Description
£l REGION Region |REGIOM |A15Y  |DIM_GEOG... |WF_RETAIL | Customer Region |
B STATECODE State,... | 5TAT... [A2 DIM_GEOG... | WF_RETAIL | Customer State (Code)
a cImyY City CITY ASOV DIM_GEOG... | WF_RETAIL | Customer City
B PRODUCT_CATEG... |Produ... |PROD... | A4OV DIM_PROD... |WF_RETAIL | Product,Category
B PRODUCT_SUBCAT... |Produ... |PROD... | ASOV DIM_PROD... |WF_RETAIL |Product,Subcategory
£ MODEL Model MODEL | ASOV DIM_PROD... | WF_RETAIL | Maodel
B PRODUCT_MAME Produ... [PROD... [ A150V DIM_PROD... | WF_RETAIL |Product Mame
£l TIME_YEAR Year, (... | TIME_... | 16 DIM_TIME_... | WF_RETAIL | Year,{Sales)
£ TIME_QTR Quart... | TIME_... |18 DIM_TIME_... | WF_RETAIL |Quarter, (Sales)
£l TIME_MTH Month... | TIME_... | 15 DIM_TIME_... |WF_RETAIL | Month,(Sales)

2 HData

= & WF_RETALL

El MSRP

E Cost

= 47 FACT_SALES
B Quantity,Sold
El Revenue

E Discount

B, Gross Profit
= & DIM_FRODUCT
B ID_PRODUCT
B Product,Category
B Product,Subcategory
B Brand Type

The following is an example of the Structured view, displaying the Description of each field.
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Query Panel Group

The Query Panel group contains commands to provide three different views of the Query
Design pane, Areas 2x2, Areas 1x4, and Tree (default). It is shown in the following image.

;i freas 2x2
Z Areas 1x4

2] Tree
[=]|

Query Panel

You can display the filter and data source field containers in the Query Design pane in one
of following three ways:

4 Areas 2x2. Displays data in two-column by two-row grid.
<4 Areas 1x4. Displays data in one-column by four-row grid.
4 Tree. (Default.) Displays data in a tree, not a grid.

The following image shows the Query Design pane when Areas 2x2 is selected for a report.

n ¥ Filter == Column Labels (ACROSS)
b N ‘ l
\’ Region Equal to Central or MorthEast or SouthEastar ... B Product,Category
n gRow Labels (BY) I 1 = Measures {sum) I
El Region B Quantity,Sold

£l Revenue
£l MSRP
Bl Discount
B Cost
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The following image shows the Query Design pane when Areas 1x4 is selected for a report.

¥ Filter

Qr Region Equal to Central or MorthEast or SouthEastor ...

= Column Labels (ACROSS) |

—1

B Product,Category

% Row Labels (BY) |

—1

E Region

M % Measures (SUM}ll

B Quantity,Sold
B Revenue

El MSRP

El Discount

El Cost
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The following image shows the Query Design pane when Tree is selected for a report.

1 F pata

L
L

g& Customers

4]

EErEEEEEEREAEEEEAEEEECEEEEEE

Quantity,Sold -
Revenue

Age

Latitude

Longitude

Population, City
Population, (3t of State)
Population, State

State, Capital, Latitude
State, Capital, Longitude
Product,Cost
Product,Weight
Base,Rate

Deliver Estimate, (Days)
Service,Rate

Cost per,Pound

Day of Week, (Delivery)
Year Quarter, (Delivery)
Year Month, (Delivery)
Year Week, (Delivery)
Shift, (Delivery)

Day of Week, (Estimated
Year Quarter, (Estmated
Year Month, (Estimated D
Year Week,(Estimated De _

m

Output Window Group

1 ¥ Filter

3 Region Equal to Central or NorthEast or SouthEast or ...

Sl query

= X Sum

B Quantity,Sold
B Revenue

£l MSRP

B Discount

B Cost

By

£l Region

il

=

= = Acoss
B Product,Cateqory

The Output Window group contains the Arrange, Output Location, and Switch Output drop-
down menus for setting output display. It is shown in the following image.

sl

Arrange

Ctpuk Switch
Location  Cwukbput

Cubput dind o

4 Arrange. Opens a drop-down menu for choosing to display multiple output windows as
a Cascade, Tile Horizontally, or Tile Vertically.
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For example, the following image shows how you can display three output windows when

you click Tile Vertically.

Qggsales[ﬁ] [_Tol[=] Qggsales[s] [_Tol[=] Qggsales[‘t] [_Tol[=]
L Unit Dolla; Unit Doll
Product Region State Sa Product Sales Region Sales Product Sales Region Sa
Biscotti fiidweest IL 2% Biscotti 21377 West 5263317 Biscotti 145242 Mortheast 18020
fliyel 297 Capuccino 189217 West 2381590 Capuccing 44785 Mortheast B420
T 27 Coffes 186534 West 2337h67 Coffes 40977 Mortheast 5092
Mortheast  CT 4z Grinder Grinder
iy A71 Coffee 190695 West 2449585 Coffee 45185 Mortheast RA07
WY 51¢ Pat Pat
Southeast  FL A0¢ Croiszant 630054 Wiest 49902 Croiszant 137394 Mortheast 16708
G 43¢ Ezpresso 308986 Wiest 3906243 Ezpresso 68127 Mortheast 8501
TH e Latte BVE0EE  West 10943622 Latte 222866 Mortheast 27718
West Ch 475 Mug 360570 West 4522521 Mug 1497 Mortheast 11442
W 26 Scone 333414 West 4218114 Scone 0732 Mortheast 9071
Capuccing  Mortheast CT 12 Thermos 190081 West 2385829 Thermos 43870 Mortheast 6040
iy 182
M 170
Southeast  FL 24
=) a7
4 | , 4 | 2l | ©

d Qutput Location. Opens a drop-down menu for choosing to direct new output to a Single

Tab (default), New Tab, Single Window, or New Window. For details, see Understanding

Output Options on page 121.

Report Group (Reports)

84

o

Switch
Report
Report

1 switch Output. Opens a drop-down menu for choosing to view any active output window.

The Report Group for reports contains the Switch Report drop-down menu which lists reports
that you can switch to. It is shown in the following image.

Switch Report. Opens a drop-down menu for choosing any active report or chart. You
can have multiple reports, charts, dashboards, and documents open in the application
window, as shown in the following image.
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Note: You can also switch reports from the status bar. For more information, see Using
the Status Bar on page 133.

Switch
Report
Documentl

Reportz
Zhart1

B & @ S

Jdil Chartz

Field Tab

In this section:

Filter Group

Sort Group

Break Group (Reports)
Style Group

Format Group

Display Group

Links Group

The Field tab appears in the ribbon when you select a data source field in the Query Design
pane or Layout canvas. The options available in the Field tab are specific to the data type
that is selected. The options available for numeric fields are different from the options
available for non-numeric and date fields. The Field tab provides access to the Filter, Sort,
Break, Style, Format, Display, and Links groups. It is shown in the following image.

o 4 - = % Fage Break E] Sub Header
ﬂ : E % * i * % + Mo Limit

&/ E] Line Break Q Sub Footer
it E] Subtotal Eﬂ Recompute
Break

Visibility

&

Links

Spedific

Format

S
<
Frompt Up Down Rank Limit Style

Filter Sort

The Field tab provides the following groups and options.
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Filter Group

The Filter group contains filtering options, including Filter, Exclude, Include, and Prompt. The
Filter group is shown in the following image.

Filter Irichuds Prompt

Filker
1 Filter. Opens the Filter dialog box for creating or modifying WHERE statements.
The Values drop-down menu contains the following options:
Fetch All Values from Source
Fetch Values from Disk File
Fetch First Value in Source
Fetch Last Value in Source

Fetch Minimum

1 T N S

Fetch Maximum

The Prompt drop-down menu contains the following options:
4 No Value Prompt (default)

4 Prompt using Data Values (Dynamic)

4 Prompt using Selection (Static)
i

Prompt using Text Input (Simple)
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Selecting any Prompt option changes the purpose of the dialog box to creating an auto
prompting parameter that you can select when you run a report. When you select the Prompt
using Data Values (Dynamic) option or the Prompt using Text Input (Simple) option, the Values
drop-down menu is unavailable. The Filter dialog box is shown in the following image.

¥ Filter for PRODUCT O x
v, =) @ Cancel E Values~ a Prompt™ .
Equal to -
Add;

When you select an existing filter in the Filter area of the Query Design pane, choosing
Exclude removes, but does not delete, the filter from the report. When you select a filter
that was previously excluded from a report in the Filter area of the Query Design pane,
choosing Include restores the filter to the report.

4 Prompt. Opens the Filter dialog box for creating an auto prompting parameter that you
can select when you run a report. The Filter dialog box is used to create both filters and
auto prompting parameters. The following options are available in the Prompt drop-down
menu:

4 Prompt using Data Values (Dynamic). This is the default value.
4 Prompt using Selection (Static)

4 Prompt using Text Input (Simple)
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4 Allow Multiple Values for Prompt. Displays a multi-select menu in the output window
when you create a dynamic auto prompting parameter for a field and then run the report.
The Filter dialog box, shown in the following image, creates a filter that displays a dynamic

auto-prompt, when the report is run for the Product field. The dynamic auto-prompt lists
the products that you can select.

\ Filter for QUANTITY_SOLD —
= Cancel F - Prompk

| Equal to Izl

Variable: |QUAM'1TY_SDLD Prompt: | qUANTITY _SOLD:

bl Allow Multiple Values for Prompt

The following is an example of a dialog box that prompts the user for a parameter value.

This dialog box opens when you run a report after creating a dynamic auto prompting
parameter for the Product field.

QUANTITY_SOLD:
2660644 IR

’ . ” Glearluknt ] [TRun in a new window

1. Specify values for all parameters.
2. Select the run button to submit the request
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If you click the Allow Multiple Values for Prompt button while creating a dynamic auto
prompting parameter, a multi-select menu appears when the report is run. Selecting
multiple parameter values displays the output in the same dialog box as the prompt, as
shown in the following image.

No Selection »

Central [

WidEast

NorthEast 7

ERUHH Reset H Slearoutnat ] [T rRun in a new window

Quantity
Region Sold Revenue

Central 32,463 19,160,774.07

Sort Group

The Sort group contains sort options, including the default Up (ascending sort), Down
(descending sort), Rank (reports only), and Limit (reports only). It is shown in the following
image.

%4_ i 3 Q i’ No Limit |~
Up Dowen Fank Lirnit

Sort

1 Up. (Default.) Sorts the selected field in ascending order.
d Down. Sorts the selected field in descending order.

4 Rank. Inserts a rank column immediately to the left if a Sort By field is selected. It also
adds a rank column to the left of the Sort By field if a Measure is selected. Ranking a
Measure results in two copies of the field, the original Measure, and the Sort By field
that is created during ranking.
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4 Limit. Opens a drop-down menu that allows you to specify the number of unique values
to display for a sort group that has been added.

For more information about these report options, see Using Custom Reporting Features on
page 157.

Break Group (Reports)

The Break group for reports contains options for customizing a report by adding a Page
Break, Line Break, Subtotal (for numeric fields only), Sub Header, Sub Footer, and Recompute
to the report output. The Break group is shown in the following image. The Break Group is
used for reports only,

1=

=
=] Line Break |} 5ub Footer

Page Break - ,i‘; Sub Header

) Subtotal -

Break

4 Page Break. Starts a new page when the primary sort field changes. Clicking the
drop-down icon enables you to select Reset Page Numbers, which allows you to reset
page numbers on a page break to start at 1.

< Line Break. Inserts a line in the report output when the primary sort field changes.

1 Sub Header. Opens a dialog box where you can type text to add a subheading just below
the column titles in the report output when the primary sort field changes.

1 Sub Footer. Opens a dialog box where you can type text to add a subfooting at the end
of the data on each page of the report output when the primary sort field changes.

4 Subtotal. Inserts a line, total text (TOTAL FIELD Value), and subtotals for all numeric
fields when the primary sort field changes.

For more information about these report options, see Using Custom Reporting Features on
page 157.
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Style Group

The Style group contains styling options for reports and charts. For a selected field in a
report, you can customize the font type, font size, font color, background color, and restore
styling to the default values. You can also style fonts (bold, italic, underline), justify text
(left, center, right). You can apply styling to the Data (default), column Title, or both the Data
and column Title for the selected field in a report. The Style group is shown in the following
image.

=5 Diata Style
& Bl Title Style
= Data + Titls

Trebuchet M5 -« 9 ﬁ f;‘
B 7 U —

Skyle

For more information about styling reports, see Styling Reports on page 139.

Format Group

The Format group contains formatting options for virtual or column fields including
Alphanumeric, Integer, Decimal, Currency, Percentage, Comma, and Decimal Places. The
Format group is shown in the following image.

Decimal -

$-% v HWa

Format

The drop-down menu provides three field-type options for the selected column, which are
Alphanumeric, Integer, and Decimal. Selecting the fourth option, More options, opens the
Field Format Options dialog box, which provides further formatting options for the selected
field. For more information, see Changing a Field Format on page 154.

You can also apply floating and non-floating currency, percent signs, and commas. You can
increase and decrease decimal places by clicking the appropriate buttons under the drop-
down menu.

The Currency button is a split button that turns the currency symbol on or off. Click the
Currency button to turn on the default floating currency option. Click the Currency button a
second time to turn off the floating currency option.

To turn on the non-floating currency option, open the drop-down menu and select Non floating
currency. To turn off the non-floating currency option, click the Currency button.
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Display Group
The Display group contains additional options for a selected field, including Hide Field, Hide
Missing, Aggregation, Traffic Lights, and Data Bars (reports only). It is shown in the following
image.
']} Hide Field ¥ Traffic Lights
') Hide Missing ~ E |Data Bars
Z:) Agoregation -

Display

4 Hide Field. Allows you to hide a selected field.
4 Hide Missing. Allows you to hide fields that have no value.
4 Aggregation. Opens a drop-down menu of the following options:
4 None (default)
4 Sum
4 Average
4 Count
4 Count Distinct
< Percent of Count
4 First Value
< Last Value
4 Maximum
<4 Minimum
4 Total
4 Percent
4 Row Percent

4 Average Square
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Links Group

Sum is the default aggregation type value for all numeric fields added to the Measure
field container in the Query Design pane. Changing the Measure field container from Sum
to Print, Count, or List overrides all assigned aggregation type values. For more information
related to reports, see How to Display Measure Data Using Aggregation Options in a Report
on page 166. For more information related to charts, see How to Display Aggregations on
Measures on page 233.

Traffic Lights. Opens the Traffic Light Condition dialog box. From this dialog box you
can do the following:

4 add new conditional styling by applying traffic light (and other) colors to a selected
field in the output when the field meets specified criteria

4 modify existing conditional styling
4 enable conditional drill-down

For more information related to reports, see Styling Reports on page 139. For more
information related to charts, see Traffic Light Condition Dialog Box on page 211.

Data Bars. (Reports only.) Adds a data visualization column to the right of a selected
numeric field. The column displays values in each row using horizontal bars that extend
from left to right in varying lengths, depending on the corresponding data values. For
more information, see How to Add Data Visualization Bars to a Report on page 165.

The Links group contains the Hyperlink command to add a hyperlink or drill-down procedure
to a selected field in a report. The Links group is shown in the following image.

g

Hyperlink.

Links
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Hyperlink. Opens the Drill Down dialog box opens. From that dialog box, you can configure
a hyperlink or a drill-down procedure for the selected field. Clicking that field in report output
takes you to the specified URL or executes the specified procedure. The Drill Down dialog
box is shown in the following image.

Drrill Down W

@ Web Page () Report
LIRL

Alternate comment

Target
Mew Window -
Parameters & | ;| X
Mame Value

Vs =) (8 cancel
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Series Tab

In this section:
Select Group
Properties Group
Line Group
Pie Group
Display Group
The Series tab appears in the ribbon only when you are working with charts. It provides

access to chart options through the Select, Properties, Line, Pie, and Display groups. The
Series tab is shown in the following image.

" R O~ R )

Style Data Labels Trendline Equation Smooth Connect Marker Expand Hide Reverse

Line Lines Order
Select Properties Line Pie Display

Select Group

The Select group contains a drop-down menu for selecting a specific measure field to which
to apply one or more of the options that are available in the Series tab. The default setting
is All Series, which applies the selected options to all the measure fields in the report.

Properties Group

The Properties group contains options for enhancing charts. The options are Style, Data
Labels, Type, Trendline, and Equation options. It is shown in the following image.

ﬁLLV%

Style Data Labels Trendline Equation

Properties

1 Style. Opens the Format Series dialog box, where you can edit the styling options for
the selected series. You can also open this dialog box by right-clicking a series, and then
clicking More Style Options. For more information, see Formatting a Series on page 208.

41 Data Labels. Adds data labels to the chart. The drop-down menu contains the following
data position options for selecting where to display data values as labels on a chart:
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]

d

Above (default)
On top edge
Below top edge
Center

Base

Clicking More Data Label Options opens the Format Labels dialog box where you can
further edit your data labels. For more information, see Formatting Data Labels on page
242.

Type. Opens a drop-down menu with the following options for selecting different chart
types:

d

]

d

]

None (default)
Bar
Line

Area

Trendline. Opens a drop-down menu that provides the following options for adding a
trendline to a chart:

]

]

d

d

]

None (default)
Linear

Quadratic
Polynomial
Hyperbolic
Logarithmic
Modified Hyperbolic
Rational
Exponential
Modified Exponential
Log Quadratic

Geometric

Note:
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4 The trendline option is not available in HTML5.

4 The trendline option is not available in InfoAssist Basic.

For more information, see How to Add a Trendline on page 219.

4 Equation. Displays the associated mathematical equation for the selected trendline on
the chart.

Note:

4 The equation is not available in HTML5.

4 The equation option is not available in InfoAssist Basic.

Line Group

The Line group contains options for formatting chart lines and line markers. The options are
Smooth Line, Connect Lines, and Marker. It is shown in the following image.

L b

Ed
Ll

£l

K
- .

Smooth Connect
Line Lines
Lime

Marker

4 Smooth Line. Draws the chart using smooth lines. For more information, see How to
Apply Smooth Line Effect to a Line Chart on page 220.

Note: The smooth line option is not available in InfoAssist Basic.

<4 Connect Lines. Controls the display of connecting lines between markers on a line or
scatter chart. By default, lines are connected on a line chart and disconnected on a
scatter chart.

4 Marker. Opens a drop-down menu from which you can select options to change the
display of the default data and legend markers on line and scatter chart types. The
drop-down menu contains the following options:

]

d

]

None
Square
Circle
Diamond
Plus

Triangle Down
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Pie Group
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]

d

Triangle Up
Triangle Right
Triangle Left
Pirate Plus
House
Hexagon

Fat X

Five Star

Six Star
Hourglass
Sideways Hourglass
Horizontal Line
Vertical Line

Area

For more information, see How to Change the Appearance of a Marker on page 222.

Note: The marker option is not available in InfoAssist Basic.

The Pie group contains options to expand or hide pie slices. It is shown in the following

image.
Expand Hide

Pie

The Pie group is activated only when you click Pie on the Format tab, in the Chart Types

group.

Note: The pie options are not available in InfoAssist Basic.
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Display Group

The Display group contains the Reverse Order command to reverse the order of a series
when All Series is selected in the Select group. It is shown in the following image.

£,

al

Rewverse
Order

Display

The Reverse Order option is available for all chart types.

Understanding the Resources Panel

In this section:

Using the Data Pane to Add Fields to a Report

Using the Query Design Pane in the Resources Panel
Using Right-Click Field Options in the Query Design Pane
Reference:

Field Image List

Filter Area of the Query Design Pane

The Resources panel displays the Data pane in the upper half of the panel and the Query
Design pane in the lower half of the panel by default. When you select Query Design view,
the Resources panel displays the Data pane only. You select Query Design view on the Home
tab, in the Design group, clicking Query or on the View tab, in the Design group, clicking
Query.
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The following image shows the default view of the Resources panel, which displays the Data

pane above the Query Design pane when you create a report.
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The Data pane, which contains all the fields from the selected data sources, is always
displayed.

You can manually adjust the size of the Resources panel and Results panel by clicking and
dragging the border between the two panels in either direction. Move the mouse pointer
over the border. When the pointer changes to a two-way arrow, click and drag the border.

Reference: Field Image List

In the Resources panel, each field has an image associated with it. The following table

displays each image and describes what it represents.

Icon Type
& Database
3B Dimension Segment
':l Measure Segment
,{} Locked Segment
i Unique Segment
Ga Key Field
B Index Field
r Blob
r Text or Alpha Field
r Date or Date and Time Field
F Numeric Field
B, Calculated Date Field
B, Calculated Numeric Field
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Icon Type
Eh Calculated Other Field
Eﬂ% Calculated Text Field
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Reference:

Filter Area of the Query Design Pane

The Filter area of the Query Design pane displays all filters that have been created for the
selected report. The Filter area is shown in the following image.

1 HData
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=
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For more information on simple filters, see Field Tab on page 85. For more information on

advanced filters, see Data Tab on page 62.

Note: The Filter area displays all created filters, both active (included) and inactive (excluded).
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Using the Data Pane to Add Fields to a Report

104

There are several ways that you can add data source fields to a report. You can drag and
drop, double-click, or right-click data source fields in the Data pane to add them to a Query
field container or Filter in the Query Design pane.

After you add data source fields to a Query field container, you can change the order of the
fields by dragging and dropping one field above or below another field.

Drag and Drop. This method provides the most control. You can drag and drop data source
fields from the Data pane to the appropriate Query field container or Filter in the Query Design
pane.

For a larger work area in which to drop data source fields in the appropriate Query field
container, make sure that Query Design view is selected, and then, on the View tab, in the
Query Panel group, click Areas 2x2 or Areas 1x4.

You select Query Design view on the Home tab, in the Design group, by clicking Query or on
the View tab, in the Design group by clicking Query. That selection expands the Query Design
pane so that it is opened in the Results Panel.

Multi-Select. You can multi-select data source fields that you want to add to a report in
Live Preview, Query Design view, and Document view. To select multiple data source fields
to add to a report, click the appropriate fields while holding the Ctrl key on the keyboard.
You can drag and drop fields onto the canvas, or add them to the Query field container.

Double-Click. To automatically add a field to the appropriate field container in the Query
Design pane, you can double-click a data source field in the Data pane.

4 When you double-click a numeric measure field in the Data pane, it is automatically added
to the Sum (Measure) Query field container.

4 When you double-click a dimension (non-numeric or date) field in the Data pane, it is
added to the By (Row Label) Query field container for a report, or to the X-axis Query field
container for a chart.

You cannot automatically add a field to the Across (Column Label) Query field container for
a report, or to the Legend (Series) and Multi-graph Query field containers for a chart.

Right-Click. You can right-click a field in the Data pane to add it to the Filter area or a Query
field container in the Query Design pane. For reports, the available right-click options are as
follows:

4 Sum. For measure (numeric) fields.
4 Sort. For all types of fields.
4 Across. For dimension (non-numeric or date) fields.

-4 Include as Coordinated. Only available in Document view.
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A

o

Filter. For all types of fields.

Slicers. For all types of fields.

For charts, the available right-click options are as follows:

A

o

A

o

A

o

Sum. For measure (numeric) fields.

Include as Category Axis. For dimension (hon-numeric or date) fields.
Include as Legends Series. For dimension (non-numeric or date) fields.
Filter. For all types of fields.

Slicers. For all types of fields.

Include as Coordinated. Only available in Document view.

Although most measure fields are composed of numeric values, and most dimension fields
are composed of non-numeric or date values, there can be exceptions, depending on the
selected data source.

Using the Query Design Pane in the Resources Panel

The Query Design pane, which contains the Filter and Query (field container) areas, appears
below the Data pane, except when you select Query Design view, which expands the size of
the Query Design pane and displays it in the Results panel. There are different field containers
for reports and charts.

Reports. For all reports, the Query field containers in the Query Design pane include Sum,
By, and Across.

o

Use the Sum & field container to aggregate or display numeric measure fields. Its context
menu provides options to Sum (default), Print, Count, or List the fields in the report.

Use the By field container to vertically sort dimension fields to produce row labels in the
report output. Dimension fields are normally non-numeric or date fields.

Use the Across field container to horizontally sort dimension (non-numeric or date) fields
to produce column labels in the report output.
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The following image shows the Filter and Query (field container) areas of the Query Design
pane as it appears in the Resources panel for reports.
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Charts. For most charts, the Query field containers in the Query Design pane include Measure
(Sum), X Axis, Legend (Series), Multi-graph and Coordinated. More complex charts that
require additional data dimensions have alternative field containers.

-

Measure (Sum). Use this field container to aggregate or display numeric measure field
values.

X Axis. Use this field container to sort dimension (non-numeric or date) fields in the
chart output.

Legend (Series). Use this field container to display dimension (non-numeric or date)
fields as color-coded values (lines, bars, areas, scatter plots) that match the color-coded
dimension values displayed in the legend below the chart. Legend (Series) provides
functionality that is similar to an Across field in a report.

Multi-graph. Use this field container to create outermost sort fields and to serve as a
page break for working with multiple charts. The sort field added to this Multi-graph
container is not plotted on the chart, but each unique sort field value is listed for every
chart.

Coordinated. Use this field container to collectively sort and collate by a common sort
group (for documents only).
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The following image shows the Filter and Query (field container) areas of the Query Design
pane as it appears in the Resources panel for most charts in Live Preview and Query Design
view.

1'ffmmr

—| |..1|.| Query
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|ﬂ Multi-graph

For pie charts, the Query field containers in the Query Design pane include Measure (Sum),
Slices, Category, Multi-graph, and Coordinated.

d

Measure (Sum). Use this field container to aggregate or display numeric measure field
values in the pie.

Pie slices. Use this field container to display dimension (non-numeric or date) fields as
color-coded pie slices that match the color-coded dimension values displayed in the
legend below the chart. The Pie slices field container is equivalent to the Legend (Series)
field container used for other chart types.

Multi-graph. Use this field container to create outermost sort fields and to serve as a
page break for working with multiple charts. The sort field added to this Multi-graph bucket
is not plotted on the chart, but each unique sort field value is listed for every chart.

Category. Use this field container to sort dimension (non-numeric or date) fields in the
chart output. Category is equivalent to the X-axis field container used for other chart
types.

Coordinated. Use this field container to collectively sort and collate by a common sort
group (for documents only).

WebFOCUS InfoAssist User's Manual 107



Understanding the Resources Panel

The following image shows the Query (field container) area of the Query Design pane as it
appears in the Resources panel for pie charts in Live Preview and Query Design view.
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Using Right-Click Field Options in the Query Design Pane

Reference:
Right-Click Field Options in Query Design Pane

In the Query Design pane, you can right-click any field and select from a list of available
options that are displayed in the menu that appears. The options that you can select vary,
depending on the type of Query field container (Sum, By, Across) in which the field is located
and the type of report that you are creating (report or chart).

Report. When you create a report, the Query field containers in the Query Design pane
include Measure (Sum), By, and Across.
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4 Sum. Right-clicking a Sum field in a report displays the Filter Values, Sort, Visibility,
Change Title, Edit Format, More, and Delete options. You can point to More to access
the Data Bars, Aggregation Functions, Traffic Light Conditions, Sub Header, Sub Footer,
and Missing options. The right-click menu is shown in the following image.
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' By. Right-clicking a By field in a report displays the Filter Values, Sort, Break, Visibility,
Change Title, More, and Delete options. You can point to More to access Traffic Light
Conditions, Sub Header, Sub Footer, and Missing options. The right-click menu is shown
in the following image.
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4 Across. Right-clicking an Across field in a report displays Filter Values, Sort, Break,
Visibility, Change Title, More, and Delete options. You can point to More to access Sub
Header, Sub Footer, and Missing options. The right-click menu is shown in the following

image.
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Chart. When you create a chart, the Query field containers in the Query Design pane include
Measure (Sum), X Axis, Legend (Series), Multi-graph, and Coordinated (for documents only).
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4 Measure (Sum). Right-clicking a Measure (Sum) field in a chart displays the Filter Values,
Sort, Visibility, Change Title, More, and Delete options. You can point to More to access
the Aggregation Functions, Traffic Light Conditions, and Missing options. The right-click

menu is shown in the following image.
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X Axis or Legend (Series). Right-clicking an X Axis or Legend (Series) field in a chart
displays the Filter Values, Sort, Visibility, Change Title, More, and Delete options. You
can point to More to access the Missing option. The right-click menu is shown in the

following image.
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4 Coordinated or Multi-graph. Right-clicking a Coordinated field or a Multi-graph field in
a chart displays only the Delete option. The right-click menu is shown in the following
image.
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Reference: Right-Click Field Options in Query Design Pane

The following table lists and describes all the right-click field options available in the Query
Design pane for a selected field.

Option Description

Filter Values Opens the Filter dialog box for creating WHERE statements,
which enable you to select only the data that you want and to
exclude all unwanted data.

Prompt for Values Opens the Filter dialog box for creating an auto prompting
parameter that can be selected when a report is run.

Rank Inserts a rank column immediately to the left if a Sort By field
is selected and adds a rank column to the left of the Sort By
field if a Measure is selected. Ranking a Measure results in
two copies of the field, the original Measure and the Sort By
field that is created during ranking.

Sort Provides access to the Sort and Limit menus. The Sort menu
allows you to sort your data either in ascending or descending
order. The Limit menu allows you to specify the number of

unique values displayed for a sort group that has been added.
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Option

Description

Data Bars

Provides a menu for enabling the data bar representation

functionality. Selecting On adds a data visualization column to
the right of a selected numeric field. The column displays values
in each row using horizontal bars that extend from left to right
in varying lengths, depending on the corresponding data values.

Aggregation Functions

Provides a menu for selecting options to assign an aggregation
type value to a selected numeric field in a report.

Subtotal Provides a menu for enabling subtotal functionality. Clicking
On inserts a line, descriptive text, and subtotal values in the
report output for all numeric fields when the primary sort field
changes.

Page Break Provides a menu for enabling page break functionality. Clicking

On starts a new page in the report output when the primary
sort field changes.

Reset Page Numbers

Allows you to reset page numbers on a page break to start at
1.

Traffic Light Conditions

Opens the Traffic Light Condition dialog box, where you can
add new conditional styling or modify existing conditional styling
by applying traffic light (and other) colors to a selected field in
the report output when the field meets specified criteria.

Visibility Provides a menu for controlling the visibility of the selected
field. Clicking Hide removes the selected field from the report
output. Clicking Show (default) displays the selected field in
the report output.

Sub Header Opens the Sub Header & Sub Footer dialog box where you can
edit and style your headers.

Sub Footer Opens the Sub Header & Sub Footer dialog box where you can
edit and style your footers.

Missing Allows you to show or hide fields with no value.

Change Title Opens the Edit Title dialog box, where you can change the title

of the selected field by typing the new title in the Enter Title
field.
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Option Description

Edit Format Opens the Field Format Options dialog box, where you can edit
the field type and display options.

Delete Deletes the selected field.

All the right-click options available in the Query Design pane are also available in the Field
tab. For more information, see Field Tab on page 85.

Understanding the Results Panel

In this section:
Using the Query Design Pane in the Results Panel
Understanding the Layout Canvas

Understanding Output Options

As you create or modify a report, the Results panel displays the Layout canvas in the default
Live Preview, or in the Query Design pane when you select Query Design view. When you
execute a report, the Results panel displays the Output window. If the Output window is
closed, or if there is no report to preview, the Results panel is blank. You can select Query
Design view or Live Preview from the Design group of the View tab or Home tab.
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The following image shows the Results panel, which displays a chart preview when you first
launch InfoAssist to create a chart. The Resources panel appears to the left of the Results
Panel.
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After executing a report to generate output, if you minimize or close the Output window, the
Results panel displays empty space.

Using the Query Design Pane in the Results Panel

The Query Design pane displays the Filter area, and the Query field containers. The Query
Design pane appears in the Resources panel below the Data pane when you select the
default Live Preview.

The Results panel provides a larger area for displaying the Query Design pane. This feature
is useful when you are designing a report with multiple filters or numerous fields. You can
select Query Design view or Live Preview on the Home tab, in the Design group, or on the
View tab, in the Design group.
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The following image shows the Query Design pane in the Results panel of the InfoAssist
application window. It is displaying report field containers that include Filter, Sum, By, and

Across.
2 P oat 1 ¥ Filter
= & WF_RETAIL A

= ¥ Dimensions
= 4 Geography
E Region
= % Product
B Product, Category
= 48 Time (Sales)
F Year,(Sales)
= 48 Time (Shipped)
B Year,(Shipped)

m

= 4 Time (Delivery) €_ il
ill] Query
B Year,(Delivery) =
= 4 Time (Estimated Delivery) MMEESUTE (Sum)
El Year,(Estimated Delivery) %3‘ Axis
= 4 Education i1 Legend (Series)
mMuIti-graph

E Education Type
B ID_SHIPFACT
B ID_SHIFMENT

Depending on whether you are creating a report or a chart, the Query Design pane displays
selected data source fields using different types of field containers.

For reports, the Query Design pane displays Column Labels, Row Labels, and Measures
field containers.
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For charts, the Query Design pane displays Filter, Legend (Series), Categories (Axis), and
Measures (Sum) field containers, as shown in the following image.

¥ Filter

J WHERE GGSALES, SALESOL REGION EQ "West'

|GE5ALES, SALESOT REGION EQ "West' |

|| ﬁ' Legend (Series)

B Category

|l Categories {Axis)

= [yl A
B Produck
B Region

[L" Measures (SM) -

I Unit Sales
fl Dollar Sales
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Understanding the Layout Canvas

The Layout canvas displays a preview of the report being created or modified in the Results
panel when you are in the default Live Preview. To select Live Preview, go to Home tab, and
in the Design group, click Live Preview, or on the View tab, in the Design group, click Live

Preview. The Layout canvas is always fully maximized (within the Results panel) and cannot
be minimized, cascaded, or tiled. However, a blank canvas opens when there is no report.

The Layout canvas displays either live data or sample data.

The Layout canvas displays live data if, on the Home tab, in the Design group, you have
clicked Data from Source (default).

The Layout canvas displays sample data if, on the Home tab, in the Design group, you have
clicked Use Sample Data.

When you select Data from Source, a live preview of the report being built is refreshed in
the Layout canvas as you add, remove, and style data source fields in the report.

When you select Use Sample Data, the Layout canvas displays sample data based on the
field type, with the same formatting and styling used to display live data.
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The following image shows a preview of a report displayed in the Layout canvas in Live

Preview.

—|;Da1ﬂ

B Day,Mame,(Delivery)

B Date,(Estimated Delivery)

B Weekend, (Estimated Delivery)
B Holiday, (Estimated Delivery)

B Day,Mame,(Estimated Delivery)
B Date, (Shipped)
8 Weekend, (Shipped)
B Holiday, (Shipped)
B Month,Mame, (Shipped)
B Day,Mame,(Shipped)
= &8 Measures Properties
B Quantity,Sold

£l MSRP
B Discount
B Cost

Bl Population, City

B Month,MName, (Estimated Delivery)

4 Revenue

1 ¥ Filter

—| E] Query

= X sum
B Quantity,Sold
£ Revenue

= ﬁEy

E Region

ﬁ Across
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Quantity
Region Sold Revenue
Central 437 26,696.44
MidEast 25 13,596.76
MorthEast 34 9,144.28
MorthWest 43 72,6B5.62
SouthEast 34 29,932.52
SouthWest 9 2,118.41
West 32 29,704.27
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Understanding Output Options

Reference:

Reference:

Output Target Options
Output View Options
Output Format Options

When you run a report, the output appears, either in a tab in the Results panel, or in a new
browser window. You can create and display output in several different ways, depending on
the following options. You can select these options on the View tab, in the Output Window
group:

-1 Cascade

< Tile Horizontally
4 Tile Vertically
4 Single Tab

4 New Tab

4 Single Window
4 New Window
-1 Switch

Output window and tab options are also available in the status bar, and output window
display options are also available in the Navigation taskbar.

Note: When you run a report, tab focus is not on the output window and pressing the Tab
key does not move the selection. To move the Tab focus out of the output window, press
F6.

Output Target Options

The following are output target options that you can select.

1 Single Tab. When you click Single Tab and run a report, a new output window is created
in the Results panel, a report instance is created, and an output tab is placed on the
Navigation taskbar. As you modify a report, the same output window is refreshed each
time the report is run. This option, which is the default, is ideal when you are working
with just one report.
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4 New Tab. When you click New Tab, each time you run a report, a new output window is

created in the Results panel. A new report instance is also created and preserved by the
addition of a new output tab on the Navigation taskbar. Each output tab maintains the
output of the report that generated the corresponding output window. Selecting an output
tab on the Navigation taskbar loads the associated output instance into the output
window.

Single Window. When you click Single Window and run a report, a new browser window
is opened and populated with the report output. As you modify the report, the same
browser window is refreshed each time the report is run. If the browser window is closed
and the report is run, a new browser window is opened again and is refreshed for each
subsequent run. The output is not displayed in the Results panel, and an output tab is
not added to the Navigation taskbar.

New Window. When you click New Window, each time you run a report, a new browser
window is opened and populated with the report output. The output is not displayed in
the Results panel, and an output tab is not added to the Navigation Taskbar.
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Reference: Output View Options
The following are output view options (Arrange) that you can select.

4 Cascade. When you click Cascade, if multiple output windows exist, they are cascaded
diagonally across the Results panel, as shown in the following image. This option does
not affect open browser windows when you select New Window or Single Window.

% Report1|1] - 0x

I % Report1]4]

- 0 Xx
% Report1]5] _Oox
MAX
I Product Quantity

Region Category Sold
Central Video Production 32,463
MidEast Video Production 13,851
MorthEast  Video Production 25,108
MorthWest  Video Production 21,702
SouthBast  Video Production 21,645
SouthWest  Video Production 5,537
West Video Production 19,182

B R
A A e
oA o e

-

-
T R

- A A e e
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4 Tile Horizontally. When you click Tile Horizontally, if multiple output windows exist, they
are tiled horizontally, one above another, across the Results panel, as shown in the
following image. This option does not affect open browser windows when you select New
Window or Single Window.

MAX E|

Product Quantity

Category Sold
Central Video Production 32,463
AAIAC -+ WiAAA Then Auim Haem 17 OR4

MAX

Product Quantity

Category Sold
Central Video Production 32,463
AAIAC -+ WiAAA ThenAuim Haem 17 OR41

MAX

Product Quantity
Region Category Sold
Central Video Production 32,463
AAIAC -+ WiAAA Then Auim Hae 17 OR41

MAX

Product Quantity

Category Sold
Central Video Production 32,463

AAIAC -+ LT Y Y e e 47 oR4

MAX
Product Quantity
Region Category Sold
Central Video Production 32,463
AAIAC -+ WiAAA ThenAuim Haem 17 OR41 -
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4 Tile Vertically. When you click Tile Vertically, if multiple output windows exist, they are
tiled vertically, side by side, across the Results panel, as shown in the following image.
This option does not affect open browser windows when you select New Window or Single
Window.

3 icpoii — o x [ eporiv _ox
MAX MAX MAX MAX MAX MAX
Product: ‘Quanti Product ‘Quanti Product ‘Quantif Product ‘Quantif Product ‘Quantit Product: ‘Quanti
Region Category Sols Region Category Sol Region Category Sole Region Category’ Sole Region Category Sol¢ Region Category Sol
Central Video 32,46 Central Video 32,460 Central Video 32,46 Central Video 32,46 Central Video 32,460 Central Video 32,460
Production Production Production Production Production Production
MidEast Video 13,85 MidEast Video 13,85° MidEast Video 13,85 MidEast Video 13,85 MidEast Video 13,85 MidEast Video 13,85
Production Production Production Production Production Production
NorthEast  Video 25,100 MNorthEast  Video 25,101 NorthEast  Video 25,100 NorthEast  Video 25,100 NorthEast  Video 25,100 NorthEast  Video 25,100
Production Production Production Production Production Production
NeorthWest  Video 21,700 MNorthWest  Video 21,700 NorthWest  Video 21,700 NorthWest  Video 21,700 NorthWest  Video 21,700 NorthWest  Video 21,700
-t adu i i
me] m m]
5,53 5,53 5,53
n Production
19,180 West Video 19,180 West Video 19,18, West Video 19,18 West Video 19,18. West Video 19,180
Production Production Praduction Production Produc tion Production

4 Switch Output. When you click Switch Output, a drop-down menu opens, where you can
select any active report to view the output. The selected report is loaded into the output
window or browser window, depending on the selected output window or tab option.

Reference: Output Format Options

The Output window can display report output in the following formats HTML, HTML5, active
report, active Flash, PDF, and active PDF. Note: Excel and PowerPoint formats open in their
native programs in a window external to InfoAssist.
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The following image shows the HTML report output, which is the default output format, as
displayed in the Output window. The Resources panel appears on the left.
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Stereo Systems
Televisions
Video Plavers
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Stereo Systems
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Stereo Systems
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The following image shows the active report output displayed with an output location of a
new window. The drop-down menu for the last column of data exposes the reporting options.

28 of 28 records, Page 1 of 1

Product Quantity

Category v Region w

Stereo Systems  Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West

Televisions Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West

Yideo Players Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West

6,870

Sort Ascending

Sort Descending

Filter

Calculate

Chart

Rollup

Pivot (Cross Tab)
Visualize

Hide Column

Grid Tool
Chart/Rollup Tool
Pivot Tool

Show Records
Commentz

Send as E-mail

Save Changes
Export
Print

Window

Restore Criginal

WebFOCUS InfoAssist User's Manual

127



Understanding the Results Panel

128

The following image shows the active Flash output displayed with an output location of a

new window.

28 of 28 records, Page 1 of 1

Stereo System: Central
MidEast
MorthEast
Maorth'West
SouthEast
SouthWest
West
Televisions Central
MidEast
MaorthEast
Morth\West
SouthEast
SouthWest
West
Video Plavers Central
MidEast
MorthEast
Maorth'West
SouthEast
SouthWest
West
Wideo Producti Central
MidEast
MaorthEast
Morth\West
SouthEast
SouthWest
West
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The following image shows a PDF report output displayed with an output location of a new

window.

Blsoveacory () 35 @ @ searen 5| &) Thoselect g (R - [ [[f © 1% - @ [03-) [ - A sion~
:% Product [o]TET,14{4%
= Category Region Sold

Stereo Systems Central 11,143
MidEast 4,607

NorthEast 8,735

NorthWest 7,287

SouthEast 7,431

SouthWest 1,832

West 6,638

Televisions Central 7,428
MidEast 3,246

NorthEast 5,578

' NorthWest 5,029
SouthEast 5,031
SouthWest 1,296

West 4,340

Video Players Central 11,647

MidEast 5,043

NorthEast 9,057

P NorthWest 7,869
g SouthEast 7,657
g SouthWest 2,038
. West 6,870
z: Video Production Central 2,245
g MidEast 955
3 MorthEast 1,738
= MorthWest 1,517
L SouthEast 1,526

= lof1

|

The following image shows an active PDF report output displayed with an output location of
a new window.

Note: The active PDF output can only be displayed if you have Adobe Reader 9.0 or later.
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The following image shows an Excel report output displayed with an output location of a new

window.
] WFServlet [Read-Only] - = X
[ 4 A B c b | E | F | & | H i
1
2 Stereo Systems West 47,673
3 Televisions West 31,948
4 Video Players West 50,181
5 Video Production West 9,686 4
6
7]
8
9
10
11
| 12 ]
13
| 14 |
15
4 4 » | AdhocRequest <%0 AT NI i
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The following image shows a PowerPoint report output displayed with an output location of
a new window.
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Using the Navigation Taskbar

The Navigation taskbar provides quick access to all active output windows and to the report
design that generated the output. You can return to the last report that you edited in the
Query Design pane by clicking Display Design View on the taskbar. The Navigation taskbar,
as shown in the following image, is always visible in InfoAssist. It is located near the bottom
of the application window, just above the status bar.

E'l Euum| & | R=portt[0] | & | Re=portt[1] I & | R=portt[7] I & | Reporti[d)] |

Each of the active output windows displays a tab on the Navigation taskbar. Selecting the
tab displays that output window in the Results panel. If you save a report with a unique
name each time you modify it, when the report is executed and a new output window is
generated, the unigue name appears as a tab on the taskbar. If you continue to modify and
execute a report without saving it with a unique name, a number in parentheses is appended
to the original, saved report name to differentiate it among the multiple output windows.

The ability to select report output from the Navigation taskbar depends on the output window
option selected from the status bar or from the Output Window group of the View tab. For
more information, see Using the Status Bar on page 133, or Understanding Output Options
on page 121.
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Each report tab on the Navigation taskbar has a right-click menu with the following options:
Restore

Minimize

Maximize

Close

Load View

£ o v oJ v o

Auto Resize

Restore, Minimize, Maximize, and Close are standard options available in any browser window
or software application. Minimize, Maximize (if the window is not maximized), or Restore (if
the window is maximized), and Close can also be found in the top-right corner of the output
window, as shown in the following image.

% Report2|0] -3 X

s

Product Quantity
Region Catepory Sold
Central VYideo Production 32,463
MidEast Yideo Production 13,851
MorthEast  Video Production 25,108
MorthWest Video Production 21,702
SouthEast  Video Production 21,645
SouthWest  VWideo Production 5,037
‘West VYideo Production 19,182

You can load the underlying report design for each output window into the Query Design
pane by right-clicking any active output window tab on the taskbar and clicking Load View.
The Auto Resize option enables automatic resizing of an output window as needed when
you add or remove fields.

The Query View Tools menu at the far left of the Navigation taskbar provides options for
displaying all active output windows in the Results panel. The display options that you can
select are Cascade, Tile Horizontally, Tile Vertically, Restore All, Minimize All, Maximize All,
or Close All. The name of each active output window appears at the bottom of the menu.

The Query View Tools menu options are directly linked to the options available in the Output
Window group of the View tab.
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Using the Status Bar

The status bar displays the status of the last selected action, a reports button that shows
the number of open reports, an output format button that shows the selected format, and
an output target button that shows the selected option for displaying new output windows
or tabs. The status bar is shown in the following image.

Dane E] 5 Reparts - & THTML - 3 3 Single Tah -

When you click the reports button, a menu opens, with options for selecting any of the open
reports. Each report is listed by name and an icon which represents the report type (report,
chart, document). The report you select becomes active.

When you click the output format button, a menu opens, with options for selecting a different
output format. Output formats include HTML, active report, active Flash, PDF, active PDF,
Excel, Excel 2007, Excel Formula, Excel Pivot, and PowerPoint.

When you click the output target button, a menu opens, with options for Single Tab (default),
New Tab, Single Window, and New Window. For more information, see Understanding Output
Options on page 121.
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You can apply styling to specific areas
of a report to customize its appearance
and functionality. You can also use the
many optional reporting features to add
custom functionality and output formats
to reports.
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Creating and Customizing Reports

Topics:

1 Creating a Basic Report

4 Styling Reports

4 Changing a Field Format

4 Using Custom Reporting Features
m
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Creating a Basic Report

In this section:

Report Outputs

How to:

Create a Report From the BI Portal Tree

Create a Report From the Application Main Menu
Create a Report From the Quick Access Toolbar

Create a Report From an Existing Chart

Procedure: How to Create a Report From the Bl Portal Tree

After you have signed in to the Bl Portal, you can work with an existing folder, or create a
new folder in the tree to store your reports.

1. Right-click the folder that you want to use, point to New, and then click Report.

The Select a data source dialog box opens, as shown in the following image.

Select a data source O x
Look in: |E| Reporting Server EI y IEE

MName |Descri|:|tion |Type |npplit3tion MName | nd
# BROKERS WebFOCUS ihisamp

# CAR WebFOCUS ibisamp -
ﬁ CARCLAP WebFOCUS ibisamp T
# CASHFLOW WebFOCUS ibisamp

# COURSE WebFOCUS ibisamp

é DMLOCS Plant Locations Fixed-format sequential ibisamp

# DMSTARTERM Fixed-format sequential ihisamp

# DMVPX WebFOCUS ibisamp

ﬁ EDUCFILE WebFOCUS ibisamp

# EMPDATA WebFOCUS ibisamp

# EMPLOYEZ WebFOCUS ibisamp

# EMPLOYEE WebFOCUS ibisamp il
et

File name: | |
Files of type: | Master Files Izl

2. From the Select a data source dialog box, select the data source that you want to use,
and click OK.
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3.

The data source that you selected appears in the Data pane of the Resources panel.

Drag and drop fields onto the canvas or into the Query pane to begin building your report.

A basic report is shown in the following image.

Quantity
Region Sold Revenue
Central 42 26,696.44
MidEast 25 13,596.76
MorthEast 34 9.144.28
MorthWest 43  22,6B5.62
SouthEast 34 29,932.52
SouthWest 9 2.118.41
West 32 29,704.27

Procedure: How to Create a Report From the Application Main Menu

1.

In the upper-left corner of the InfoAssist interface, click the IA button to open the
Application Menu.

From the Application Main Menu, click New.

The InfoAssist splash screen opens.

On the InfoAssist splash screen, select Build a Report.

The Select a data source dialog box opens.

From the Select a data source dialog box, select the data source that you want to use,
and click OK.

The data source that you selected appears in the Data pane of the Resources panel.

Drag and drop fields onto the canvas or into the Query pane to begin building your report.

Procedure: How to Create a Report From the Quick Access Toolbar

1.

On the Quick Access Toolbar, click the New icon.

The InfoAssist splash screen opens.

On the InfoAssist splash screen, select Build a Report.

The Select a data source dialog box opens.
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4,

From the Select a data source dialog box, select the data source that you want to use,
and click OK.

The data source that you selected appears in the Data pane of the Resources panel.

Drag and drop fields onto the canvas or into the Query pane to begin building your report.

Procedure: How to Create a Report From an Existing Chart

1.
2.

Open the chart that contains the data that you want to present in a report.
On the Home tab, in the Format group, click Report.

The data is presented as a report.

Report Outputs

138

The following output types are available for reports:

d

-

d

-

d

HTML

active report
active Flash
PDF

active PDF
Excel

PowerPoint

Note: When you create a report in Document view, you have access to Excel only.

When you create a report in Live Preview or Query Design view you have access to the
following Excel output types:

-

d

-

Excel. Outputs the report in Excel format.
Excel 2007. Outputs the report in Excel 2007 format.

Excel Formula. Outputs the report using native Excel formulas for totals and computed
values.

Excel Pivot. Outputs the report in Excel with pivot table processing.
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Styling Reports

How to:

Perform Report-Level Styling

Perform Field-Level Styling in a Report

Add Headings and Footings to a Report

Style Headings and Footing in a Report

Style Rows of Data With Alternating Colors in a Report

Apply Traffic Light Conditional Styling to a Report (By Constant)
Apply Traffic Light Conditional Styling to a Report (By Field)
Use Cell Padding in a Report

You can apply custom styling to specific areas of a report. When creating a report in
InfoAssist, you can perform the following styling customization.

d

Global styling for the entire report. For more information, see How to Perform Report-Level
Styling on page 139.

Style data and column titles. For more information, see How to Perform Field-Level Styling
in a Report on page 142.

Style headings and footings. For more information, see How to Style Headings and Footing
in a Report on page 148.

Style the rows of data with alternating colors. For more information, see How to Style
Rows of Data With Alternating Colors in a Report on page 148.

Apply traffic light conditional styling to data. For more information, see How to Apply Traffic
Light Conditional Styling to a Report (By Constant) on page 149 and How to Apply Traffic
Light Conditional Styling to a Report (By Field) on page 151.

Increase or decrease the amount of space inserted between rows and columns. For more
information, see How to Use Cell Padding in a Report on page 152.

Procedure: How to Perform Report-Level Styling

You can style an entire report.

1.
2.

Create a report.

On the Home tab, in the Report group, click Style.
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The Report Style dialog box opens.

£= Report Style x

| TREBUCHET M5 E' g |:|

B oo

| Ed|s|®

Preview

TREBLUCHET MZ 9

3. Select any of the following styling options that are available in the Style group.

-

d

-

-

Font. Use the menu to change the font.
Font size. Use the menu to change the numeric value for the font size.

Font style. Click the appropriate button (bold, italic, underline) to style the selected
text.

Text alignment. Click the appropriate button (left, center, right) to align the selected
text.

Font color. Click the button to open the Color dialog box, where you can select the
font color.

Background color. Click the button to open the Color dialog box, where you can
select the background color for the report.

Currency symbol. Click the appropriate button (US dollar, British Pound, Japanese
Yen, Euro, New Israeli Shekel).

Style Reset. Click the Reset to Quick Styles from Template button to reset all settings
to the default settings from the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK,
all changes are committed. To undo global styling after it has been committed, you
must use the Undo command on the Quick Access Toolbar.

Preview. Displays the text as you have formatted it.

4. Click OK. The report is styled accordingly.
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The following image shows a report using the style that had been selected in the Options
dialog box (medium blue). In this style, Trebuchet MS 9 pt. black is the default font.

Product
Category
Stereo Systems
Televisions
Video Plavers
Stereo Systems
Televisions
Video Playvers
Stereo Systems
Televisions
Video Plavers
Stereo Systems
Televisions
Video Playvers
Stereo Systems
Televisions
Video Plavers
Stereo Systems
Televisions
Video Playvers
Stereo Systems
Televisions

Video Plavers

Region
Central

MidEast

MorthEast

HorthWest

SouthEast

SouthWest

West

WebFOCUS InfoAssist User's Manual

Quantity

Sold
11,143
7,428
11,647
4,607
3,246
5,043
8,735
5,578
9,057
7,287
5,029
7,869
7,431
5,031
7,657
1,832
1,29
2,038
6,638
4,340
6,870

Revenue
3,027,276.42

10,131,328.09

3,835,578.36
1,254,014.44
4,256,202.11
1,653,244.82
2,381,435.14
7,452,259.19
2,980,605.73
2,043,976.10
6,713,008.94
2,602,775.63
2,034,149.11
6,793,602.47
2,500,094.24

494,200.80
1,705,461.80

670,346.72
1,782,370.94
5,927,165.23
2,248,798.50
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The following image shows the same report with the font changed to Helvetica 12 pt.
in blue (Red 0, Green 0, Blue 255) with a white background (Red 255, Green 255, Blue
255).

Region
Central

MidEast

NorthEast

NorthWest

SouthEast

SouthWest

West

Product
Category
Stereo Systems
Televisions
Video Players
Stereo Systems
Televisions
Video Players
Stereo Systems
Televisions
Video Players
Stereo Systems
Televisions
Video Players
Stereo Systems
Televisions
Video Players
Stereo Systems
Televisions
Video Players
Stereo Systems
Televisions
Video Players

Quantity
Sold

11,143
7,428
11,647
4,607
3,246
5,043
8,735
5,578
9,057
7,287
5,029
7,869
7,431
5,031
7,657
1,832
1,296
2,038
6,638
4,340
6,870

Procedure: How to Perform Field-Level Styling in a Report

Revenue
3,027,276.42
10,131,328.09
3,835,5678.36
1,254,014.44
4,256,202.11
1,653,244.82
2,381,435.14
7,452,259.19
2,980,605.73
2,043,976.10
6,713,008.94
2,602,775.63
2,034,149.11
6,793,602.47
2,500,094.24
494,200.80
1,705,461.80
670,346.72
1,782,370.94
5,927,165.23
2,248,798.50

You can style data, column titles, or both, in the report output for the selected data source

field.

1. Create a report.

2. In the Query Design pane, select a data source field.

The Field tab appears on the ribbon.

142
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3. In the Style group, click one of the following;:
1 Data Style. Styles only the data for the selected data source field.
1 Title Style. Styles only the column title for the selected data source field.
41 Data + Title. Styles both the data and the column title for the selected data source
field.
4. Select any of the following styling options that are available in the Style group.
4 Font. Use the menu to change the font.
-1 Font size. Use the menu to change the numeric value for the font size.

4 Font color. Click the button to open the Color dialog box, where you can select the
font color.

41 Style Reset. Click the Reset styling to default style button to reset all settings to
the default settings from the template.

Note: Reset only works while the Report Style dialog box is open. Once you click OK,
all changes are committed. To undo global styling after it has been committed, you
must use the Undo command on the Quick Access Toolbar.

4 Font style. Click the appropriate button (bold, italic, underline) to style the selected
text.

4 Text alignment. Click the appropriate button (left, center, right) to align the text.

4 Background color. Click the button to open the Color dialog box, where you can
select the background color for the report.

5. Click OK. The report is styled accordingly.
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The following image shows a report with the default formatting and the Revenue data
column selected for styling.

MidEast

MaorthEast

MorthWest

SouthEast

SouthWest

West

Catepo

Stereo Systems
Televisions
Yideo Plavers
Stereo Systems
Televisions
Video Plavers
Stereo Systems
Televisions
Yideo Plavers
Stereo Systems
Televisions
Video Plavers
Stereo Systems
Televisions
Yideo Plavers
Stereo Systems
Televisions
Video Plavers
Stereo Systems
Televisions
Yideo Playvers

14
&
&
7
&
B

11

10
14
1
11
10

o = MIowD LR

10

3,075.02
10,341.19
2,153.94
889.93
B,821.97
2,396.92
2,227.90
647.48
3.344.90
4,075.92
11,897.36
3,594.89
3,267.01
11,399.67
3.136.M
409.98
299.99
949,46
2,143.22
24,093.18
1,549.%%
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The following image shows the Revenue data column styled to display the American
dollar sign ($) as the currency symbol.

Product Quantity
Region Catepory Sold Revenue
Central Stereo Systems 11,143 53,027,276.42
Televisions 7,428 510,131,328.09
Video Players 11,647  53,835,578.36
MidEast Stereo Systems 4,607 51,254,014.44
Televisions 3,246 54,256,202.11
Videao Plavers 5,043 51,603,244.82
MorthEast  Stereo Systems B,735 52,381,435.14
Telewvisions 5,578 57,452,259.19
Video Players 9,057  52,9B0,605.73
MorthWest  Stereo Systems 7,287 52,043,976.10
Televisions 5,029  56,713,008.%4
Video Players 7,869 52,602,775.63
SouthEast  Stereo Systems 7,431 52,034,14%.11
Televisions 5,031 56,793,602.47
Video Players 7,657 52,500,094.24
SouthWest  Stereo Systems 1,832 54%4,200.80
Televisions 1,296  51,705,461.80
Yideo Players 2,038 5670,346.72
‘West Stereo Systems f,638 §1,782,370.94
Televisions 4,340  55,927,165.23
Video Players 6,870  52,248,798.50

Procedure: How to Add Headings and Footings to a Report

You can make a report more meaningful by adding headings and footings. Headings and
footings supply context and key information about a report, such as its purpose and audience.
Headings and footings also provide structure, helping you navigate to the detail sought. They
enhance visual appeal.

In this procedure, you will add and style a report heading and page heading. The procedure
uses sample values, but you can supply values that apply to your own, reports.

Headings and Footings are available in Query Design view, Live Preview, and Document view.

1. Create a report.
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On the Home tab, in the Report group, click the Header & Footer button.

The Header & Footer dialog box opens.

Click the tab for the heading or footing element that you want to add.

For a report, you can add a report heading, page heading, page footing, or report footing.
By default, the Report Header tab is selected. In this procedure, accept the default.

Click inside the design area of the dialog box, and type the text for the heading.
For example, the text for a sample report heading might be Quantity Sold by Product.

Using the styling ribbon, apply styling to the report heading text.

For example, click the arrow next to the font field, and click HELVETICA. Click 11 for the
font size.

The sample report heading with the selected styling values is shown in the following
image.

EsHeader & Footer o x
Report Header Page Header B3 Page Footer

HELYETICA ﬂ

Quantity Sold by Product

“Cancel ' ia Apply

Click Apply to save the changes you have made so far, without closing the dialog box.
To add a page heading, click the Page Header tab.

In this procedure, you are going to add one of the supplied quick text options.

Click the last button @ i (Insert preformatted text content for headers/footers) on the
right of the styling ribbon, and click Confidential in the list.

Change the font and font size. For example, change the font to HELVETICA and the size
to 10.
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You can add your own text before or after the supplied text, for example, For Regional
Managers Only.

ETIJ' eader & Footer

pork Header age Header

HELVETICA =

Confidential
For Regional Managers Only

= Cancel 2 Apply

10. Click OK to save the report heading and page heading and close the Header & Footer
dialog box.

The report heading and page heading that you added and styled are shown in Live Preview
in the following image.

W Interactive Design Yiew

Quantity Sold by Product

Confidential
For Regional Managers Only

Product Quantity
Catepol Sold
Stereo Systems 132
Televisions i
Yideo Players 108
Video Production 23

11 To make changes, to either the report, or page heading, right-click the heading and click
Edit in the menu.
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Procedure: How to Style Headings and Footing in a Report

You can style headings and footings in the report output for the selected heading or footing

field.
1. Create a report.
2. With the report opened in Live Preview, select the heading or footing text that you want
to style.
3. On the Home tab, in the Report group, click Header & Footer.
The Header & Footer dialog box opens.
4. Select any of the following styling options that are available in the Style dialog box.
<4 Font. Use the menu to change the font.
4 Font size. Use the menu to change the numeric value for the font size.
4 Font style. Click the appropriate button (bold, italic, underline) to style the selected
text.
4 Text alignment. Click the appropriate button (left, center, right) to align the selected
text.
<4 Font color. Click this button to open the Color dialog box, where you can select the
font color.
4 Background color. Click this button to open the Color dialog box, where you can
select the background color for the report.
<4 Reset to Quick Styles from Template. Click this button to reset all settings to
the default settings from the template.
Note: Reset only works while the Report Style dialog box is open. Once you click OK,
all changes are committed. To undo global styling after it has been committed, you
must use the Undo command on the Quick Access Toolbar.
5. Click OK. The report is styled accordingly.

Procedure: How to Style Rows of Data With Alternating Colors in a Report

148

You can style rows of data in a report with alternating colors.

1.
2.
3.

Create a report.
Open the report in Live Preview.

On the Home tab, in the Report group, click Banded.
The Color dialog box opens.
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4. Select a color.

5. Click OK.

The selected color provides an alternating color scheme for the report. The report output
displays alternating rows of data, using a white background for one row and a background
of the selected color for the next row. This pattern continues throughout the report, as
shown in the following image of Banded report output.

Product Quantity

Category Sold Gross Profit
Stereo Systems 47,673 3,933,147.95
Televisions 31,948 B,266,357.83
Video Players 50,181 4,422,423.00
Yideo Producton 9,686 2,064,832.62

Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Constant)

You can apply traffic light conditional styling to data for a selected measure field. By default
the report displays the values that satisfy the first condition in green, and the values that
satisfy the second condition in red.

1. Open a report in Live Preview.

2. Open the Traffic Light Condition dialog box in one of the following ways:

d

Ribbon: Select a field on the report, and then on the Field tab, in the Display group,
click Traffic Lights.

Right-Click Menu: Right-click a field on the report, point to More, and then click
Traffic Light Conditions.

The Traffic Light Condition dialog box opens.

3. From the Relational Operators drop-down menu below the field name, click a relational
operator.

The options are:

d

-

d

Equal to

Not equal to
Greater than
Less than

Greater than or equal to
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d Less than or equal to

In the field to the right of the operator drop-down menu, click the down arrow for the
Type drop-down menu.

The Type dialog box opens.
In the Type dialog box, click Constant.
Enter a value in the Value field, or

a. From the Get Values drop-down menu, select one of the following values All, First,
Last, Minimum, Maximum, From File. The value that you select appears in the Get
Values field.

b. Select the value in the Get Values field. The value that you selected appears in the
Value field.

Click OK.

The value that you selected appears in the field to the right of the operator drop-down
menu.

Click the Color button.
The Color dialog box opens.

Select a color.

Click OK.

The color appears in the Preview box.

Click the Drill Down button.

The Drill Down dialog box opens.

In the Drill Down dialog box, specify each of the following:
4 Drill down to a report or a web page

<4 URL of the web page

< An alternate comment

4 Target (New Window, Same Window)

4 Parameters that you want to use (Name, Value)

13 Click OK to close the dialog box.
14. Click the New button to set traffic light conditions for additional fields.

WebFOCUS



4. Creating and Customizing Reports I

Procedure: How to Apply Traffic Light Conditional Styling to a Report (By Field)

You can apply traffic light conditional styling to data for a selected measure field. By default
the report displays the values that satisfy the first condition in green, and the values that
satisfy the second condition in red.

1. Open areport in Live Preview.

2. Open the Traffic Light Condition dialog box in one of the following ways:

4 Ribbon: Select a field on the report, and then on the Field tab, in the Display group,
click Traffic Lights.

<4 Right-Click Menu: Right-click a field on the report, point to More, and then click
Traffic Light Conditions.

The Traffic Light Condition dialog box opens.
3. From the drop-down menu below the field name, select a relational operator.
The options are:
4 Equal to
4 Not equal to
<4 Greater than
4 Less than
4 Greater than or equal to

d Less than or equal to

4. |In the field to the right of the operator drop-down menu, click the arrow for the Type
drop-down menu.

The Type dialog box opens.

5. In the Type dialog box, select Field.

The Type dialog box displays the Dimensions, and Measures and Properties of your
data. You can display the data in the following ways:

4 View fields in business order. Select from the following options Title, Description,
Name, Alias.

4 View fields in a sortable grid. Select from the following options Name, Title, Alias,
Format, Segment, Filename, Description, Reference.

4 View the hierarchical structure of the data. Select from the following options Title,
Description, Name, Alias.
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Select a field.

Click OK.

The field that you selected appears in the field to the right of the operator drop-down
menu.

8. Click the Color button.

The Color dialog box opens.

9. Select a color.

The color appears in the Preview box.

E B

Click OK.
Click the Drill Down button.

The Drill Down dialog opens.

12 |n the Drill Down dialog, specify each of the following:

-

d

-

d

-

Drill down to a report or a web page
URL of the web page

An alternate comment

Target (New Window, Same Window)

Parameters that you want to use (Name, Value)

13 Click OK.
14. Click the New button to set traffic light conditions for additional fields.

How to Use Cell Padding in a Report

You can customize the amount of space inserted between rows and columns in a report.

1. Open areport in Live Preview.

2. On the Layout tab, in the Report group, open the Cell Padding menu.

3. On the Cell Padding menu, click Custom.
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The Cell Padding dialog box opens.

i1 Cell Padding [alx]
5 0K <9 Reset (§) Cancel
Top: 0.0  Mehes  pogom, 00 inches
Lefr: 0.0 inches Right: 0.0 inches
Ready ﬁE

4. Type the cell padding values that you want in the Top, Bottom, Left, and Right fields.

5. Click OK.

The report reflects the cell padding that you set.

The following image shows a report with default cell padding.

Product Quantity

Catego Sold Revenue
Stereo Systems 132 40,5%0.03
Televisions 71 112,961.49
Yideo Plavers 108 33,606.42
Video Production 23 22,183.66

The following image shows the same report with a cell padding of 0.01 inches added
to the top, bottom, left, and right of the cell.

Stereo Systems

Televisions

Yideo Players

Yideo Production
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132 40,590.03
71 112,961.4%
108 33,606.42
23 22,183.66
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Changing a Field Format

How to:

Assign an Alphanumeric Format
Assign a Numeric Format
Assign a Date Format

Assign a Date-Time Format

Add a Percent Sign to a Numeric Field

You can change the format of any field except a Sort field. You can change the format of
measures, as well as any calculated fields. The following image shows the Field Format
Options dialog box.

%] Field Format Options

Field type: Display options:
Alphanumeric [] Floating Currency (M) [] Percent (=&)
Floating point [T mon floating Dollar (M) [] scientific Notation (E)
Integer
Ea?:ad [] use Comma (C) [ suppress Comma (c)
a

Date-Time

[[] Leading Zeros (L) [] suppress Zeros (5)
Sample:

123456789.01
[] Bradkets Megative {8) [ credit negative (R)

Field Length {1-20) Decmals (0-18)

The following procedures show how to change a field format from the Field Format Options
dialog box. For more information on how to use the Format group options, see Field Tab on
page 85.

Procedure: How to Assign an Alphanumeric Format

1. With a report open in Live Preview, right-click a virtual field or column Measure field, and
select Edit Format.
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The Field Format Options dialog box opens.

From the Field type list, select Alphanumeric.

To assign a different length, specify a number between 1 and 4095 in the Total length
field. The default value is 20.

4. Click OK to close the Field Format Options dialog box and return to the Results Panel.

The new format appears in the previously selected column.

Procedure: How to Assign a Numeric Format

1. With a report open in Live Preview, right-click a virtual or column Measure field, and
select Edit Format.

The Field Format Options dialog box opens.

2. From the Field type list, click one of the following options:
4 Floating Point (default length 7.2)
< Integer (default length 5)
4 Decimal (default length 12.2)
4 Packed (default length 12.2)

If the selected field matches the selected format type, its current length appears in the
Field Length field. Otherwise, the default length appears in the Field Length field. The
Decimals field shows the numbers of decimal places for Floating Point, Decimal, and
Packed.

3. To assign a different length, specify it in the Field Length field for format types as follows:
1-9 for Floating Point, 1-11 for Integer, 1-20 for Decimal, and 1-33 for Packed.

4. To assign a different number of decimal places for Floating Point, Decimal, or Packed,
specify the number in the Decimals field.

5. Click OK to close the Field Format Options dialog box and return to the Results Panel.

The new format appears in the previously selected column.

Procedure: How to Assign a Date Format

1. With a report open in Live Preview, right-click a virtual or column Measure field, and
select Edit Format.

The Field Format Options dialog box opens.
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From the Field type list, click Date.

To assign a different date display format, select a date format from the Date Format
list.

The default date display format is MDY.

Click OK to close the Field Format Options dialog box and return to the Results Panel.

The new format appears in the previously selected column.

Procedure: How to Assign a Date-Time Format

Procedure:
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1.

With a report open in Live Preview, right-click a virtual or column Measure field, and
select Edit Format.

The Field Format Options dialog box opens.

From the Field type list, click Date-Time.

To assign a different date-time format, select the date format you want to use from the
Date Format list. Expand Year First, Month First, or Day First to see the available options.

Select a time format (if applicable) from the Time Format list. Expand Hour First, Minute
First, or Seconds First to see the available options.

If you select the Time Only check box then you can only set a time format.

Click OK to close the Field Format Options dialog box and return to the Results Panel.

The new format appears in the previously selected column.

How to Add a Percent Sign to a Numeric Field

You can add a percent sign to the end of a numeric value (Decimal, Integer, and Floating
Point formats). This numeric display option includes a percent sign along with the numeric
data, but does not calculate the percent.

1.

With a report open in Live Preview, right-click a virtual or column Measure field, and
select Edit Format.

The Field Format Options dialog box opens.

From the Field type list, click a numeric value format (Floating point, Integer, Decimal,
or Packed), and then select the Percent (%) check box.

Click OK to close the Field Format Options dialog box and return to the Results Panel.

The new format appears in the previously selected column.
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Using Custom Reporting Features

How to:

Rank Fields in a Report

Limit the Values of a Column in a Report

Add Page and Line Breaks to a Report

Add Subtotals to a Report

Add Column Totals to a Report

Add Row Totals to a Report

Add Subheadings and Subfootings to a Report
Add Pop-Up Titles to a Report

Add Data Visualization Bars to a Report
Display Measure Data Using Aggregation Options in a Report
Display Repeated Sort Values in a Report

Recalculate the Result of a Compute Command

You can use the following custom features when creating reports in InfoAssist.

o

Rank. Inserts a ranking column for By and Measure fields in a report. For more
information, see How to Rank Fields in a Report on page 158.

Limit. Limits the number of unique variables in a column. For more information, see How
to Limit the Values of a Column in a Report on page 159.

Page Breaks. Starts a new page in the output when the primary sort field changes. For
more information, see How to Add Page and Line Breaks to a Report on page 159.

Line Breaks. Inserts a line in the report output when the primary sort field changes. For
more information, see How to Add Page and Line Breaks to a Report on page 159.

Subtotal. Inserts subtotals in the output for all numeric fields when the primary sort
field changes. For more information, see How to Add Subtotals to a Report on page 160.

Column Totals. Inserts a grand total row at the bottom of the report to sum numeric
data in each column. For more information, see How to Add Column Totals to a Report
on page 163.

Row Totals. Inserts a grand total column to the right side of the report to sum numeric
data in each row. For more information, see How to Add Row Totals to a Report on page
164.
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Sub Header. Adds a subheading just below the column titles in the report output when
the primary sort field changes. For more information, see How to Add Subheadings and
Subfootings to a Report on page 164.

Sub Footer. Adds a subfooting at the end of the data on each page of the report output
when the primary sort field changes. For more information, see How to Add Subheadings
and Subfootings to a Report on page 164.

Pop-up Titles. Adds pop-up titles to report output when the mouse pointer hovers over
a column title. For more information, see How to Add Pop-Up Titles to a Report on page
165.

Data Bars. Adds data visualization bars to numeric data. For more information, see How
to Add Data Visualization Bars to a Report on page 165.

Aggregation. Displays numeric measure data using aggregation options other than the
default of Sum. For more information, see How to Display Measure Data Using Aggregation
Options in a Report on page 166.

Repeat Sort Values. Displays all repeated sort values instead of blanks after the first
instance of a new sort value appears in the report. The default behavior is to display
blanks after the first instance of a new sort value. For more information, see How to
Display Repeated Sort Values in a Report on page 168.

Recompute. Recalculates the result of a Compute command. Recompute is similar to
Subtotal in that it recalculates only at the specified sort break. For more information,
see How to Recalculate the Result of a Compute Command on page 170.

How to Rank Fields in a Report

You can add rank columns to the By and Measure fields in a report by clicking the Rank
button. You access the Rank button, on the Field tab, in the Sort group.

-

Adding a rank column to a By field inserts a rank column immediately to the left of the
field.

Adding a rank column to a Measure field creates a copy of the column as a By field and
adds a rank column to the left of the new By field.

Note: The rank option can also be accessed by right-clicking a By or Measure field and
accessing the Rank option through the right-click menu.

1.

2.

With a report open, in the Query Design pane, select a By or a Measure field.

The Field tab appears on the ribbon.

In the Sort group, click Rank.
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A rank column appears, as shown in the following image.

Product Quantity
RANK Category Sold Revenue
1 Stereo Systems 47,673 13,017,422.95
2 Televisions 31,948 42,979,027.83
3 Video Players 50,181 16,491,444.00
4  Video Producton 9,686 9,281,163.62

Note: The rank column can now be edited and formatted like any other column, with
the following exceptions:

1 The only formatting that can be applied is Traffic Light Conditions.
4 |t cannot be hidden.

1 You cannot insert breaks or a filter on the RANK column.

]

No column can be moved in between the rank column and the column it is ranking.

Procedure: How to Limit the Values of a Column in a Report

You can limit the number of unique values that appear in a column through the Limit menu.
First you must select a column, then the Limit menu becomes available on the Field tab, in
the Sort group.

Note: You can also access the Limit option by right-clicking a column, pointing to Sort, and
then selecting Limit.

1. With a report open, in the Query Design pane, right-click a By or Measure field.

The Field tab appears on the ribbon.
2. In the Sort group, enter a value in the Limit field, or select a value from the list. The

number of unique values that appear in the column is now limited to value that you set.

Procedure: How to Add Page and Line Breaks to a Report
You can add page breaks and line breaks to report output for the primary sort field.
1. With a report open, in the Query Design pane, select a By (sort) field.
The Field tab appears on the ribbon.

2. From the Break group, click Page Break or Line Break.

WebFOCUS InfoAssist User's Manual 159



Using Custom Reporting Features

Procedure: How to Add Subtotals to a Report
1. With a report open, in the Query Design pane, select a By (sort) field.
The Field tab appears on the ribbon.

2. From the Break group, click Subtotal.

If you select Page Break, a new page is created every time the value of the primary sort
field changes. Each page includes a new set of column titles, as shown in the following

image.

Product Quantity
Category Sold Revenue

Central Stereo Systems 11,143 3,027,276.42
Televisions 7,428  10,131,328.09
Video Players 11,647  3,835,578.36
Video Production 2,245 2,166,591.20
Product Quantity
Category Sold

MidEast Stereo Systems 4,607 1,254,014.44
Televisions 3,246 4,256,202.11
Video Players 5,043 1,653,244.82
Video Producton 955 896,178.80
Product Quantity
Category Sold

MorthEast  Stereo Systems B,735  2,381,435.14
Televisions 5,578  7,452,259.19
Video Players 9,067  2,980,605.73
Yideo Production 1,738 1,723,425.57
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If you select Line Break, a new divider line is inserted in the report output every time
the value of the primary sort field changes, as shown in the following image.

3t Catepo Wwenue
Central Stereo Systems 14 3,075.02
Televisions B 10,341.19

Yideo Plavers b 1.673.95

VWideo Production 3 964.39

MidEast Stereo Systems ¥ BA%.93
Televisions B 8,821.97

Video Players B 2,396.92

Yideo Production 2 478.00

MorthEast Stereo Systems 10 2,059.90
Televisions 1 297.49

Video Players 10 3,344,90

VWideo Production 1 269.10
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Clicking Subtotal turns Subtotal on for all fields as a RECOMPUTE and inserts a line of
descriptive text (*Subtotal FIELD Value). Clicking the down arrow launches a menu of
options. From this menu, you can choose between simple and recompute. Selecting
More Options opens a dialog box from which you can choose which fields to subtotal,
as well as what type of aggregation to do for those fields. You can also change the
Subtotal text.

Product Quantity
Catepory Sold
Central Stereo Systems 11,143 3,027,276.42
Televisions 7,428 10,131,328.0%
Video Players 11,647 3,B35,578.36
Yideo Production 2,245 2,166,5%1.20
Subtotal: Central 19,160,774.07
MidEast Stereo Systems 4,607 1,254,014.44
Televisions 3,246 4,256,202.11
Video Players 5,043 1,653,244.82
Yideo Producton 955 896,178.80
Subtotal: MidEast 8,059,640.17
MorthEast Stereo Systems B,735 2,381,435.14
Televisions 5,578 7,452,259.19
Video Players 9,057 2,980,605.73
Yideo Production 1,738 1,723,425.57
Subtotal: NorthEast 25,108 14,537,715.63
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Procedure: How to Add Column Totals to a Report

On the Home tab, in the Report group, click Column Totals.

Clicking Column Totals adds a grand TOTAL row at the bottom of the report that sums numeric
data in each column, as shown in the following image.

Product Quantity
Region Catepory Sold
Central Stereo Systems 11,143
Televisions 7,428
Video Players 11,647
Yideo Production 2,245
MidEast Stereo Systems 4,607
Televisions 3,246
Video Players 5,043
Video Production 955
MorthEast Stereo Systems B,735
Televisions 5,578
Video Players 9,057
Yideo Production 1,738

TOTAL

Revenue
3,027,276.42

10,131,328.09

3,835,578.36
2,166,591.20
1,254,014.44
4,756,202.11
1,653,244.82

896,178.80
2,381,435.14
7,452,259.19
2,980,605.73
1,723,425.57
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Procedure: How to Add Row Totals to a Report

Procedure:

164

On the Home tab, in the Report group, click Row Totals.

Clicking Row Totals adds a grand TOTAL column to the right side of the report that sums

numeric data in each row, as shown in the following image.

Product
Catepory
Stereo Systems
Televisions
VYideo Plavers
Video Production
Stereo Systems
Televisions
VYideo Plavers
Video Production
MorthEast Stereo Systems
Televisions
VYideo Plavers
Video Production

Region
Central

MidEast

Quantity

Sold
11,143
7,428
11,647
2,245
4,607
3,246
5,043
955
8,735
5,578
9,057
1,738

Revenue
3,027,276.42
10,131,328.09
3,835,57B.36
2,166,591.20
1,254,014.44
4,256,202.11
1,653,244.82
8%6,178.80
2,381,435.14
7,452,259.1%
2,980,605.73
1,723,425.57

MSRP TOTAL
3,182,253.10  6,220,672.52
10,644,911.84  20,783,667.93
4,027,553.53  7,B74,778.89
2,298,225.94  4,467,062.14
1,315,480.81  2,574,102.25
4,495 671.02  8,755,119.13
1,746,289.57  3,404,577.39
950,618.84  1,847,752.64
2,513,345.35  4,903,515.49
7,837,476.74  15,295,313.93
3,133,979.43  6,123,642.16
1,814,322.39  3,539,485.9%

How to Add Subheadings and Subfootings to a Report

You can add subheadings and subfootings to report output for the sort field.

1. With a report open, in the Query Design pane, select a By (sort) field.

The Field tab appears on the ribbon.

2. From the Break group, click Sub Header or Sub Footer.

The Sub Header & Sub Footer dialog box opens.

3. Inthe Sub Header & Sub Footer dialog box, type and style the text, and click OK.
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Procedure:

Procedure:

Subheadings appear just below the column titles in the report output every time the
value of the primary sort field changes. Subfootings appear at the end of the data on
each page of the report output every time the value of the primary sort field changes.
The following image shows how subheadings and subfootings appear in the report output.

Product Quantity
Region Category Sold Revenue MSRP TOTAL
Central Stereo Systems 11,143 3,027, 276.42  3,182,253.10  6,220,672.52
Televisions 7,428 10,131,328.0% 10,644,%11.84 20,783,667.93
Video Players 11,647  3,835,578.36  4,027,553.53  7,B74,778.89
Video Production 2,245 2,166,591.20  2,298,225.94  4,467,062.14

This is a subfooter

How to Add Pop-Up Titles to a Report
On the Format tab, in the Features group, click Title Popup.

Clicking Title Popup displays a pop-up title when the mouse pointer hovers over any column
title in the report, as shown in the following image.

Revenue

3,027,276.42  3,182,253.10  6,220,672.52
Televisions 7,428 10,131,328.09 10,644,%11.84 20,783,667.93
Video Players 11,647  3,835,578.36  4,027,553.53  7,B74,778.8%
Video Production 2,245 2,166,591.20  2,298,225.94  4,467,062.14

How to Add Data Visualization Bars to a Report

You can add data visualization bars to the report output for a selected numeric data source

field.

1. With a report open, in the Query Design pane, select the numeric data source field.

The Field tab appears on the ribbon.

2. In the Display group, click Data Bars.

WebFOCUS InfoAssist User's Manual
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A data visualization column appears to the right of the selected numeric data source
field to display values in each row. The column uses horizontal bars that extend from
left to right and vary in length, depending on the corresponding data values. The following
image is an example of report output with data visualization bars.

Product Quantity
Region Category Sold Revenue
Central Stereo Systems 11,143 3,027,276.42
Televisions 7,428 10,131,228.09 N
Video Players 11,647  3,835,576.3¢
Video Productaon 2,245 2,166,591.20 N
MidEast Stereo Systems 4,607 1,254,014.44 W
Televisions 3,246 4,256,202.11 |
Video Players 5,043  1,653,244.82 W
Video Productaon 955 Bo6,178.80 I
MorthEast Stereo Systems B,735  2,381,435.14 N
Televisions 5,578 7,452,259.19 [
Video Players 9,057  2,980,605.73
Video Productaon 1,738 1,723,425.57 W

Procedure: How to Display Measure Data Using Aggregation Options in a Report

166

You can display numeric measure data using a variety of aggregation type values other than

the default of Sum.

1. With a report open, in the Query Design pane, select the numeric measure data source

field.

The Field tab appears on the ribbon.

2. Access the Aggregation Functions menu by doing one of the following;:

4 From the Display group, click Aggregation.

1 Right-click the selected measure field and click More Aggregation Functions.

The Aggregation Functions menu opens. It contains the following options:

4 Sum
1 Average

4 Count

WebFOCUS



4. Creating and Customizing Reports I

-

d

Count Distinct
Percent of Count
First Value

Last Value
Maximum
Minimum

Total

Percent

Row Percent

Average Square

If you change the Measure field container from Sum to Print, Count, or List, it overrides

all assigned aggregation type values.

The following image is an example of the MIN (minimum), MAX (maximum), and AVE
(average) aggregation prefix operators added to measure fields in the Query Design
pane.

—| @ Query
= X sum
Fl MIN.Quantity,Sold
B MAX, Quantity,Sold

Jifl

By
B Region

B Product,Category

IOT
B Across
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Procedure: How to Display Repeated Sort Values in a Report

168

The following image is an example of report output produced by assigning the Minimum

and Maximum aggregation options to measure fields in a report.

Central

MidEast

MorthEast

Stereo Systems
Televisions

Video Plavers
Video Production
Stereo Systems
Televisions

Video Plavers
Video Production
Stereo Systems
Televisions

Video Plavers
Video Production

—_— e i e e i i e e el i e

=

O e o N N S A

On the Format tab, in the Features group, click Repeat Sort Value.

Run this procedure when the output format, Excel, for example, does not sort properly.

When you click Repeat Sort Value, all repeated sort values appear in the report output. This
option overrides the default behavior, which displays blanks after the first instance of each
new sort value that appears in the report.
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The first image shows a report before Repeat Sort Value is applied.

Product Quantity
Region Catepory Sold
Central Stereo Systems 11,143
Televisions 7,428
Video Players 11,647
Video Producton 2,245
MidEast Stereo Systems 4,607
Televisions 3,246
Video Players 5,043
Video Production D55
MorthEast Stereo Systems B,735
Televisions 5,578
Video Players 9,057
Video Producton 1,738

The second image shows the same report with Repeat Sort Value applied.

Product Quantity
Region Category Sold
Central Stereo Systems 11,143
Central Televisions 7,428
Central Video Plavers 11,647
Central Yideo Production 2,245
MidEast Stereo Systems 4,607
MidEast Televisions 3,246
MidEast Video Players 5,043
MidEast Video Production 955
MorthEast Stereo Systems B,735
MorthEast Televisions 5,578
MorthEast Video Players 9,057
MorthEast Video Production 1,738
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Procedure: How to Recalculate the Result of a Compute Command

For more information on the compute command, see Calculation Group on page 62.

1.

With a report open, in the Query Design pane, select a By (sort) field.
The Field tab appears on the ribbon.

You can recalculate the result of a Compute command in one of the following ways:

-1 Ribbon: On the Field tab, in the Break group, open the Subtotal menu. On the menu,
click Recomputed.

4 Right-Click Menu: Right-click a sort field, point to Break, then Subtotal, and then
click Recomputed.

Note: Recompute is not available for Across fields.

Creating Customized Report Outputs

170

How to:

Create OLAP Reports

Create Table of Contents Reports
Freeze Column Titles in a Report
Create Pages On Demand Reports
Create Accordion Reports

Implement Stack Measures

In addition to HTML, active report, active Flash, PDF, active PDF, Excel, and PowerPoint

o

output formats, you can create the following custom report output formats.

OLAP. To view output with OLAP functionality. For more information, see How to Create
OLAP Reports on page 171.

Table of Contents. To view output for individual values of the first sort (By) field, one
value at a time. For more information, see How to Create Table of Contents Reports on
page 173.

Freeze. To view output with column titles that freeze (remain in view) when you scroll
through pages of the report output. For more information, see How to Freeze Column
Titles in a Report on page 175.
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4 Pages On Demand. To view output, one page at a time, and use a menu bar at the
bottom of the report output, from which you can view any specific page. You can also
click an arrow to move forward a page, move backward a page, go to the first page, or
go to the last page. For more information, see How to Create Pages On Demand Reports
on page 176.

4 Accordion. To view output that is expandable for each vertical sort field. This option
displays data values only for the first vertical sort field when you first view the output.
You can manually expand your view to expose the data values of lower-level sort fields.
For more information, see How to Create Accordion Reports on page 177.

Procedure: How to Create OLAP Reports

1. On the Format tab, in the Navigation group, click the Auto Drill & Analysis down arrow.
The Auto Drill & Analysis menu opens. It contains the following options:

4 OLAP panel not accessible. (Default) Select this option to only display sorting
options in the column titles. The OCP (OLAP ribbon) cannot be accessed from the
title options.

4 OLAP panel accessible. Select this option to access the OLAP panel using the Auto
Drill & Analysis button in the output of the report.

Note: Using this option versus the hidden option allows the user to better distinguish
the difference between the first and second options. The hidden option is available
by accessing the Navigation dialog box.

1 Dimension filtering enabled. Select this option to display dimension filters at the
top of the report. You customize the filter placement within the Navigation dialog
box. You access the dialog box by clicking More options.

<4 Dimensions grouped in tabs. Select this option to group dimension filters in tabs
based on hierarchy within statements in the metadata.

4 More Options. Select this option to open the Auto Drill & Analysis dialog box, as
shown in the following image.
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% Auto Drill & Analysis

X
OLAP options Auto drill options
(%) DLAP panel is not accessible (%) Dimensions
) OLAP panel is accessible ") Dimensions and Measures
) Hide access to the OLAP Panel () Mone
" Dimension filtering enabled
Filtering position  Tgp
) Dimensions grouped in tabs
" OK @ Reset | Scancel | & apply

In addition to the options discussed previously, the Auto Drill & Analysis dialog box
allows the following additional configuration and customization options for OLAP

output:

4 Hide access to the OLAP panel. Select this option to hide access to the OLAP

panel.

<4 Dimension filtering enabled. This option provides a secondary positioning
option allowing placement of the filters on the Top (default) or Bottom of the

report.

Note: If the Dimension filtering enabled option is cleared at any time, the position

option resets to Top.

4 Auto drill options. The auto drill options are:

4 Dimensions. Select this option to automatically drill down on dimensions in

both reports and graphs.

4 Dimensions and Measures. (Default). Select this option to automatically
drill down on dimensions in both reports and graphs and, on measures in

reports.

4 None. Select this option to disable automatic drill downs.

2. Select an option.

172

WebFOCUS



4. Creating and Customizing Reports I

Selecting an option from the OLAP group, such as OLAP panel is accessible, generates
output that invokes OLAP processing. The following image is an example of an OLAP
report. The OLAP button below the report, when clicked, launches the OLAP ribbon.

Stereo Systems 47673 13,017,422.95

Televisions 31,948 42,979,027.83
Video Players 50,181  16,491,444.00

Yideo Production 9,686 9,281,163.62

Procedure: How to Create Table of Contents Reports
Note: You cannot use the Table of Contents with the Accordion feature.
1. Create a report.
2. On the Format tab, in the Navigation group, click Table of Contents.

A table of contents button appears in the top-left corner of the report output, as shown
in the following image.

Region Industry

Central Agriculture 218
BioTech 1,872
Chemical / Petroleum 1,664
Defense [ Aerospace 2,607
Entertainment / Publishing 3,554
Finance [/ Insurance 2,070
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3. Double-click the button to display the Table of Contents menu, shown in the following
image. The Table of Contents menu enables you to select and view individual values of
the first sort (By) field, one value at a time.

L~ Table of Contents

'LE] Central 218
& NorthEast 1,872
'LEI SouthEast e
. _ 2,607
View Entire Report (On/Off) e
Remaove Table of Contents 2,070

Drag the Table of Contents menu in any direction to view the report output, which appears
behind the menu by default.

Quantity

Region Industry Sold
Central Agriculture 218
BioTech 1,872

Chemical / Petroleum 1,664

Defense / Aerospace 2,607
Entertainment / Publishing 3,554
Finance / Insurance 2,000

|~ Table of Contents

H4E] Central

#E NorthEast

H4E] SouthEast

~[f] Vview Entire Report (On/Off)
Remove Table of Contents
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Select a sort field to view values for that field. In the following example, clicking NorthEast
displays the corresponding report output.

Quantity

Region Industry Sold
MorthEast Agriculture 198
BioTech 1,443

Chemical / Petroleum 1,406

Defense / Aerospace 2,263
Entertainment / Publishing 2,871

Finance / Insurance 1,548

L~ Table of Contents

'Llﬁj Central

'LEl MorthEast

'1EJ SouthEast

View Entire Report (On/Of)
Remove Table of Contents

You can also select options to view the entire report or remove the table of contents.

Procedure: How to Freeze Column Titles in a Report
On the Format tab, in the Navigation group, click Freeze.

Column titles freeze (remain in view) when you scroll through pages of the report output.
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The following image shows the scroll bar that appears when you freeze column titles.

Quantity
Sold Revenue
Subtotal: Central 32,463 19,160,774.07 [in
MidEast Stereo Systems 4,607 1,254,014.44
Televisions 3,246 4,256,202.11 —
Video Players 5,043 1,653,244.82
Video Production 955 896,178.80
Subtotal: MidEast 13,851 8,059,640.17
MorthEast Stereo Systems 8,735 2,381,435.14 | _
Televisions 5,578 7,452,259.1% r
Video Players 9,057 2,980,605.73
Yideo Production 1,738 1,723,425.57
Subtotal: MorthEast 25,108 14,537,725.63
MorthWest Stereo Systems T.287 2,043,976.10
Televisions 5,029 6,713,008.%4
Video Players 7,869 2,602,775.63
Yideo Production 1,517 1,429,375.13
Subtotal: NorthWest 1,702 12,789,135.80
SouthEast Stereo Systems 7,431 2,034,149.11
Televisions 5,031 6,793,602.47
VWideo Players 7,657 2,500,094.24 ~

Procedure: How to Create Pages On Demand Reports
On the Format tab, in the Navigation group, click Pages On Demand.

One page of output appears at a time. This option provides a menu bar at the bottom of the
report output that you can use to view additional pages of output. The menu bar is shown
in the following image.

el 2 g [ | 2l
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Procedure: How to Create Accordion Reports
Note: You cannot use the Table of Contents in conjunction with the Accordion feature.

1. Create a report.
The following image shows a chart before the accordion option is applied.

Catepo Region
Stereo Systems Central 14
MidEast T
MorthEast "
MorthWest 14
SouthEast 10
SouthWest 2
West 10
Televisions Central
MidEast
MorthEast 2
MorthWest "
SouthEast
SouthWest
West 13
Video Players Central &
MidEast B
MorthEast 10
MorthWest 1
SouthEast 9
SouthWest 4
West 4

2. On the Format tab, in the Features group, click Accordion.
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Plus signs, shown in the following image, indicate that there are expandable views of
data for each vertical sort field.

Quantity
Sold

2 Video Playvers m

You can manually expand your view to expose the data, as shown in the following image.

Quantity
Sold

= Video iy | 50,11
Central

11,647
MidEast 5,043
MorthEast 9,057
MorthWest 7,869
SouthEast 7,657
SouthWest 2,038
West 6,870

Procedure: How to Implement Stack Measures
On the Format tab, in the Features group, click Stack Measures.

All measures on the report are stacked.
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The following image shows a report in Live Preview before the Stack Measures option is

enabled.

Region

Central MidEast HorthEast
Product Quantity Quantity Quantity
Category Sold Revenue Sold Revenue Sold Revenue
Stereo Systems 11,143 3,027,276.42 4,607 1,254,014.44 8,735 2,381,435.14
Televisions 7,428  10,131,328.09 3,246 4,256,202.11 5,578 7,452,259.19
Yideo Players 11,647 3,835,578.36 5,043 1,653,244.82 9,057 2,980,605.73

The following image shows a report in Live Preview after the Stack Measures option is
enabled.

Region

| MidEast HorthEast

Stereo Systems PRAITElTaiat 1| 11,143 4,607 B,735

3,007,276.42  1,254,014.44 2,381,435.14
Televisions 7,428 3,246 5,578
10,131,328.09  4,256,202.11  7,452,259.19
Video Players 11,647 5,043 9,057
3,835,578.36  1,653,244.82  2,980,605.73
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InfoAssist enables you to easily create different types of simple and complex charts. You can select from
a variety of chart types and output formats, and add custom features to a chart.

Creating and Customizing Charts

You can also create a chart from any existing report in InfoAssist.

focs 4 Formatting a Legend
-4 Visualizing Your Data With Charts 4 Formatting Gridlines
4 Selecting a Chart 4 Formatting Axis Labels
-1 Creating a Chart 4 Formatting a Frame and a Background
4 Accessing Chart Formatting Tools 4 Formatting a Gauge Chart
4 Formatting a Series 4 Formatting Page Headings and Page Footings
4 Formatting Data Labels J4  Using Additional Formatting Features
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Visualizing Your Data With Charts

182

A chart often conveys meaning more clearly and effectively than data displayed in tabular
form. A chart enables you to visually communicate quantitative information. On a chart, you
can give data a shape and form, and reveal patterns and relationships among many data
values. A chart can highlight anomalies that require further investigation. These are some
things to consider when deciding between a report and a chart for your data.

Use a Table to: Use a Chart to:

Look up individual values. Show overall shape of values.
Compare individual values. Show relationship among multiple
Use values precisley. values using patterns and trends.

=0
Customer

45

Degree Tvpe Income Range

40
: 50 TO 524,999

: 525,000 TO 549,999

Azsociate Degree
335

: 550,000 TO 574,999 E 30
: 575,000 TO 599,999 a5
: 5100,000 OR MORE E -
Bachelor's Dearee : 25,000 TO 549,999 = "
: 575,000 TO 599,999 10
: 5100,000 OR MORE 5

Master's Degrees : 50 TO 524,999

: 525,000 TO 549,399 ¢ &@ &é & 2 &d; @t"’é gf}
: 550,000 TO 574,999 o e&"‘z eﬁr\m S
: 575,000 TO 599,599 =

E: 5100,000 OR MORE

A
B:
4
D
E
B:
C: 550,000 TO 574,999
D
E
A
B
J&
D
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Selecting a Chart

Bar Charts

In this section:
Bar Charts

Pie Charts

Line Charts

Area Charts
Multi-Axis Charts
XY Plot Charts
3D Charts

Stock Charts
Special Charts

Combination Charts

In this section:

Bar Chart Types

WebFOCUS InfoAssist User's Manual

It is important that you choose a chart that is appropriate for your data. InfoAssist provides
a complete chart library of both basic and advanced charts. You can choose from a wide
variety of charts to best represent the data that you want to display.

Bar charts plot numerical data by displaying rectangular blocks against a scale (numbers or
variable measures that appear along the axis). The length of a bar corresponds to a value

or amount. You can clearly compare data series (fields) by the relative heights of the bars.
Use a bar chart to display the distribution of numerical data. You can create horizontal and
vertical bar charts.
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When to use: Use a bar chart when individual values are important. For example, the
following image is a basic vertical bar chart that compares the individual products sold to
the total amount in sales for each product. A retailer would find it important to know which

pieces of inventory are selling and how much revenue each item is generating for the
company.

12K
10K
Bl

BK

Quantity Sold

4K

2K

Blu Ray Camcorder- Pocketable DWD Players Receivers ‘ideo Editing

Product Subcategory
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A horizontal bar chart becomes useful when you want to emphasize a ranking relationship
in descending order, or the X-axis labels are too long to fit legibly side-by-side. For example,
the following image is a basic horizontal bar chart that ranks in descending order which
products are generating the most revenue for the retailer.

Hama Thaxer Systams

Flat Pared TV

VD Plaryers

Bl Ray

Boam Box - Portable

3 .

= Camoorder
€
8

-] Recavers
(%]
-

= Speeer Kt
w

k1] Carncorder - Packesatie

E Hesacdgfores
2

o Camenrder . Profession

Prersonal TV

DD Plaryers - Partalie

Uriversal Ramate Cantrals

idke Ectiing

0 Bk 10K 16K 20K 26K 30K 35K 40K
Quantity Sold
Bar Chart Types

The following table lists the available bar chart types.

Available Bar Chart Types

Vertical Clustered Bar Horizontal Clustered Bar

Vertical Stacked Bar Horizontal Stacked Bar

Vertical Dual-Axis Clustered Bar Horizontal Dual-Axis Clustered Bar
Vertical Dual-Axis Stacked Bar Horizontal Dual-Axis Stacked Bar

Vertical Bi-Polar Clustered Bar (Not in HTML5) | Horizontal Bi-Polar Clustered Bar (Not in

HTMLD5)

Vertical Bi-Polar Stacked Bar (Not in HTML5) | Horizontal Bi-Polar Stacked Bar (Not in
HTMLD5)

Vertical Percent Bar Horizontal Percent Bar
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Pie Charts

186

Available Bar Chart Types

Vertical Histogram

Horizontal Histogram

Vertical Waterfall

Horizontal Waterfall

Vertical Multi-3Y Bar (Not in HTML5)

Vertical Multi-5Y Bar (Not in HTML5)

Vertical Multi-4Y Bar (Not in HTML5)

Error Bar

In this section:

Pie Chart Types

A pie chart is a circular chart that represents parts of a whole. A pie chart emphasizes where
your data fits, in relation to a larger whole. Pie charts work best when the data consists of
several large segments. As a best practice, limit your pie chart to five measures. Too many
measures can divide a pie into many thin "slices" that could become difficult to see. Use
color on individual segments to create visual contrast.

Note: You cannot plot negative data on a pie chart.
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When to use: Use a pie chart when you have several large segments of data that you want
to display as a whole. For example, the following image is a pie chart that shows the
educational background of the customers of a retailer.

Customers

W Graduate Degree W High School W Mo High School [ Other M Undergraduate

Pie Chart Types

The following table lists the available pie chart types.

Available Pie Chart Types

Multi Pie

Multi Ring Pie

Multi Proportional Pie (Not in HTML5)

Multi Proportional Ring Pie (Not in HTMLYS)

Single Pie

Single Ring Pie

Pie-Bar (Not in HTML5)

Ring Pie-Bar (Not in HTML5)

WebFOCUS InfoAssist User's Manual

187



Selecting a Chart

Line Charts

188

In this section:

Line Chart Types

Line charts are useful for emphasizing the movement or trend of numerical data over time.
They allow you to trace the evolution of a data point by working backwards or interpolating.
Highs and lows, rapid or slow movement, or a tendency towards stability are all types of
trends well suited to a line chart.

You can also plot line charts with two or more scales to present a comparison of the same
value, or set of values, in different time periods.

When to use: Use a line chart when you want to trend data over time, for example monthly
changes in employment figures, or yearly sales of an item in your inventory. For example,
the following image is a line chart that traces gross profit in sales for four products over a
four-year period.

F . W S
2 = = = =
e o 3 3% 3 W2 3%
@ K & o R R Y
< & & & & &
< =0 & &
Region
will= Quantity Sold WMSRP Cost Discount Revenue

Radar charts are essentially analogous to line charts, except that the scale wraps around.
Radar charts compare two or more data sets. They work well with data that is cyclical, such
as the months of a year. A radar line chart is available in the line chart category, and a radar
area chart is available in the area chart category. You can use axes or polygons to represent
values in a star or spider configuration.
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Line Chart Types

The following table lists the available line chart types.

Available Line Chart Types

Vertical Absolute Line

Horizontal Absolute Line

Vertical Stacked Line

Horizontal Stacked Line

Vertical Dual-Axis Absolute Line

Horizontal Dual-Axis Absolute Line

Vertical Dual-Axis Stacked Line

Horizontal Dual-Axis Stacked Line

Vertical Bi-Polar Absolute Line (Not in HTMLYS)

Horizontal Bi-Polar Absolute Line (Not in
HTMLD)

Vertical Bi-Polar Stacked Line (Not in HTML5)

Horizontal Bi-Polar Stacked Line (Not in
HTMLD5)

Vertical Percent Line

Horizontal Percent Line

Radar Line

Area Charts

In this section:

Area Chart Types

Area charts are similar to line charts except that the area between the data line and zero
line (or axis) is usually filled with color. Area charts allow you to stack data on top of each
other. Stacking allows you to highlight the relationship between data series, showing how
some data series approach a second series.
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When to Use: Use an area chart when you want to distinguish the data more dramatically
by highlighting volume with color. For example, the following image is a basic area chart that
depicts the price and product cost for four products. The data is more boldly distinguished
on this chart in comparison to the line chart.
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Area Chart Types

The following table lists the available area chart types.

Available Area Chart Types

Vertical Absolute Area Horizontal Absolute Area

Vertical Stacked Area Horizontal Stacked Area

Vertical Bi-Polar Absolute Area (Not in Horizontal Bi-Polar Absolute Area (Not in

HTMLD5) HTMLD5)

Vertical Bi-Polar Stacked Area (Not in HTML5) | Horizontal Bi-Polar Stacked Area (Not in
HTMLD5)

Vertical Percent Area Horizontal Percent Area

Radar Area
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Multi-Axis Charts

Bar, line, and area chart types have multi-axis options, such as dual-axis charts and multi-
Y charts, where you can compare one X-axis value to several Y-axis measures.

InfoAssist allows you to assign each individual series to the Y1 through Y5 axis. For more
information, see How to Create a Dual-Axis Chart on page 202.

When to use: Use a multi-axis chart when you want to plot values on an additional axis, or
multiple axes, to compare multiple sets of data that are on different scales. For example,
the following image is a dual-axis chart that shows the quantity of inventory pieces sold and
the revenue that their sales generate.
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XY Plot Charts

In this section:

XY Plot Chart Types

An XY plot chart depicts the relationships among the numeric values in several data series.
It plots two groups of numbers, where for every X value, there is a corresponding Y value.
This results in a single point of XY coordinate.

When to use: Use XY plot charts when you have two sets of numbers to compare and want
to perform trend analysis.

1 Scatter. Scatter charts show a relationship between X and Y values. They compare two
sets of numbers at once, possibly revealing patterns and trends.
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You can plot data using variable scales on both axes. When you use a scatter chart, the
data is plotted with a basic line pattern so that you can visualize the density of individual
data values around particular points, or discern patterns in the data. A numeric X axis,
or sort field, always yields a scatter chart by default.

If your chart reveals clouds of points, there is a strong relationship between X and Y
values. If data points are scattered, there is a weak or no relationship.

Scatter charts share many of the characteristics of basic line charts. Scatter charts and
line charts are distinguishable from one another only by virtue of their X-axis format. Line
charts can appear without connecting lines, making them look like scatter charts, and
scatter charts can appear with connecting lines, making them look like line charts.
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4 Polar. A polar chart is a circular chart. Data is displayed on a polar chart in terms of
values and angles. Polar charts share characteristics with scatter charts. Only one column
field is allowed, in the following order: X (degree) for the column field, and Y (distance

from the center) for the Across or By field.
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4 Bubble. A bubble chart is a chart in which the data points are represented by bubbles.
Bubble charts can have two column fields representing X and Y data values, or have
three column fields representing X, Y, and Z data values, in that order. The third variable
(2) represents size. The size of each bubble is used to show the relative importance of

the data.
1.2M
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1M
§ 00K
o
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BO0K 700K 800K 900K 1M 1.1M 1.2M 1.3M
MSRP
@® Central MorthEast @  MorthWest West
XY Plot Chart Types
The following table lists the available XY plot chart types.
Available XY Plot Chart Types
XY Scatter XY Polar
Bubble
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3D Charts

In this section:

3D Chart Types

A 3D chart uses three axes, X, Y, and Z to display data from two or more data sets so that

trends are most apparent. For example, the following image is a 3D chart that shows the
cost and revenue for four products.

When to use: Use a 3D bar chart when you want to look at the general shape of the data,
but add visual depth to a chart presentation. A 3D chart would not be a good choice for
presenting exact values, since it is difficult to determine values in a 3D chart.
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3D Chart Types

The following table lists the available 3D chart types.

Available 3D Chart Types

3D Bar 3D Pyramid (Not in HTML5)

3D Octagon (Not in HTML5) 3D Cylinder (Not in HTMLD5)

3D Floating Cubes (Not in HTML5) 3D Floating Pyramids (Not in HTML5)
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Available 3D Chart Types

3D Connected Series Area 3D Connected Series Ribbon

3D Connected Group Area 3D Connected Group Ribbon

3D Cone (Not in HTML5) 3D Sphere (Not in HTML5)

3D Surface 3D Surface with Sides (Not in HTML5)

3D Smooth Surface (Not in HTML5) 3D Smooth Surface with Sides (Not in
HTML5)

3D Honeycomb Surface (Not in HTML5)

Stock Charts

In this section:
Stock Chart Types

Stock charts track the trend of a particular stock. They show the trading volume of the stock,
its opening and closing values, and its high and low values over a specific time period. The
data is represented by sets of bars or lines.
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S

tock Chart Types

The following table lists the available stock chart types.

Available Stock Chart Types

Stock Hi-Lo (Not in HTMLY5)

Stock Hi-Lo with Volume (Not in HTMLD5)

Stock Hi-Lo Open-Close (Not in HTML5)

Stock Hi-Lo Open-Close with Volume (Not
in HTML5)

Open-Hi-Lo-Close Candle Stock

Open-Hi-Lo-Close Candle Stock with

Volume (Not in HTML5)

Special Charts

Special charts include a variety of additional chart types.

o

Gauge. A gauge chart indicates the current position of a single data value within a given
spectrum. This chart has a circular shape.

Gauge Thermometer. A gauge thermometer chart indicates the current position of a
single data value within a given scale. This chart has the shape of a thermometer. It is
not available in HTML5.

Pareto. A Pareto chart uses the X axis to show group members, and the Y axis to show
the percent of the total of all groups that each group represents. This chart highlights
the differences between groups of data.

Vertical Box Plot. A vertical box plot is oriented vertically, and shows the distribution
of data through five-number summaries: Upper limit, Upper Quartile, Median, Lower
Quartile, and Lower Limit. This chart can be represented with or without outliers, also
known as whiskers.

Horizontal Box Plot. A horizontal box plot is oriented horizontally, and shows the
distribution of data through five-number summaries: Upper limit, Upper Quartile, Median,
Lower Quartile, and Lower Limit. This chart can be represented with or without outliers,
also known as whiskers.

Funnel. A funnel chart is essentially a pie chart, displaying only one group of data at a
time, from the first series to the last series at the bottom of the funnel.

Pyramid. A pyramid chart is essentially a pie chart, displaying only one group of data at
a time, from the first series to the last series at the top of the pyramid.

Spectral Map. A spectral map contains a row or column matrix of markers that are
displayed in different colors, according to the data values.
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Combination Charts

A combination chart displays multiple series using two or more different types of data graphics
from a bar, line, or an area chart. Combining these charts improves clarity in the presentation
of your data, and highlights the relationship between various data sets on one graph. This
combination chart is referred to as a mixed, composite, or overlay graph.

When to use: For example, a retailer might want to combine a vertical bar chart that shows
revenue with a line chart that shows quantity sold.

140 120K
120
100K
100
- 80K
80
eu BOK
40
40K
20
0 20K
Stereo Systems Televisions Yideo Players Wideo Production
Product Category
== Cuantity Sold Revenue

198 WebFOCUS



5. Creating and Customizing Charts I

Creating a Chart

In this section:

Chart Outputs

How to:

Create a Basic Chart
Create an Advanced Chart
Create a Combination Chart
Create a Dual-Axis Chart
Create a Multi-Axis Chart

On the Format tab, the Chart Types group, shown in the following image, provides buttons
for each of the five most commonly-used chart types, bar (default), pie, line, area, and
scatter. A button labeled Other gives you access to the complete chart library of advanced
charts.

i O pC W

Pie Line Area  Scatker Other

T s
-

Chart Types

Note: For more information on how to invoke the version of InfoAssist that you are using,
please see Getting Started With InfoAssist on page 21.

Procedure: How to Create a Basic Chart
You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click the button of the chart that you want
to create. Bar chart is the default.

The chart appears on the canvas.
2. Populate the chart with your data in one of the following ways:

1 Drag the data dimensions and measures onto the chart.

4 Drag the data dimensions and measures into the appropriate field containers in the
Query pane.
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Procedure:

200

How to Create an Advanced Chart
You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click Other.

The Other Chart Types dialog box opens. Each of the tabs across the top of the dialog
box represents a type of chart.

To display the name of a chart type, hover over the tab with the mouse.

From left to right, the chart type categories are Bar, Line, Area, Pie, XY Plots, 3D, Stock,
and Special.

Click a chart type.

All supported variations of the chart type appear as thumbnail images in the area
underneath.

Within the category, click an image to display a detailed description of that chart type.

If you are not familiar with a chart type, be sure to read the description carefully before
finalizing your selection. Some chart types require a certain number of data values, or
a certain type of data values. If your data does not satisfy the requirements, the chart
will not accurately represent the data.
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In the following image, the Pie tab is selected (the fourth tab from the left). Underneath
the tab, the pie chart types supported by InfoAssist appear as images. Within the images,
the pie chart type is selected, and a description appears underneath.

Other Chart Types O x

l W % € B ¢ i @

€ c

€C <& ¢
c € €

€<
<

™
o

Pie: The most widely used chart for displaying percentages of a total.

o OK @' Cancel

You can also hover over an image with your mouse to display the chart type name, as
shown in the following image.

c €

€

|F‘iE multi ring proportional |

5. In the Other Chart Types dialog box, click OK to finalize your selection and close the
dialog box.

6. Populate the chart with your data in one of the following ways:
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4 Drag the data dimensions and measures onto the chart.

4 Drag the data dimensions and measures into the appropriate field containers in the
Query pane.

Procedure: How to Create a Combination Chart
You can run this procedure in Query Design view or Live Preview.

1. On the Format tab, in the Chart Types group, click the button of the chart that you want
to create. Bar chart is the default.

The chart appears on the canvas.
2. Populate the chart with your data in one of the following ways:
4 Drag the data dimensions and measures onto the chart.
4 Drag the data dimensions and measures into the appropriate field containers in the
Query pane.
3. Change a series type in one of the following ways:

< Ribbon: On the Series tab, in the Select group, select the series that you want to
display in a different chart type. Then, in the Properties group, from the Type drop-down
menu, select the chart type.

4 Right-Click Menu: Right-click the series that you want to display in a different chart
type, point to Series Type, and select the chart type.

The series appears in the new chart type.

Procedure: How to Create a Dual-Axis Chart

When you create a dual-axis chart, you assign one data series to the Y1 axis and another
data series to the Y2 axis.

1. Create a chart.
2. On the Format tab, in the Chart Types group, click Other.
The Other Chart Types dialog box opens.

3. Select a dual-axis chart, such as dual-axis bar, and then click OK.

Drag one field onto the Y1 field, and then drag another field onto the Y2 field.
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Procedure: How to Create a Multi-Axis Chart

When you create a multi-axis chart, you assign one data series to the Y1 axis and another
data series to the Y2, Y3, Y4, and Y5 axes (as needed).

1.
2.

4,

Create a chart.
On the Format tab, in the Chart Types group, click Other.
The Other Chart Types dialog box opens.

Select a multi-axis chart, and then click OK.
Drag fields onto the Y1, Y2, Y3, Y4, and Y5 fields, as needed.

Chart Outputs

You can create charts using one of the following output formats:

d

-

d

d

-

HTML
HTML5
active report
active Flash
PDF

active PDF
Excel

PowerPoint

The HTML5 output format allows you to render a chart in the browser using a built-in JavaScript
engine. Charts with this output format utilize the very latest capabilities of the HTML5 Web
standard, including animation, high-quality vector output, and attractive alpha-channel and
gradient effects.

Note: Not every chart type can be output in every format listed here. To make sure that the
chart that you are creating can be output in the format that you want, please see the topic
for that particular chart type.
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Accessing Chart Formatting Tools

In this section:
Identifying Chart Elements
Using Live Preview

Using Right-Click Field Options in the Query Design Pane

Your presentation of data on a chart is successful when it communicates to your audience
the message that you intend. InfoAssist helps you meet the needs of your audience and
convey your message by providing numerous chart features. For example, you can adjust
the appearance of a chart, add layers of information, or customize the labels that identify
the data on the chart.

Identifying Chart Elements

204

The following image identifies the basic elements that you can customize on a chart. The
elements that are annotated here are for a vertical bar chart. The available elements and
their right-click menu options vary according to the chart that you are creating. Note: The
3D effect is not a default setting. It was enabled for the chart in the following image to
enhance the appearance of the chart. To access the 3D option, go to the Format tab, and
in the Features group, click 3D Effect.
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Legend

Horizontal Gridlines
Vertical Gridlines
X-Axis Label

Y-Axis Label

® N o e hoo

Reference Line
9. Annotation

10. Frame

11 Background

Using Live Preview

In Live Preview, the canvas on the right of the window provides a preview of the report or
chart that you can interact with. The preview is context sensitive, meaning that depending
on what portion you select different options become available.

In Live Preview, when you hover the mouse over a graph element (for example, legend, axis
label, title), the bounding area is highlighted with a dotted line. In the following image, the
legend is highlighted.
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In Live Preview, when you select a graph element (for example, legend, axis label, title), the
bounding area is highlighted with a solid line. In the following image, the legend is selected.
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Once you select a chart element, you can access all available design options on the ribbon,
or you can right-click an element to open a right-click menu of frequently-used design options.
Once you have selected your design option from the ribbon or the menu, InfoAssist instantly
applies it to the chart element, so that you see the result immediately.
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This image shows an Live Preview of a bar chart in Live Preview. In this example, the right-
click menu for a series (field) element is opened.
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Right-click menus are enabled for charts that are generated with either sample data, or live
data from your data source.

Note: Right-click menus are not available in InfoAssist Basic.

The following sections describe the chart elements, the ribbon options, and the right-click
menus that you can work with to design your charts in Live Preview.

Using Right-Click Field Options in the Query Design Pane

In the Query design pane, you can right-click any field and select from a list of available
options that are displayed in the menu that appears. The options that you can select vary,
depending on the type of Query field container in which the field is located, and the type of
chart that you are creating.

When you create a chart, the Query field containers in the Query Design pane include Measure
(Sum), X Axis, Legend (Series), Multi-graph, and Coordinated (for documents only).

Right-clicking a Measure (Sum) field in a chart displays the Filter Values, Sort, Visibility,
Change Title, More, and Delete options. You can point to More to access the Aggregation
Functions, Traffic Light Conditions, and Missing options.

WebFOCUS InfoAssist User's Manual 207



Formatting a Series

Right-clicking an X Axis or Legend (Series) field in a chart displays the Filter Values, Sort,
Visibility, Change Title, More, and Delete options. You can point to More to access the
Missing option.

Right-clicking a Coordinated field or a Multi-graph field in a chart displays only the Delete
option.

For more information, see Using Right-Click Field Options in the Query Design Pane on page
108.

Formatting a Series

In this section:
Associated Dialog Boxes
Series Elements Right-Click Menu

Using Series Properties

A series is a data source field (measure field) that is included in a chart. You can format a
series in a variety of ways. For example, you can change the color of a series, add a trendline
to a series, or change the appearance of markers on a series.

You can access the full set of formatting options on the Series tab and Field tab. For more
information, see Series Tab on page 95 and Field Tab on page 85.

You can also access a subset of frequently-used options by right-clicking a series element
on a chart to open a menu of those options.

Tip: The options that you see on the menu depend on the type of chart that you are creating.
For example, the Series Type option would not appear on the menu for a pie chart, but it
would appear for a bar, line, and area chart.

Associated Dialog Boxes

208

In this section:

Format Series Dialog Box

Edit Title Dialog Box

Traffic Light Condition Dialog Box

Whether you access series options from the ribbon or the right-click menu, you are presented
with a dialog box of options. The following dialog boxes are commonly used for formatting
a series:
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< Format Series

- Edit Title

4 Traffic Light Condition

For Instructions on how to open these dialog boxes, see the procedures in Using Series
Properties on page 217.

Format Series Dialog Box

The Format Series dialog box contains options to format the fill and border of each series

on a chart.

The Format Series dialog box contains the following tabs:

< Fill

4 Border

Use the Fill tab to modify the color of a chart series. The Fill tab is shown in the following

image.

@Formal All Series

Fill

Border

Fil

) Mo il
) Solid fill
@ Gradient fill

Direction | Gradient right

Gradient Style

Color Pattern @ ]

First color Transparency

Second color m

Transparency o |

" OK

The Fill tab contains the following options:

4 No fill. Select this option to remove the color from the series.

@ Cancel 2 Apply

4 Solid fill. Select this option to display the Color and Transparency options.
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4 Color. Click this icon to open the Color dialog box, where you can select a color for
the series.

41 Transparency. Move the slider to make the bands opaque (0%) or transparent (100%).
The default is 0%.

4 Gradient fill. Select this option to display the direction of the gradient, the color pattern
of the gradient, and the degrees of transparency for the two colors that make up the
gradient. A gradient is a smooth color transition or blending of one color to another. The
number of colors to use in a gradient is defined by the stop or pin elements.

< Direction. Select from this drop-down menu to set the direction of the gradient fill.
The options are:

210

d

;|

d

Gradient right
Gradient left
Gradient down
Gradient up
Gradient down left
Gradient up left
Gradient down right
Gradient up right
Radial

Radial top left
Radial top right
Radial bottom left
Radial bottom right
Radial pie

Radial pie inverted
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Use the Border tab to specify a border for a chart series. The Border tab is shown in the
following image.

@Fmﬂlsmﬁ x

B Border

Border
[] Show Barder Calor

Border Color =

o 0K €S Cancel & apply
The Border tab contains the following options:
4 Show Border Color. Select this option to show a border color around each series.

4 Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border.

Edit Title Dialog Box

The Enter Title dialog box contains a text field in which you can type the title for a series on
a chart. Click OK and the title appears on the chart.

Edit Title

€ , Enter Title
\‘_ﬁ

Ok Cancel

Traffic Light Condition Dialog Box

The Traffic Light Condition dialog box contains fields for adding new conditional styling or
modifying existing conditional styling by applying a traffic light color to the selected field.
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The Traffic Light Condition dialog box is shown in the following image.

¥ Traffic Light Condition for Revenue e
W New | g€ @ Color jﬁ Crill Dowen
=} Revenue - — Preview
Greater than ~ 0 E
Type: Constant v
Value:
| 0
3 Get values~
I 2 apply
v ok @& cancel

The Traffic Light Condition dialog box contains the following fields.

4 Relational Operators. Select from this drop-down menu to set the relational operator.
The options are:

4 Equal to

4 Not equal to

4 Greater than

4 Less than

4 Greater than or equal to
4 Less than or equal to

<4 Type/Value. Click this unlabeled field to open a dialog box that contains the following
fields:

4 Type. Opens a drop-down menu of the following values Constant and Field. Select
Constant to enter a constant value. Select Field to open a visual display of the fields
in your data source.

4 Get Values. Select from this drop-down menu. The options are:
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4 All

4 First

4 Last

<4 Minimum
4 Maximum
<4 From Field

The visual display of fields is shown in the following image.
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The Traffic Light Condition dialog box contains the following buttons:

4 Selected Condition. Click this icon to select a condition to work on.

4 New. Creates a new rule.

[

Delete. Deletes a rule.

L

Color. Opens the Color dialog box.
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<4 Drill Down. Opens the Drill Down dialog box, shown in the following image, where you
can drill down to a web page or a URL. Specify the following:

<4 URL of the web page or location of the report
4 An alternate comment
4 Target (New Window, Same Window, a value that you enter)

4 Parameters that you want to use (Name, Value)

Cirill Drown n

@ Web Page () Report
URL

Alternate comment

Target
Mew Window -
Parameters & | 7| >
Mame Value

£5) cancel

gt

Series Elements Right-Click Menu

When you right-click a series on a chart, a menu of options opens. The menu contains options
that are available on the Field and Series tabs.
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The menu options are described in the following table. The table provides links to the sections
of this document in which those options are also discussed.

Option

Description

Filter Values

Enables you to create or modify a WHERE statement, using
the Filter dialog box. With a WHERE statement, you select only
the data that you want to display, and exclude unwanted data.

For information on filtering your data, see Data Tab on page
62 and Field Tab on page 85.

Sort

Enables you to sort the series in either ascending or
descending order.

Visibility

Controls the display of the selected series (field) on a chart.
The value Hide suppresses the display of the series, and the
default value Show displays the series.

For instructions, see How to Hide a Field in a Series on page
231.

Change Title

Enables you to edit the title of the selected series. In the Edit
Title dialog box, type the new title in the Enter Title field, and
click OK.

For instructions, see How to Change the Title of a Series on
page 239.

Series Type

Changes the chart type of the selected series to bar, line, or
area. The option None (default) returns the series to the chart
type that was in effect before you changed it. This option
applies to bar, line, and area chart types only.

For instructions, see How to Change the Type of a Series on
page 218.

Series Color

Enables you to specify the color of the selected series, using
the Color dialog box. For more information, see Color Dialog
Box on page 46.

More Style Options

Opens the Format Series dialog box. For more information,
see Format Series Dialog Box on page 209.
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Option

Description

Data Labels

Controls the display of data labels (values) on the selected
series. The default value Hide suppresses the display of
labels, and the value Show displays labels.

This option does not apply to the gauge chart type.

For instructions, see How to Show and Hide Data Labels on
page 254.

Color Mode

Controls how color is applied to a series (measure field) on a
chart. The possible settings are By Series (default) and By
Group. For example, assume that there is only one series on
a sample bar chart. The By Series setting applies the same
color to all the bars in the series. The By Group setting applies
a different color to each bar.

For instructions, see How to Control the Color Mode on page
241.

Add Trendline

Draws a line on a chart to indicate a statistical trend.

This option does not apply to the pie, funnel, 3D, gauge, or
stock chart type.

For an example of a chart with a trendline, see How to Add a
Trendline on page 219.

More

Contains the Aggregation Functions, Traffic Light Conditions,
and Missing options.

Aggregation Functions assigns an aggregation value to a
numeric measure field in a report. For instructions, see How
to Display Aggregations on Measures on page 233.

Traffic Light Conditions enables you to specify the color of
numeric measure fields in the output, depending on conditions
that you set. You can use the Traffic Light Condition dialog
box to specify the conditions and colors.

For instructions, see How to Apply Traffic Light Conditions With
Drill-Down to a Numeric Measure Field (By Constant) on page
235andHow to Apply Traffic Light Conditions With Drill-Down to
a Numeric Measure Field (By Field) on page 238.

The Missing option allows you to show or hide fields with no
value.
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Option Description

Delete Removes the selected series from the report and updates the
Live Preview accordingly.

Using Series

Properties

In this section:

Series Tab Select Group
Series Tab Style Group
Series Tab Properties Group
Series Tab Line Group
Series Tab Pie Group
Series Tab Display Group
Field Tab Filter Group

Field Tab Sort Group

Field Tab Display Group

The following sections contain procedures for customizing a series. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

S

eries Tab Select Group

How to:

Select a Series

Procedure: How to Select a Series

1.
2.

Create a chart.

to customize.

The Series appears in the drop-down menu field.

WebFOCUS InfoAssist User's Manual

On the Series tab, in the Select group drop-down menu, select the Series that you want

217



Formatting a Series

Series Tab Style Group

How to:

Format the Fill and Border of a Series

Procedure: How to Format the Fill and Border of a Series

1.
2.

5.

Create a chart.

Open the Format Series dialog box in one of the following ways:

4 Ribbon: On the Series tab, in the Style group, click Style.

<4 Right-Click Menu: Right-click a series on the chart, and select More Style Options.
The Format Series dialog box opens.

Use the fill and border options to format the series.

For more information, see Format Series Dialog Box on page 209.

Click OK to close the dialog box.

The Format Series dialog box closes. The series fill and border are formatted accordingly

Click Run to generate the report.

Series Tab Properties Group

How to:
Change the Type of a Series
Add a Trendline

Procedure: How to Change the Type of a Series

218

1.
2.

Create a bar, line, or area chart.

Access the list of series types in one of the following ways:
<4 Ribbon: On the Series tab, in the Properties group, open the Type drop-down menu.

<4 Right-Click Menu: Right-click a series on the chart, and point to Series Type.

Select the type that you want the series to become.

The chart contains the new series type.
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Procedure: How to Add a Trendline

A trendline is a line that is drawn over the plot area of a chart to show the pattern of the
data points. The pattern reveals a statistical trend.

Note: Linear regression trendlines are not available for bubble charts in HTML5.
1. Create a chart.

2. Access the menu of trendline types in one of the following ways:

4 Ribbon: On the Series tab, in the Properties group, open the Trendline drop-down
menu.

<4 Right-Click Menu: Right-click a series on the chart, and point to Add Trendline.

3. Select the type of trendline that you want to display.

The trendline appears on the chart.

4. Optionally, to display the mathematical equation for the selected trendline option, on
the Series tab, in the Properties group, click Equation.

The following image shows a trendline that appears with the Linear option.

CNT PRODUCT_CATEGORY

2007 2008 2003 2010 2007 2008 200 2010 2007 2003 2010
L L L | L L L L 1 ' 1

L L
1 2 4

Quantity Sold : Year (Sales)
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Series Tab Line Group

How to:
Apply Smooth Line Effect to a Line Chart
Hide a Series Line Between Markers

Change the Appearance of a Marker

Procedure: How to Apply Smooth Line Effect to a Line Chart

1. Create a line chart without a smooth line effect.
The following image shows a chart without the smooth line effect.
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2. Select a series on the line chart.

3. On the Series tab, in the Line group, click Smooth Line.
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The Smooth Line effect is applied to the series, as shown in the following image.
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Procedure: How to Hide a Series Line Between Markers

Lines appear between markers by default, as shown in the following image.
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To hide a series line between a marker follow these steps:

WebFOCUS InfoAssist User's Manual 221



Formatting a Series

Create a line chart.
Select a series on the line chart.

On the Series tab, in the Series Group drop-down menu, select the series that you want
to hide.

4. In the Line Group, click Connect Lines.

The series line between the markers disappears, as shown in the following image.
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To make the series line reappear, click Connect Lines again.

Procedure: How to Change the Appearance of a Marker

222

Markers are used to display points of data on a line chart. They are also used in the legend
to identify the data that is on the chart. The different marker shapes distinguish one series
from another.

1. Create a line chart.

2. Select a series on the line chart.

3. On the Series tab, in the Line group, open the Marker drop-down menu.
4

From the Marker drop-down menu, select the marker shape. The options are:

4 None
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d Square (default)
< Circle

<4 Diamond

< Plus

4 Triangle Down
<4 Triangle Up

4 Triangle Right
<4 Triangle Left

4 Pirate Plus

<4 House

4 Hexagon

4 Fat X

< Five Star

4 Six Star

< Hourglass

4 Sideways Hourglass

4 Line

The markers are formatted.

WebFOCUS InfoAssist User's Manual
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The following image shows a square marker for Dollar Sales and a circle marker for
Quantity.
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Series Tab Pie Group

How to:
Expand Pie Slices
Hide a Pie Slice

Procedure: How to Expand Pie Slices

The following image shows a basic pie chart before its slices are expanded.
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1. Create a pie chart.

2. On the Series tab, in the Select group, from the drop-down menu, select one of the

following:

4 All Series expands all slices out from the center of the pie.

A specific series expands that particular slice out from the center of the pie.

3. In the Pie group, click Expand.

The pie expands accordingly.
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The following image shows a pie chart with all slices expanded.
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Procedure: How to Hide a Pie Slice
1. Create a pie chart.

2. On the Series tab, in the Select group, from the drop-down menu, select the series that
you want to hide. Then, in the Pie group, click Hide.

The slice is hidden.
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The following image shows a pie chart with a slice hidden.
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Series Tab Display Group

How to:

Reverse the Order of a Series

Procedure: How to Reverse the Order of a Series
1. Create a chart.
2. On the Series tab, in the Display group, click Reverse Order.

The order of the series is reversed.
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The following image shows a vertical bar chart.
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The following image shows the same data with the series in reverse order.
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Field Tab Filter Group

How to:

Filter Values in a Series

Procedure: How to Filter Values in a Series

1. Create a chart.

2. Select a series on the chart.

3. Open the Filter dialog box in one of the following ways:
<4 Ribbon: On the Field tab, in the Filter group, click Filter.
<4 Right-Click Menu: Right-click a series, and select Filter Values.
The Filter dialog box opens. For more information, see Filter Group on page 42.
Select values for values and prompts.

Click OK to close the dialog box.

The series values are filtered.

Field Tab Sort Group

How to:

Sort the Fields in a Series

Procedure: How to Sort the Fields in a Series
For more information, see Sort Group on page 89.
1. Create a chart.
2. Select a series.

3. Sort the series in one of the following ways:

4 Ribbon: On the Field tab, in the Sort Group, click Up to sort the series values from
smallest to largest, or click Down to sort the series values from largest to smallest.

4 Right-Click Menu: Right click a series on the chart, and point to Sort, and then Sort
again. Click Ascending to sort the series values from smallest to largest, or click
Descending to sort the series values from largest to smallest. Select Limit to open
a list of values to display for a sort group.
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The chart appears with the series sorted accordingly.
The following image shows a vertical bar chart before sorting is applied.
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The following image shows the same data sorted in descending (highest to lowest) order.
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The following image shows the same data sorted in ascending (lowest to highest) order.
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Field Tab Display Group

How to:

Hide a Field in a Series

Display Aggregations on Measures

Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Constant)
Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field (By Field)
Change the Title of a Series

Control the Color Mode

Delete a Series

Procedure: How to Hide a Field in a Series
1. Create a chart.

2. Hide a field in a series is one of the following ways following ways:
1 Select the field in the Query pane.
1 Right-click the field in the chart.
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4 Ribbon: Select the field in the Query pane or by right-clicking it in the chart. On the
Field tab, in the Display group, click Hide Field. Click Hide Field again to make the
series reappear.

4 Right-Click Menu: Right-click a series in the Query pane, or in the chart, point to
Visibility, and then click Hide. Right-click the same series, point to Visibility, and then
click Show to make the series reappear.

The field is hidden.

The following image shows a vertical bar chart with each of the series shown.
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The following image shows the same data with the Price field hidden.
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Procedure: How to Display Aggregations on Measures
You can display numeric measure data using a variety of aggregation values.
For more information, see Display Group on page 72.
1. Create a chart.

2. Open the list of Aggregation options in one of the following ways:

4 Ribbon: On the Field tab, in the Display group, open the Aggregation drop-down
menu.

1 Right-Click Menu: Right-click a series, point to More, and then Aggregation Functions.

3. Select an aggregation function.
The aggregation function is applied to the series.

Note: If you change the Measure (Sum) field container in the Query Design pane from
Sum to Print, Count, or List, the change overrides all assigned aggregation values.
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The following image shows a vertical bar chart without any aggregation values applied.
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The following image shows the same data with the aggregation value of Average (AVE.)
applied to Price, and the aggregation value of Maximum (MAX.) applied to revenue.
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Procedure: How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field
(By Constant)

1.
2.

Create a chart.

Open the Traffic Light Condition dialog box in one of the following ways:

4 Ribbon: In the Query pane, select a field, and then on the Field tab, in the Display
group, click Traffic Lights.

<4 Right-Click Menu: Right-click a series on the chart, point to More, and then select
Traffic Light Conditions.

The Traffic Light Condition dialog box opens. For more information, see Traffic Light
Condition Dialog Box on page 211.

From the Relational Operators drop-down menu below the field name, select a relational
operator. The options are:

4 Equal to

d Not equal to

<4 Greater than

4 Less than

4 Greater than or equal to

d Less than or equal to

In the field to the right of the operator drop-down menu, click the down arrow for the
Type drop-down menu.

The Type dialog box opens.

In the Type dialog box, select Constant.
Enter a value in the Value field, or

a. From the Get Values drop-down menu, select one of the following values All, First,
Last, Minimum, Maximum, From File. The value that you select appears in the Get
Values field.

b. Select the value in the Get Values field. The value that you selected appears in the
Value field.
Click OK.

The value that you selected appears in the field to the right of the operator drop-down
menu.
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8. Click the Color button.

The Color dialog box opens.

©

Select a color.

10. Click OK.

The color appears in the Preview box.

BB

Click OK.
Click the Drill Down button.

The Drill Down dialog box opens.

13 In the Drill Down dialog box, specify each of the following;:

d

-

d

-

d

Drill down to a report or a web page
URL of the web page

An alternate comment

Target (New Window, Same Window)

Parameters that you want to use (Name, Value)

14. Click OK to close the dialog box.

15. Click the New button to set traffic light conditions for additional fields.
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The following image shows a vertical chart without traffic light conditions.
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The following image shows the same vertical chart with traffic light conditions applied.
In this example, the condition was set to display the revenue series in red when the
Revenue series exceeds the value of 14399.46.
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Procedure: How to Apply Traffic Light Conditions With Drill-Down to a Numeric Measure Field
(By Field)

238

1.
2.

Create a chart.

Open the Traffic Light Condition dialog box in one of the following ways:

4 Ribbon: In the Query pane, select a field, and then on the Field tab, in the Display
group, click Traffic Lights.

<4 Right-Click Menu: Right-click a series on your chart, point to More, and then select
Traffic Light Conditions.

The Traffic Light Condition dialog box opens. For more information, see Traffic Light
Condition Dialog Box on page 211.

From the Relational Operators drop-down menu below the field name, select a relational
operators. The options are:

4 Equal to

4 Not equal to

4 Greater than

<4 Less than

d  Greater than or equal to

4 Less than or equal to

In the field to the right of the operator drop-down menu, click the arrow for the Type
drop-down menu.

The Type dialog box opens.

In the Type dialog box, select Field.

The Type dialog box displays the Dimensions, and Measures and Properties of your
data. You can display the data in the following ways:

< View fields in business order. Select from the following options Title, Description,
Name, Alias.

4 View fields in a sortable grid. Select from the following options Name, Title, Alias,
Format, Segment, Filename, Description, Reference.

< View the hierarchical structure of the data. Select from the following options Title,
Description, Name, Alias.
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Select a field.
Click OK.

The field that you selected appears in the field to the right of the operator drop-down
menu.

8. Click the Color button.
The Color dialog box opens.
9. Select a color.

The color appears in the Preview box.

Click OK.
Click the Drill Down button.

E B

The Drill Down dialog box opens.
12 |n the Drill Down dialog box, specify each of the following:
4 Drill down to a report or a web page
<4 URL of the web page
4 An alternate comment
<4 Target (New Window, Same Window)

4 Parameters that you want to use (Name, Value)

13 Click OK to close the dialog box.
14. Click the New button to set traffic light conditions for additional fields.

Procedure: How to Change the Title of a Series
1. Create a chart.
2. Open the Edit Title dialog box in one of the following ways:
<4 Right-Click Menu: Right-click a series on the chart, and select Change Title.
4 Query Pane: Right-click a series, and select Change Title.
The Edit Title dialog box opens.
In the Enter Title field, type the new name for the series.

Click OK to close the dialog box.
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The series has a new title.

The following image shows a vertical bar chart with a Price series and a Revenue series.
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In the following image, Annual Revenue has replaced Revenue as the series title.
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Procedure: How to Control the Color Mode

When you create a single-series chart, all series groups appear in the same color. To use
a different color for each group, set the color mode to By Group.

The following image shows a single-series chart with all series groups in the same color.
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Create a chart.
Right-click a series on the chart, point to Color Mode, and then select By Group.

A different color is applied to each group in the series. To return to the default display
of the series in one color, right-click the series, point to Color Mode, and then select By
Series.

3. Click Run to generate the report.
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The following image shows a single-series chart with a different color applies to each
group in the series.
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Procedure: How to Delete a Series
1. Create a chart.
2. Right-click a series on the chart, and select Delete.

The series is deleted.

Formatting Data Labels

In this section:

Associated Dialog Boxes

Data Labels Elements Right-Click Menu
Using Data Labels Properties

Data labels highlight important data points on a chart. They identify exact numbers. You can
customize data labels in a variety of ways to make them stand out more clearly on the chart.
For example, you can change the position, angle, color, or size of data labels.
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Associated Dialog Boxes

In this section:

Format Labels Dialog Box
Style Dialog Box

Line Style Dialog Box

Whether you access data label options from the ribbon or the right-click menu, you are
presented with a dialog box of options. The following dialog boxes are commonly used for
formatting data labels:

<4 Format Labels

4 Style

4 Line Style

For instructions on how to open these dialog boxes, see the procedures in Using Data Labels

Properties on page 254.

Format Labels Dialog Box

The Format Labels dialog box contains options for editing data labels. Bar, line, and area
charts share the same tabs.

The Format Labels dialog box contains the following tabs:
4 General Options (options vary by chart type)
4 Advanced (options vary by chart type)
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Use the General Options tab to add data labels to a chart and set their position, angle, and
radius. The General Options tab is shown in the following image.

L_ﬂanﬁl Labels

GeneralOptions W Canaral Options

Advanced
[] Show Data Labels
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Format Labels
Custom Format

Style Labels
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General -

e

The General Options contains the following options:

0K 5) Cancel 2 Apply

4 Show Data Labels. Select this option to show data labels on a chart. Clear this option

a

to suppress data labels.

Position. Select an option from this drop-down menu to determine where the data label

will be positioned. The options are:
Custom

Above

On top edge

Below top edge

Center

Base

T I L S A

Center back
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4 Angle. Set the angle of the data label. When the position is set to Custom, you can
define the angle properties to create a custom position for the data label.

4 Radius. Set the radius of the data label. When the position is set to Custom, you can
define the radius properties to create a custom position for the data label.

4 Format Labels. Select from this drop-down menu of preset formats that can be applied
to the labels. The options are:

4 Use Pattern / 100

1 Use Pattern

4 General

4 No Decimal

4 Percent with no decimal

4 Percent with one decimal
4 Percent with two decimals
4 Currency general

4 Currency with no decimal
4 General in thousands

4 Currency in thousands

4 Currency in millions

4 General in billions

< General in trillions

4 Currency in trillions

4 Thousands separator no decimal.
4 Thousands separator two decimals.
4 Date short

4 Date medium

4 Date long

4 Date full

4 Percent with no decimal / 100
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4 Percent with one decimal / 100
4 Percent with two decimals / 100

4 Custom Format. Enter a standard number format pattern for the data label. This option
is only available when you select the Use Pattern option from the Format Labels drop-down
menu.

4 Style Labels. Click this icon to open the Style dialog box, where you can style text. For
more information, see Style Dialog Box on page 252.

Use the Advanced tab to modify additional data labels properties. The Advanced tab is shown
in the following image.

@Fﬂmﬁl Labels ¥

General Options Advanced

Advanced -
[¥] Show Zero Labels

[] remove duplicate data labels

Megative Data labels

[7] Apply color to negative data labels

Color .

o OK £5) Cancel 2 Apply

The Advanced tab contains the following options:

1 Show Zero Labels. Select this option to display zero values in a chart. Clear this option
to display all data values except zero.

4 Remove duplicate data labels. Select this option to remove the display of multiple
data labels that share the same value so that only one value is shown.

1 Apply color to negative data labels. Select this option to style negative data labels
separately from positive data labels.
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4 Color. Click this icon to open the Color dialog box, where you can select a color for the
negative number.

There are some options in the General Options tab that are specific to stack charts. The
General Options tab for a stack chart is shown in the following image.

|1 Format Labels *

General Options General Options

[ show Data Labels

Pasition Abaove -
Angle a0 Radius 10
Format Labels General -

Custom Format

i
T

Style Labels @
[¥] show Cumulative Sums
Stacked Total
[7] show Stacked Total
[¥] Show Zero Labels
Style Labels @

W OK €8) Cancel 2. Apply

These options specific to a stack chart are:

4 Show Cumulative Sums. Select this option to have the data text labels show cumulative
sums. Clear this option to have data text labels show individual sums.

4 Show Stacked Total. Select this option to display stacked totals. Data position should
be set to Center to display a stacked total.

Bubble and stock charts share the same General Options and Advanced tabs as bar, line,
and area charts, except for the Custom Label option.
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For pie charts, the General Option and Advanced tabs are replaced by the Pie Labels and
Pie Title tabs.

Use the Pie Labels tab to customize your pie data labels. The Pie Labels tab is shown in
the following image.

@Fnrmat Labels X
Pie Labels Pie Labels
Pie Title Label Position Feeler Lines and Labels -
Label Display Percent Value -
Format Labels Percent with no decimal -

Custom Format =,

1%

Style Labels @
Feeler Line
Line Style X

W« 0K €5 cancel 5 Apply

The Pie Labels tab contains the following options:

4 Label Position. Select from this drop-down menu an option to control the display of
feeler lines and labels on a pie chart.

4 Label Display. Select from this drop-down menu an option to control the format of labels
displayed next to feelers on a pie chart.

4 Format Labels. Select from this drop-down menu of preset formats that can be applied
to labels.

<4 Custom Format. Select this option to use a custom format from a list of preset formats.
See the following table for a list and description of the characters that you can use in a
custom format.

4 Style Labels. Click this button to open the Style dialog box, where you can style text.
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4 Ring Label. These options appear on the tab for a ring pie chart.

Feeler Line

41 Show Ring Label. Select this option to control the display of the total label on a pie ring

chart.

4 Format Labels. Select from this drop-down menu of preset formats that can be applied

to labels.

4 Custom Format. Select this option to use a custom format. See the following table.

-4 Style Labels. Click this button to open the Style dialog box, where you can style text.

The Format Labels drop-down menu provides a list of preset formats that you can apply to
labels. When you select a custom format, it must be defined using a custom format pattern.
The following table describes the characters that you can use in a custom format.

Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for decimal separator.

, (comma) Is a placeholder for grouping separator.

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in
the prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or suffix.
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Use the Pie Title tab to create and style a pie title. The Pie Title tab is shown in the following
image.

@. Format Labels ¥

PiE LabE|S PIE' TIt'E

Pie Title

Show Pie Title
Style Title @

o OK ®cancel 2 apply

The Pie Title tab contains the following options:

1 Show Pie Title. (Default). Clear this option to suppress a pie title. Select this option to
display a pie title.

1 Style Title. Click this icon to open the Style dialog box, where you can style pie title text.
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Use the Funnel Labels tab to customize the labels on a funnel or a pyramid chart. The Funnel
Labels tab is shown in the following image.

L&Fﬂﬂ'ﬂﬂ Labels w

Funnel Labels Funnel Labels

Label Position Labels and Values to the Right -
Format Labels General -

Custom Format

Style Labels E&
Style Value %
Feeler Line
[¥] show Feeler Lines
Line Style e

0

" OK £5) Cancel 2 Apply

The Funnel Labels tab contains the following options:

d

-

d

Label Position. Select from this drop-down menu an option to control the display of
feeler lines and labels on a funnel chart.

Format Labels. Select from this drop-down menu of preset formats that can be applied
to labels.

Custom Format. Select this option to use a custom format. See the table in the previous
section for a list and description of the characters that you can use in a custom format.

Style Labels. Click this button to open the Style dialog box, where you can style text.

Style Value. Opens the Style dialog box, where you can style the value.

Feeler Line
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Show Feeler Lines. (Default) Clear this option to suppress feeler lines. Select this
option to display feeler lines.

Line Style. Click this button to open the Line Style dialog box, where you can edit the
color, weight, and style of the feeler line.

Style Dialog Box

The Style dialog box contains options to style the data labels. The Style dialog box is shown
in the following image.

3 Style x
Sans serif - -
B I U| E=EE B|®P
— Preview
Sans serif
" OK &3 cancel

The Style dialog box contains the following options:

d
d

d

252

Font. Use the drop-down menu to change the font.
Font size. Use the drop-down menu to change the numeric value for the font size.
Font style. Click the appropriate button (bold, italic, underline) to style the selected text.

Text alignment. Click the appropriate button (left, center, right) to align the selected
text.

Font color. Click the button to open the Color dialog box, where you can select the font
color.

Reset to Quick Styles from Template. Click the button to reset all settings to the
default settings from the template.

Note: Reset only works while the Style dialog box is open. Once you click OK, all changes
are committed. To undo global styling after it has been committed, you must use the
Undo command on the Quick Access Toolbar.
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Line Style Dialog Box

The Line Style dialog box contains options to style lines on a chart. The Line Style dialog
box is shown in the following image.

(W]

fam Line Style O x
fhcolor | —Weight - | — style -~

W« 0K ) Reset 5 cancel

The Line Style dialog box contains the following options:

<4 Color. Click this button to open the Color dialog box, where you can select the color for
the line.

4 Weight. Click this button to open a drop-down menu of line weight options.
4 Style. Click this button to open a drop-down menu of line style options.

<4 Reset. Click this button to reset the line to the default options.

Data Labels Elements Right-Click Menu

When you right-click a data label on a bar, line, or area chart, a menu of the following options
opens:

4 Data Labels. Point to this option to toggle between Show and Hide.

<4 More Label Options. Click this option to open the Format Labels dialog box.

The right-click menu contains options that are available on the Series tab.

When you right-click a data label on a pie chart, a menu of the following options opens:

4 Smart Positioning. Select this option to use smart positioning of data labels. For
example, if a pie chart has so many slices that a data label could become illegible,
InfoAssist moves the data label outside of the pie, but connects it to the slice with a
feeler line.

4 On Slice. Select this option to display the data labels on the pie slices.
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4 Outside Slice. Select this option to display the data labels outside the pie slices.
41 Outside with feeler lines. Select this option to display the data labels outside the pie
slices with feeler lines.

Using Data Labels Properties

In this section:

Series Tab Properties Group

The following sections contain procedures for customizing data labels. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Series Tab Properties Group

How to:
Show and Hide Data Labels
Change the Position of Data Labels

Procedure: How to Show and Hide Data Labels
1. Create a chart.

2. You can access the option to show data labels in one of the following ways:

-1 Ribbon: On the Series tab, in the Properties group, open the Data Labels drop-down
menu and select More Data Labels Options to open the Format Labels dialog box.
On the General tab, select the Show Data Labels option, and click OK to close the
dialog box. You can use this dialog box to format and style the data labels. For more
information, see Format Labels Dialog Box on page 243. To hide data labels, clear
this option.

4 Right-Click Menu: Right-click a series on the chart, point to Data Labels, and then
select Show. To hide data labels, right-click a series on the chart, point to Data
Labels, and then select Hide.

The data labels appear and are formatted and styled accordingly.
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The following image shows a chart with data labels.
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Procedure: How to Change the Position of Data Labels
1. On the Series tab, in the Properties group, open the Data Labels drop-down menu.
2. On the menu, select the position for the data labels.

The data labels are positioned accordingly.
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The following image shows a chart with the data labels centered.
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Formatting a Legend

In this section:

Format Legend Dialog Box

Legend Elements Right-Click Menu
Using Legend Properties

A legend contains information that is necessary to accurately interpret the data on a chart.
By default, a chart displays either a vertical axis title if there is a single measure field, or a
legend if there are multiple measure fields.

Format Legend Dialog Box

Whether you access legend options from the ribbon or the right-click menu, you are presented
with the Format Legend dialog box of options. For instructions on how to open this dialog
box, see Using Legend Properties on page 262.

The Format Legend dialog box contains options for formatting a legend on a chart. It contains
the following tabs:

4 Legend Options
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< Markers & Labels

4 Fill

4 Border Styles

< Advanced

Note: The Fill, Border Style, and Shadows tab are not available in InfoAssist Basic.

For instructions on how to open this dialog box, see the procedures in Using Legend Properties
on page 262.

Use the Legend Options tab to customize the appearance of a legend on a chart. The Legend
Options tab is shown in the following image.

% Format Legend =

Legend Options Legend Options

Markers & Labels [7] show Legend

Fill Legend Position Auto

Border Styles Legend Orientation Auto

Ad d
i [] reverse Legend Order

Legend Position

X RE Width a03
348 Height 26
0K {5 Cancel

The Legend Options tab contains the following options.

4 Show Legend. Select this option to show a legend on a chart. Clear this option to
suppress a legend on a chart.

<4 Legend Position. Select an option from this drop-down menu to position a legend on a
chart. The options are:

4 Auto
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-1 Bottom

<1 Right

4 Left

4 Top

4 Right Top

<4 Right Bottom
J4 Left Top

-1 Left Bottom

-4 Bottom Left

4 Bottom Right
4 Top Left

4 Top Right

-1 Free Float

4 Legend Orientation. Select an option from this drop-down menu to control the orientation
of legend markers in the legend area. The available options are Auto, Horizontal, Vertical.

4 Reverse Legend Order. Select this option to specify that the legend be drawn in reverse
order. Clear this option to specify that the legend be drawn in normal order.

4 Legend Position
4 X. Controls the point location of the bottom left corner of the legend.
4 Width. Controls the width of the legend.

< Y. Controls the point location of the bottom left corner of the legend.

L

Height. Controls the height of the legend.
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Use the Markers & Labels tab to customize the appearance of markers and labels on legends.
The Markers & Labels tab is shown in the following image.

% Format Legend

Legend Options

Markers & Labels

Fill

Border Styles

Advanced

Markers and Labels

F
Style Labels wﬁ
Marker Style Automatic Line Style -
Marker Position Left of Text -

[] Show Beveled Markers

" OK €5 Cancel & Apply

The Markers & Labels tab contains the following options:

4 Style Labels. Click this button to open the Style dialog box, where you can style text.

4 Marker Style. Select an option from this drop-down menu to edit the line style in the
legend. The options are:

d

]

L

]

Markers Only
Line Style Only

Markers and Line Style

Automatic Line Style

4 Marker Position. Select an option from this drop-down menu to set the position of text
relative to the legend marker. The options are:

d

]

d

Left of Text
Right of Text
Above Text
Below Text

On Text
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4 Show Beveled Markers. Select this option to show beveled markers. Clear this option
to suppress beveled markers.

Use the Fill tab to modify the color of the legend area. For more information, see Format
Series Dialog Box on page 209.

Use the Border Styles tab to place a border around a legend. For more information, see
Format Series Dialog Box on page 209.

The Border Styles tab contains the following options:
4 Show Border. Sclect this option to place a border around a legend.

4 Color. With the Show Border option selected, you can click this button to open the Color
dialog box, where you can select a color for the border.

Use the Advanced tab to use square markers and marker shapes on a legend. The Advanced
tab is shown in the following image.

% Format Legend %
Legend Options Advanced
Markers & Labels [¥] square Markers
Fill Uise Marker Shapes

Border Styles

Advanced

" OK {5) Cancel B Apply

The Advanced tab contains the following options:
4 Square Markers. Select this option to display square markers on a legend.

4 Use Marker Shapes. Select this option to display marker shapes on a legend.
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Legend Elements Right-Click Menu

When you right-click a legend on a chart, a menu of options opens. The menu contains
options that are available on the Format tab.

If you right-click the background area around the legend, two additional options are available,
Legend Area Color, and Legend Border Color. The right-click menu options are described in
the following table. The table provides links to the sections of this document in which those
options are also discussed.

Option

Description

Show Legend

Controls the display of the legend. InfoAssist displays the legend
by default. When you clear this option, InfoAssist suppresses
the legend. For instructions, see Using Legend Properties on
page 262.

The background right-click menu has an option to restore the
legend after it has been suppressed.

Legend Position

Controls the placement of the legend on the chart. For
instructions see, Using Legend Properties on page 262.

Legend Orientation

Controls the orientation of the legend on the chart. For
instructions see, Using Legend Properties on page 262.

Legend Area Color

Enables you to specify the color of the legend background area
using the Color dialog box.

This option is available only when you right-click the area around
the legend. For instructions see, Using Legend Properties on
page 262.

Legend Border Color

Enables you to specify the color of the border around the legend
background area using the Color dialog box.

This option is available only when you right-click the area around
the legend. For instructions see, Using Legend Properties on
page 262.

More Legend Options

Opens the Format Legend dialog box.
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Using Legend Properties

In this section:

Format Tab Labels Group

The following sections contain procedures for customizing legend. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Format Tab Labels Group

How to:

Hide a Legend

Position a Legend

Control the Orientation of a Legend
Specify the Color of a Legend Background
Specify the Color of a Legend Border

Procedure: How to Hide a Legend
1. Create a chart with multiple measure fields.

2. Clear the Show legend option in one of the following ways:

-1 Ribbon: On the Format tab, in the Layout group, open the Legends drop-down menu,
and clear the Show legend option.

4 Right-Click Menu: Right-click the legend, and clear the Show Legend option.
The legend is hidden.

Procedure: How to Position a Legend
1. Create a chart with multiple measure fields.

2. Open the menu of label position options in one of the following ways:

-1 Ribbon: On the Format tab, in the Layout group, open the Legends drop-down menu,
and point to Legend Position.

41 Right-Click Menu: Right-click the legend, and point to Legend Position.

3. Select a position for the legend. The options are:
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The following image shows a chart with the legend in the default position on the bottom.
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The following image shows a chart with the legend moved to the right.

35K

30K

25K

20K

15K

10K

SK

Central MidEast NorthEast MorthiWest SouthEast SouthWest West

Region

B Cost

B Revenus

Procedure: How to Control the Orientation of a Legend

264

1. Create a chart with multiple measure fields.

2. Open the menu of label orientation options in one of the following ways:

1 Ribbon: On the Format tab, in the Layout group, open the Legends drop-down menu,
and point to Legend Orientation.

4 Right-Click Menu: Right-click the legend, and point to Legend Orientation.

3. Select an orientation for the legend.

The options are:

1 Auto

1 Vertical

1 Horizontal
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The following image shows a chart with a legend that has a vertical orientation.
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Procedure: How to Specify the Color of a Legend Background
1. Create a chart with multiple measure fields.

2. Open the Format Legends dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Layout group, open the Legends drop-down menu,
and select More Legend Options.

1 Right-Click Menu: Right-click the legend, and select More Legend Options.

The Format Legends dialog box opens. For more information, see Format Legend Dialog
Box on page 256.

On the Fill tab, set the fill, color, and transparency options for the legend background.
4. Click OK to close the dialog box.

The legend is formatted accordingly.
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The following image shows a chart with a legend with a teal background.
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Procedure: How to Specify the Color of a Legend Border
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1.
2.

Create a chart with multiple measure fields.

Open the Format Legends dialog box in one of the following ways:

1 Ribbon: On the Format tab, in the Layout group, open the Legends drop-down menu,
and select More Legend Options.

J  Right-Click Menu: Right-click the legend, and select More Legend Options.

The Format Legends dialog box opens. For more information, see Format Legend Dialog
Box on page 256.

On the Border Styles tab, select the option to Show Border.

Click the Color icon to open the Color dialog box, where you can specify the color of the
legend border.

Click OK to close the Color dialog box.
Click OK to close the Format Legend dialog box.

The legend border is formatted accordingly.
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Formatting Gridlines

In this section:

Format Grid Lines Dialog Box
Gridline Elements Right-Click Menu
Using Gridline Properties

Gridlines are used on a chart as a reference to help you understand the quantities and
values of your data and decode information on the axis. There are four types of gridlines
that you can display and edit on your chart. They are:

o

A

o

A

Horizontal major gridlines
Horizontal minor gridlines
Vertical major gridlines

Vertical minor gridlines

Major gridlines enhance the display of values, while minor gridlines supplement major
gridlines. If a plot point falls in between major gridlines, you can use minor gridlines for more
precise interpretation of the data.

o

A

o

Vertical gridlines in a vertical chart run on the X axis.
Horizontal gridlines in a vertical chart run on the Y axis.

Horizontal major gridlines enhance the display of values, compared to the Y-axis scale
alone. They are enabled by default on many charts. They do not apply to the pie, 3D,
gauge, spectral map, or funnel chart type.

Horizontal minor gridlines are disabled by default. They do not apply to the pie, 3D, gauge,
spectral map, or funnel chart type.

Vertical major gridlines enhance the display of values, compared to the X-axis scale alone.
They are enabled by default. They do not apply to the pie, 3D, gauge, spectral map, or
funnel chart type.

Vertical minor gridlines are disabled by default. They apply only to scatter and bubble
chart types, where the X axis is numeric. They do not apply to the pie, 3D, gauge, spectral
map, or funnel chart type.

Note: The orientation of a chart determines the available gridline options.
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Format Grid Lines Dialog Box

268

Whether you access gridline options from the ribbon, or the right-click menu, you are
presented with the Format Grid Lines dialog box of options to format horizontal and vertical
gridlines, color bands, and frames on a chart.

Color bands come in a pair, with each band uniquely colored. They appear in a continually
repeating pattern behind a series on a chart. The contrast of colors is designed to make
the chart easier to read.

Alternate formatting can be used to apply different colors to sections, called regions, of an
axis.

The Format Grid Lines dialog box contains the following tabs:

4 Major Grid Lines

[

Minor Grid Lines

< Color Bands

< Frames

Note: The Color Bands and the Frames options are not available in InfoAssist Basic.

Use the Major Grid Lines tab to format the major gridlines on the chart. The Major Grid Lines
tab is shown in the following image.

@Fﬂmﬂ Horizontal Grid Lines W

Major Grid Lines Major L

Minor Grid Lines Show Grid Lines
Color Bands Grid Style | Mormal -
Frames Line Style %
Ticks
Tick Style Hidden —
Tick Color !|

o OK €5) Cancel 2 Apply
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The Major Grid Lines tab contains the following options:

4 Show Grid Lines. Select this option to display major gridlines on a chart if minor gridlines
are the default for the chart.

4 Grid Style. Select from this drop-down menu to edit the style of the gridlines, such as
adding a tick on the inside or the outside of the line.

4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

4 Tick Style. Select from this drop-down menu of tick styles (Inside, Outside, Spanning,
Hidden).

4 Tick Color. Click this icon to open the Color dialog box, where you can edit the color of
the tick.

Use the Minor Grid Lines tab to format the minor gridlines on your chart. The Minor Grid
Lines tab is shown in the following image.

@Fﬂﬂﬁd Vertical Grid Lines x

Major Grid Li ; ey
G e el Minor Grid Lines

Minor Grid Lines [] show Grid Lines
Color Bands Grid Style | Mormal -
e line Style 18y
Grid count 8
Ticks
Tick Style | Hidden g
Tick Calor !|

o OK {5 Cancel 2 Apply

The Minor Grid Lines tab contains the following options:

4 Show Grid Lines. Select this option to display minor gridlines on a chart. By default,
this option is enabled.

WebFOCUS InfoAssist User's Manual 269



Formatting Gridlines

270

Grid Style. Select from this drop-down menu to edit the style of the gridlines. The options
are:

4 Normal

-4 Normal with tick outside
4 Normal with tick inside
<4 Tick spanning

Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the gridline.

Grid count. Set the number of minor gridlines that will appear between major gridlines.
Tick Style. Select from this drop-down menu of tick styles. The options are:

4 Inside

-1 Outside

4 Spanning

- Hidden

Tick Color. Click this icon to open the Color dialog box, where you can edit the color of
the tick.
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Use the Color Bands tab to format the color bands on your chart. The Color Bands tab is
shown in the following image.

|| Format Horizontal Grid Lines ¥
Major Grid Lines Color Bands
Minor Grid Lines
[ Band 1
Color Bands
Color .|
Frames
Transparency 0 %
[] Band 2
Color -|
Transparency o= %

W OK () Cancel 2 Apply

The Color Bands tab contains the following options:
4 Band 1. Select this option to add Band 1 to a chart.

4 Color. Click this icon to open the Color dialog box, where you can edit the color of
Band 1.

4 Transparency. Move the slider to make Band 1 opaque (0%) or transparent (100%).
The default is 0%.

4 %. Enter or select the percentage of the transparency of Band 1.
4 Band 2. Select this option to add Band 2 to a chart.

4 Color. Click this icon to open the Color dialog box, where you can edit the color of
Band 2.

4 Transparency. Move the slider to make the Band 2 opaque (0%) or transparent
(100%). The default is 0%.

4 %. Enter or select the percentage of the transparency of Band 2.
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Use the Quadrant Lines tab to control the placement and style of the quadrant lines in your
scatter and bubble chart. The Quadrant Lines tab is shown in the following image.

@Fﬂﬂl‘ﬂ Herizental Grid Lines w

Majar Grid Lines Quadra nt Lines
Minor Grid Lines
[] sShow Quadrant Line

Color Bands
Value 1.234567E30

Quadrant Lines
Line Style g

Frames

W OK (§) Cancel 2 Apply

The Quadrant Lines tab contains the following options:

4 Show Quadrant Line. Select this option to show the quadrant line. Clear this option to
suppress the quadrant line.

4 Value. Enter a value to control where the quadrant line will be placed on the X axis.

4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the
color, weight, and style of the quadrant line.
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Use the Frames tab to enable or disable frame regions, and to set the location and style of
the frame text. The Frames tab is shown in the following image.

LﬁFnrmal Herizontal Grid Lines w

Major Grid Lines Frames

Minor Grid Lines [] Show Frame Regions

Color Bands Region 1 - Add P

Quadrant Lines e [

Frames
Color |
-

Border Color !|
Text

style Text  [54

W« OK {S) Cancel & apply

The Frames tab contains the following options:

d

Show Frame Regions. Select this option to show a frame region. Clear this option to
suppress a frame region.

4 Region. Select from this drop-down list, the region that you want to format.
4 Add. Click this button to add a region.

4 Remove. Click this button to remove a region.

Location. Enter the location of the region.

Color. Click this icon to open the Color dialog box, where you can edit the color of the
frame.

Border Color. Click this icon to open the Color dialog box, where you can edit the color
of the frame border.

Text. Enter the text that you want to appear on the frame.

Style Text. Click this icon to style the frame text.
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For instructions on how to open this dialog box, see the procedures in Using Gridline Properties

on page 274.

Gridline Elements Right-Click Menu

When you right-click a gridline on a chart, a menu of options opens. The options for the

gridline elements are described in the following table.

Element

Option

Description

Horizontal Major Gridlines
Horizontal Minor Gridlines
Vertical Major Gridlines

Vertical Minor Gridlines

Delete

Removes the gridline from the
chart and updates the Live
Preview accordingly.

Set Line Color

Enables you to specify the color
of the gridline, using the Color

dialog box. For more information,
see Color Dialog Box on page 46.

More Grid Lines
Options

Opens the Format Gridlines dialog
box. For more information, see
Format Grid Lines Dialog Box on
page 268.

Using Gridline Properties

In this section:

Format Tab Features Group

The following sections contain procedures for customizing gridlines. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

274
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Format Tab Features Group

How to:

Display Horizontal Major Gridlines

Display Horizontal Minor Gridlines

Display Vertical Major Gridlines

Display Vertical Minor Gridlines

Set the Color, Weight, and Style of a Gridline
Set Ticks

Set Color Bands

Delete a Gridline

Display Quadrant Lines

Procedure: How to Display Horizontal Major Gridlines
If your chart does not display gridlines by default, use this procedure to generate gridlines.
1. Create a chart.

2. On the Format tab, in the Features group, open the Grid drop-down menu, point to
Horizontal Gridlines, and then select Major Gridlines.

The Format Horizontal Grid Lines dialog box opens.

3. On the Major Grid Lines tab, select Show Major Grid Lines.

Horizontal major gridlines are added to the chart.

WebFOCUS InfoAssist User's Manual 275



Formatting Gridlines

The following image shows a chart with the horizontal major gridlines highlighted and
the right-click menu open.
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Procedure: How to Display Horizontal Minor Gridlines
1. Create a chart.

2. Access the option to show gridlines in one of the following ways:

<4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu.
On the Grid drop-down menu, point to Horizontal Gridlines, and then select Minor
Gridlines.

4 Right-Click Menu: Right-click the chart, and select More Grid Line Options. The
Format Horizontal Grid Lines dialog box opens. On the Minor Grid Lines tab, select
Show Minor Grid Lines.

Horizontal minor gridlines are added to the chart.
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The following image shows a chart with the horizontal minor gridlines highlighted.
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Procedure: How to Display Vertical Major Gridlines
1. Create a chart.

2. Access the option to show gridlines in one of the following ways:

<4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu.
On the Grid drop-down menu, point to Vertical Gridlines, and then select Major
Gridlines.

4 Right-Click Menu: Right-click the chart, and select More Grid Line Options. The
Format Vertical Grid Lines dialog box opens. On the Major Grid Lines tab, select Show
Major Grid Lines.

Vertical major gridlines are added to the chart.
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The following image shows a chart with the vertical major gridlines highlighted and the
right-click menu open.
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Procedure: How to Display Vertical Minor Gridlines
1. Create a chart.

2. Access the option to show gridlines in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu.
On the Grid drop-down menu, point to Vertical Gridlines, and then select Minor
Gridlines.

1 Right-Click Menu: Right-click the chart, and select More Grid Line Options. The
Format Vertical Grid Lines dialog box opens. On the Minor Grid Lines tab, select Show
Minor Grid Lines.

Vertical minor gridlines are added to the chart.
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The following image shows a chart with vertical minor gridlines highlighted.
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Procedure: How to Set the Color, Weight, and Style of a Gridline

1. Open the Format Grid Lines dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu,
point to the gridline type that you want to format, and select More Grid Lines Options.

<4 Right-Click Menu: Right-click a gridline, and select More Grid Lines Options.
The Format Grid Lines dialog box opens.
2. Click the Line Style icon.
The Line Style dialog box opens.
Set the color, weight, and style of the gridline.
Click OK to close the Line Style dialog box.
Click OK again to close the Format Grid Lines dialog box.

The gridline is formatted accordingly.
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The following image shows a chart with the default styling for gridlines.
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The following image shows the same chart with the gridlines styled as red, dashed lines,
of medium weight.
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Procedure: How to Set Ticks

Ticks are short lines which are perpendicular to a gridline. They are used to tick off specific
increments along the gridline.
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Create a chart with gridlines.

Open the Format Grid Lines dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu,
point to the gridline type that you want to format, and select More Grid Lines Options.

J  Right-Click Menu: Right-click a gridline, and select More Grid Lines Options.
The Format Grid Lines dialog box opens.

3. From the Tick Style drop-down menu select a tick style option. The options are:
4 Hidden

D Inside

4 OQutside

1 Spanning

4. Click the Color icon to open the Color dialog box, where you can set the color of the tick
marks.
Click OK to close the Color dialog box.
Click OK again to close the Format Grid Lines dialog box.
The tick marks are formatted accordingly.

The following image shows a chart with tick marks spanning the frame of the chart.
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Procedure:

How to Set Color Bands

1.
2.

Create a chart with gridlines.

Open the Format Grid Lines dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu,
point to gridlines that you want to format, and select More Grid Lines Options.

<4 Right-Click Menu: Right-click a gridline, and select More Grid Lines Options.

The Format Grid Lines dialog box opens.

On the Color Bands tab, click the Color icon to open the Color dialog box, where you can
set the color of the color bands.

Use the transparency slider, or the percentage box, to type or select the percentage of
the transparency that you want to apply to the color.

Click OK to close the Color dialog box.
Click OK again to close the Format Grid Lines dialog box.

The following image shows a chart with Color Band 1 set to a green color with 80 percent
transparency.
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Procedure: How to Delete a Gridline

282

1. Create a chart with gridlines.

2. Select a gridline.
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3. Delete the gridline in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, open the Grid drop-down menu.
From the menu, point to the gridline that you want to format, and select More Grid
Lines to open the Format Grid Lines dialog box. On the tab for the gridline that you
want to delete, clear the Show Grid Lines option, and click OK.

<4 Right-Click Menu: Right-click the gridline, and from the menu, select Delete.

The gridline is deleted from the chart.

Procedure: How to Display Quadrant Lines

Use the options on the Quadrant Lines tab to control the placement and style of the quadrant
lines in your scatter and bubble chart. Note: Quadrant lines are on by default for bubble
charts and off by default for scatter charts.

The following image show a scatter chart without quadrant lines.
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Create a scatter chart.

On the Format tab, in the Features group, click Grid.

3. On the drop-down menu, point to either Horizontal Gridlines or Vertical Gridlines, and
then click More Grid Lines Options.

The Format Grid Lines dialog box opens.
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4. On the Quadrant Lines tab, select Show Quadrant Line.
The quadrant line displays on the chart.

5. Click OK to close the Format Grid Lines dialog box.

The following image shows the same chart with quadrant lines.
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In this section:
Format Axis Dialog Box
Axis Elements Right-Click Menu

Using Axis Properties

Vertical and horizontal axes are based on the orientation of the graph. For example, in a
vertical graph, the horizontal axis refers to the X axis and the vertical axis refers to the Y
axis. In a horizontal graph, the horizontal axis refers to the Y axis and the vertical axis refers
to the X axis. This is important to consider, since options could change depending on the
orientation of the graph.

A chart can contain the following types of axis labels:

4 Horizontal axis labels represent the X axis. They do not apply to pie, funnel, or gauge
charts.
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- Vertical axis labels represent the Y1 axis in a single axis chart. They represent a numeric
scale, usually located on the left side of a vertical chart.

4 Secondary horizontal and vertical labels can only be used when dual axes charts are
selected.

Format Axis Dialog Box

In this section:

Secondary Axes Options

Whether you access axis options from the ribbon, or the right-click menu, you are presented
with the Format Axis dialog box of options for formatting for both vertical and horizontal axes.
The Format Axis dialog box contains the following tabs:

- Scale
4 Title

4 Labels

L

Advanced
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Use the Scale tab to modify scale properties. The Scale tab is shown in the following image.

|| Format Vertical Axis %
Scale Srale
Title [¥] Automatic Minimum
Labels Value 0.0
Advanced [¥] Automatic Maximum
Value  70.0

[¥] Automatic Grid Step
Value | 15.0
[ Logarithmic Scale
Log scale base 10.0

[7] Indude zero on scale

The Scale tab contains the following options:

<4 Automatic Minimum. Select this option to have the engine automatically supply the
minimum value on the Y-axis scale. To use manual scaling, clear this option. You can
then set the minimum value by entering a number into the Value text box.

4 Value. Enter the minimum value in this text box if you have not selected Automatic
Minimum.

<4 Automatic Maximum. Select this option to have the engine automatically supply the
maximum value on the Y-axis scale. To use manual scaling, clear this option. You can
then set the maximum value by entering a number into the Value text box.

4 Value. Enter the maximum value in this text box if you have not selected Automatic
Maximum.

4 Automatic Grid Step. Select this option to automatically calculate the number of major
grid steps. To use manual scaling, clear this option. You can then set the value by entering
the number into the Value text box.

4 Value. Enter the value in this text box if you have not selected Automatic Grid Step.

286 WebFOCUS



5. Creating and Customizing Charts I

4 Logarithmic Scale. Select this option to control whether or not the Y-axis scale
progresses logarithmically instead of linearly. This option is disabled by default. When
selected, the logarithmic base is set to 10.0, but can be changed by entering another
value.

<4 Log scale base. Enter the base value to be shown on the logarithmic scale.

4 Include zero on scale. Select this option to control whether or not a zero (0) value
appears on the scale. This option is enabled by default.

Use the Title tab to create and style the title for the axis. The Title tab is shown in the
following image.

[, Format Vertical Axs -

Scale \ Title
Title

Text

Labels o
Style text !'["‘ﬂ-

Advanced

W OK {9 Cancel 2 Apply

The Title tab contains the following options:
4 Text. Enter a title for the axis.

<4 Style. Click this icon to open the Style dialog box, where you can style the text.
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Use the Labels tab to format the layout of the axis labels. The Labels tab is shown in the

following image.

@Fﬂmﬁl Vertical Axis w
e Labels
Title [¥] Show Labels
Labels Axis side | Left
Advanced Style labels @g
[ stagger Labels
Format Labels General
Custom Format o
0K X, Apply

The Labels tab contains the following options:

4 Show Labels. Select this option to display labels next to the axis. This is enabled by
default. Clear this option to suppress labels.

4 Axis side. Select from this drop-down menu of position options for the labels on the
axis. The options are Left (default), Right, or Both.

4 Style labels. Click this icon to open the Style dialog box, where you can style text.

1 Stagger Labels. Select this option to set the labels to appear staggered.

4 Format Labels. Select from this drop-down menu of preset formats that can be

applied to the labels.

4 Custom Format. Select this option to use a custom format.

The Format Labels drop-down menu provides a list of preset formats that you can apply to
labels. When you select a custom format, it must be defined using a custom format pattern.
See the following table for a list and description of the characters that you can use in a

custom format.
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Character Description

# Is a digit.

0 (zero) Shows as absent.

. (period) Is a placeholder for a decimal separator.

, (comma) Is a placeholder for a grouping separator.

; (semicolon) Separates formats.

- (dash) Is the default negative prefix.

% (percent) Divides by 100 and shows as a percentage.

X Determines that any other characters can be used in
the prefix or suffix.

‘ (apostrophe) Is used to quote special characters in a prefix or suffix.
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Use the Advanced tab to modify additional axis properties. The Advanced tab is shown in
the following image.

|1, Format Vertical Axis X

Scal
i | Advanced

Title [ Exdude Minimum Label

Labels [ Exdude Maximum Label

s [ Descending Axis
[¥] show ais line

Line Style Ly
[] show zero line

Line Style =y
[ Custom Baseline

Value 0.0

Line Style Hy

W OK £5) Cancel B Apply

The Advanced tab contains the following options:

d

Exclude Minimum Label. Select this option to exclude the label with the lowest axis
value from the chart.

Exclude Maximum Label. Select this option to exclude the label with the highest axis
value from the chart.

Descending Axis. Select this option to draw the axis in descending order.
Show axis line. Select this axis to control the display of the axis baseline.

Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the axis line.

Show zero line. Select this option to control the display of the zero line.

Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the zero line.
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4 Custom Baseline. Select this option to control the display of the custom baseline.
4 Value. Enter a value for the custom baseline.

4 Line Style. Click this icon to open the Line Style dialog box, where you can edit the color,
weight, and style of the custom baseline.

For instructions on how to open this dialog box, see the procedures in Using Axis Properties
on page 293.

Secondary Axes Options

Formatting option are available for secondary axes in dual-axis charts. For example, in a
vertical dual-axis chart, the secondary vertical axis refers to the Y2 axis.

The Format Secondary Axis dialog box contains the following tabs for both vertical and
horizontal axes:

<4 General. For more information, see the Scale tab options in Format Axis Dialog Box on
page 285.

4 Title. For more information, see the equivalent tab in Format Axis Dialog Box on page
285.

<4 Labels. For more information, see the equivalent tab in Format Axis Dialog Box on page
285.

4 Advanced. For more information, see the equivalent tab in Format Axis Dialog Box on
page 285.

Axis Elements Right-Click Menu

When you right-click an axis label in a chart in Live Preview, a menu of options opens. The
options for the right-click axis label elements are described in the following tables.
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Element Option Description
Horizontal Delete Deletes labels from the chart and updates the Live Preview
Labels accordingly.

Stagger Controls the positioning of the labels. The On value
positions the labels in a zigzag pattern. The Off default
value positions the labels in a straight row.

Rotate Rotates the labels a specified number of degrees.

Style Labels | Enables you to apply styling to the labels, using the Style
dialog box. For more information, see Style Dialog Box on
page 252.

More Axis Opens the Format Axis dialog box. For more information,

Options see Formatting Axis Labels on page 284.

Vertical Delete Deletes labels from the chart and updates the Live Preview
Labels accordingly.

Stagger Controls the positioning of the labels. The On value
positions the labels in a zigzag pattern. The Off default
value positions the labels in a straight row.

Rotate Rotates the labels a specified number of degrees.

Format Formats the labels according to the value that you specify.

Labels

Style Labels | Enables you to apply styling to the labels, using the Style
dialog box. For more information, see Style Dialog Box on
page 252.

More Axis Opens the Format Axis dialog box. For more information,

Options see Formatting Axis Labels on page 284.

292
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Using Axis Properties

How to:

Delete Axis Labels

Stagger Axis Labels

Rotate Axis Labels

Format Axis Labels

Manually Set the Scale of an Axis
Add an Axis Title

Set Advanced Axis Properties

The following sections contain procedures for customizing an axis. The procedures are
organized by the tab and group in which their associated options appear on the ribbon.

Axis labels appear by default.

Procedure: How to Delete Axis Labels
1. Create a chart.

2. You can delete axis labels in one of the following ways:

-1 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, and clear the Show Labels option.

4 Right-Click Menu: Right-click an axis label on the chart, and select Delete.

The axis labels are deleted from the chart.

Procedure: How to Stagger Axis Labels
1. Create a chart with at least one axis label on display.

2. Access the Stagger option in one of the following ways:

4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, and select Stagger Labels.

41 Right-Click Menu: Right-click an axis label on the chart, point to Stagger and select
On.

The axis labels are staggered.
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The following image shows a chart with the vertical axis labels staggered.
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Procedure: How to Rotate Axis Labels
1. Create a chart with axis labels.

2. Access the Rotate option in one of the following ways:

4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, point to Rotate Labels, and then select
the degree to which you want to rotate the axis labels.

4 Right-Click Menu: Right-click an axis label on the chart, point to Rotate, and then
select the degree to which you want to rotate the axis labels.

The axis labels are rotated.
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The following image shows a chart with the axis labels rotated 45 degrees.
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Procedure: How to Format Axis Labels
1. Create a chart with an axis label.

2. Access the list of axis label options in one of the following ways:

1 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, and select More Axis Options to open the
Format Axis dialog box. Open the Labels tab, and from the Labels option drop-down
menu, select the formatting option that you want.

1 Right-Click Menu: Right-click an axis label, point to Format Labels, and select the
formatting option that you want.

The axis labels are formatted accordingly.
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The following image shows a chart with the axis labels styled in red, bold, Arial font.
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Procedure: How to Manually Set the Scale of an Axis

296

1.
2.

Create a chart.

Open the Format Axis dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, and select More Axis Options.

1 Right-Click Menu: Right-click an axis value on the chart, and select More Axis
Options.

The Format Axis dialog box opens.

On the scale tab, clear the Automatic Minimum option and enter your own minimum
value in the Value text box.

Clear the Automatic Maximum option, and enter your own maximum value in the Value
text box.

Clear the Automatic Grid Step option, and enter your own grid step value in the Value
text box.

Optionally, you can select the Logarithmic Scale option and enter the log scale base in
the text field of that name. You can also clear the Include zero on scale option if you do
not want zero to appear on the axis.

Click OK to close the dialog box.
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Procedure:

The axis scale is set accordingly.

How to Add an Axis Title
1. Create a chart with an axis label.

2. Open the Format Axis dialog box in one of the following ways:

1 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, and select More Axis Options.

4 Right-Click Menu: Right-click an axis label, and select More Axis Options.
The Format Axis dialog box opens.

On the Title tab, type the axis title in the Text field.

Click the Style text icon to open the Style dialog box, where you can style the text.
The axis title is styled accordingly.

Note: Right-click the axis title to delete, change, or style the axis title.

The following image shows a chart with a title added to the vertical axis.
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Procedure: How to Set Advanced Axis Properties

1. Create a chart with an axis label.

2. Open the Format Axis dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Labels group, open the Axes drop-down menu,
point to the axis that you are working with, and select More Axis Options.

4 Right-Click Menu: Right-click an axis label, and select More Axis Options.
The Format Axis dialog box opens.
3. On the Advanced tab, set the following options:
<4 Exclude Minimum Label
-1 Exclude Maximum Label
4 Descending Axis
-1 Show axis line
-1 Show zero line
4 Custom Baseline (Value)

You can edit the color, weight, and style of all the lines that you set in the Line Style
dialog box.

4. Click OK.

The axis advanced options are set accordingly.

Formatting a Frame and a Background
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In this section:
Frame & Background Dialog Box
Frame and Background Right-Click Menu

Using Frame and Background Properties

The frame of a chart is the area that contains the plot points. It is also the area in which
horizontal and vertical gridlines are drawn.

The background of a chart is the area around the frame.
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You can adjust the appearance of the frame and background to achieve different visual
effects for your charts. For example, you can change the appearance of the chart frame line,
or you can change the color of the background of your chart.

Frame & Background Dialog Box

Whether you access frame and background options from the ribbon, or the right-click menu,
you are presented with the Frame & Background dialog box of options for formatting the
frame and background of a chart. The Frame & Background dialog contains the following
tabs:

4 Frame
<4 Frame Edge
4 Background

The Frame & Background dialog box and pertinent tabs are discussed in this section for the
following types of charts:

<4 2D Charts and 2D Charts with 3D Effects (Frame and Frame Edge tabs)
4 Pie Charts (Frame and Frame Edge tabs)

<4 3D Charts (Left Wall, Right Wall, Floor, and Advanced tabs)

Note: The options in the Frame tab vary based on the chart type selected.
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Use the Frame tab for 2D charts and 2D charts with 3D effects to set a frame depth angle
and depth radius, select a fill for a frame, and set a shadow for a frame for these types of
charts. The Frame tab for 2D charts and 2D charts with 3D effects is shown in the following

image.
(1] Frame & Background X
Erame Frame
Frame Edge Depth Angle 45 Depth Radius i
Backaround
Fill
) No fil
@ Solid fil
) Gradient fil
Colar I::!
Transparency [ - 0~ %
i Shadow

[] sShow Shadow

" OK S cancel 2 apply

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:

4 Depth Angle. Enter the angle from the front of the chart to the back where the chart
risers and frames are drawn. You can set the depth angle from zero to 180 degrees, but
it must be used along with Depth Radius.

4 Depth Radius. Enter how far out the extruded frame will be extended. Small values,
such as zero, produce very narrow charts. Large values, the maximum being 100, produce
thicker charts.

Fill
4 No fill. (Default). Select this option to keep the legend colorless.

4 Solid fill. Select this option to display the Color and Transparency options.
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4 Color. Click this icon to open the Color dialog box, where you can select a color for
a frame.

41 Transparency. Move the slider to make the frame opaque (0%) or transparent (100%).
The default is 0%.

4 Gradient fill. Select this option to display the direction of the gradient, the color pattern
of the gradient, and the degrees of transparency for the two colors that make up the
gradient. A gradient is a smooth color transition or blending of one color to another. The
number of colors to use in a gradient is defined by the stop or pin elements.

< Direction. Select from this drop-down menu to set the direction of the gradient fill.
The options are:

4 Gradient right

-1 Gradient left

<1 Gradient down

4 Gradient up

- Gradient down left

4 Gradient up left

4 Gradient down right

4 Gradient up right

-1 Radial

4 Radial top left

< Radial top right

- Radial bottom left

<4 Radial bottom right

4 Radial pie

1 Radial pie inverted
Gradient style

1 Color Pattern. Select the color pattern for the data series. The color pattern option on
the left is an AB wash that uses two colors in the pattern colorl - color2, for example,
red-green. The color pattern option on the right is an ABA wash that uses two colors in
the pattern colorl - color2 - colorl, for example, red-green-red.

WebFOCUS InfoAssist User's Manual 301



Formatting a Frame and a Background

4 First Color. Click this icon to open the Color dialog box, where you can select a color
for the first color.

4 Second Color. Click this icon to open the Color dialog box, where you can select a color
for the second color.

Shadow
4 Show Shadow. Select this option to set a shadow.

Use the Frame Edge tab for 2D charts and 2D charts with 3D effects to set a frame depth
angle and depth radius, select a fill for a frame, and set a shadow for a frame for these
types of charts. The Frame Edge tab is shown in the following image.

@Frame&ﬂackgmund W

Frame

Frame Edge

Fr Ed
=S Automatically Shade Frame Edge

Backaround

Side Frame

A

Bottom Frame

A

o OK S cancel 2 Apply

The Frame tab for 2D charts and 2D charts with 3D effects contains the following options:
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A

Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge. Clear this option to enable the Side Frame and Bottom Frame options.

Side Frame

o

A

Show Color. Select this option to show the color of the side frame.

Color. Click this icon to open the Color dialog box, where you can select a color for the
side frame.

Show Border Color. Select this option to show the color of the border of the side frame.

Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border of the side frame.

Bottom Frame

o

A

Show Color. Select this option to show the color of the bottom frame.

Color. Click this icon to open the Color dialog box, where you can select a color for the
bottom frame.

Show Border Color. Select this option to show the color of the bottom frame.

Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border of the bottom frame.
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Use the Frame tab for pie charts to set pie depth and tilt, select a fill and color for a pie
frame, and set a shadow for the frame. The Frame tab is shown in the following image.

@Frame&ﬂar_kgmund w
RS Frame
Frame Edge
Fie Depth 0 Fie Tilt |q
Backaground
Fill
@ Mo fil
() Solid fill
() Gradient fil
Shadow

[] Show Shadow

" OK (S cancel 5 Apply

The Frame tab for pie charts contains the following options:

<4 Pie Depth. Set the depth of the edge of a pie chart. You can select a value from zero
to 100 to set the thickness of an edge.

4 Pie Tilt. Set the tilt of the pie chart. The smaller the value you add, the flatter the pie
chart appears. The larger the value you add, more of the pie edge appears.

Fill
<4 No fill. (Default). Results in no color added to the edge of the pie.
1 Solid fill. Select this option to display the Color and Transparency options.

4 Color. Click this icon to open the Color dialog box, where you can select a color for
the frame.

4 Transparency. Move the slider to make the fill opaque (0%) or transparent (100%).
The default is 0%.
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4 Gradient fill. Select this option to display the direction of the gradient, the color pattern
of the gradient, and the degrees of transparency for the two colors that make up the
gradient. A gradient is a smooth color transition or blending of one color to another. The
number of colors to use in a gradient is defined by the stop or pin elements.

< Direction. Select from this drop-down menu to set the direction of the gradient fill.
The options are:

d

;|

d

;|

Gradient right
Gradient left
Gradient down
Gradient up
Gradient down left
Gradient up left
Gradient down right
Gradient up right
Radial

Radial top left
Radial top right
Radial bottom left
Radial bottom right
Radial pie

Radial pie inverted

4 Gradient Style

;|

Shadow

Color Pattern. Select the color pattern for the data series. The color pattern

option on the left is an AB wash that uses two colors in the pattern colorl - color2,
for example, red-green. The color pattern option on the right is an ABA wash that
uses two colors in the pattern colorl - color2 - colorl, for example, red-green-red.

First Color. Click this icon to open the Color dialog box, where you can select a
color for the first color.

Second Color. Click this icon to open the Color dialog box, where you can select
a color for the second color.
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4 Show Shadow. Select this option to set a shadow around the frame.

Use the Frame Edge tab for pie charts to set the edge of a pie frame. The Frame Edge tab
is shown in the following image.

@Frame&ﬂackgrnund w

Frame

Frame Edge

Fr Ed
rame Eoge Automatically Shade Frame Edge

Background

Side Frame

Bottom Frame

A

0K S cancel 2 apply

The Frame Edge tab for pie charts contains the following options:

<4 Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge. Clear this option to enable the Side Frame and Bottom Frame options.

4 Show Color. Select this option to show the color of the side frame.

<4 Color. Click this icon to open the Color dialog box, where you can select a color for side
frame.

4 Show Border Color. Select this option to show the color of the border of the side frame.
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-

Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border of the side frame.

Bottom Frame

d

-

Show Color. Select this option to show the color of the bottom frame.

Color. Click this icon to open the Color dialog box, where you can select a color for the
bottom frame.

Show Border Color. Select this option to show the color of the bottom frame.

Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border of the bottom frame.

Use Wall and Floor tabs to set the walls and floor of a 3D chart. The Left Wall tab is shown
in the following image.

@Frame&'_ﬂackgrnund X
Left wall
Left wall
Right Wal
Show Wall
Floor Wall Thickness 0.0
Advanced Cube Size 30.0
Background

Color J Border Color ﬂ

W 0K (S cancel 2 apply

These Wall and Floor tabs contain the following options:

d

Show Wall or Show Floor. Select this option to show the wall or floor (depending on
the tab) of the 3D chart.

Wall Thickness. Specify the thickness of the wall or floor.
Cube Size. Specify the cube size of the wall or floor.

Color. Click this icon to open the Color dialog box, where you can select a color for the
wall or floor.
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4 Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border of the wall or floor.

4 Show Wall (Left Wall). Select this option to show the left wall.
4 Show Wall (Right Wall). Select this option to show the right wall.
4 Show Floor. Select this option to show the floor.

Use the Advanced tab for 3D charts to modify additional properties for 3D frames. The
Advanced tab for 3D charts is shown in the following image.

g Fraene= 8 Badegraund x

Laft Wal

Advanoad

Figrtal Wewng Angles Custom -

Floor
[ 1aometric Projection

Ackaroed

| Proportional Cube
Bactgrourd [ Austomatic shadng of wals
[ Avtomatically Shade Frame Edge
=D Zowoin Factor

Fan Horzantally

Fan Yerdcally

The Advanced tab contains the following options:

<4 Viewing Angles. Select from a drop-down menu of viewing angles for three-dimensional
charts. The options are:

4 Standard

4 Group View

4 Series View

- Distorted Value

4 Isometric Standard
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d

;|

Distorted Standard
Emphasize Group
Blast-O-Vision

Thin Wall

Isometric Group View
Isometric Group View #2
High Backed

Upward Distorted

Down Tilt

Narrow Isometric
Isometric view by groups

Custom

41 Isometric Projection. Select this option to ignore perspective distortion in a project

graph cube from an isometric view.

4 Proportional Cube. Select this option to define the axis size proportional to the number
of series or groups.

41 Automatic shading of walls. Select this option to shade chart walls.

4 Automatically Shade Frame Edge. Select this option to automatically shade the frame
edge.

4 3D Zoom Factor. Enter a value in the text box to set the global scaling factor for
zooming in and out in a 3D chart. Smaller values zoom out and produce a smaller
display of the chart within a frame. Larger values zoom in and produce a larger display

of the chart within a frame.

Pan Horizontally. Enter a value in the text box to pan a 3D chart in the horizontal
direction. Smaller values move the frame of the chart to the left. Larger values move

the frame of the chart to the right.

Pan Vertically. Enter a value in the text box to pan a 3D chart in the vertical direction.
Smaller values move the frame of the chart upward. Larger values move the frame of

the chart downward.
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Use the Background tab to set and customize a border for a chart. The Background tab is
shown in the following image.

@Frame&ﬂackgmund w
]
Leftwal Background
Right Wl Show Border Color
Floor Border Color ﬂ
Advanced Background Fil
@ Solid fil
Background _
) Gradient fil
Colar
Transparency o= o

« OK £5) cancel 5 Apply

The Background tab contains the following options:

-

d

Show Border Color. Select this option to show the color of the border.

Border Color. Click this icon to open the Color dialog box, where you can select a color
for the border.

Solid fill. Select this option to display the Color and Transparency options.

4 Color. Click this icon to open the Color dialog box, where you can select a color for
the frame.

4 Transparency. Move the slider to make the background opaque (0%) or transparent
(100%). The default is 0%.

Gradient fill. Select this option to display the direction of the gradient, the color pattern
of the gradient, and the degrees of transparency for the two colors that make up the
gradient. A gradient is a smooth color transition or blending of one color to another. The
number of colors to use in a gradient is defined by the stop or pin elements.

4 Direction. Select from this drop-down menu to set the direction of the gradient fill.
The options are:

4 Gradient right

WebFOCUS



5. Creating and Customizing Charts I

d

]

Gradient left
Gradient left
Gradient down
Gradient up
Gradient down left
Gradient up left
Gradient down right
Gradient up right
Radial

Radial top left
Radial top right
Radial bottom left
Radial bottom right
Radial pie

Radial pie inverted

Gradient Style

4 Color Pattern. Select the color pattern for the data series. The color pattern option on
the left is an AB wash that uses two colors in the pattern colorl - color2, for example,
red-green. The color pattern option on the right is an ABA wash that uses two colors in
the pattern colorl - color2 - colorl, for example, red-green-red.

< First Color. Click this icon to open the Color dialog box, where you can select a color
for the first color.

1 Second Color. Click this icon to open the Color dialog box, where you can select a color
for the second color.

For instructions on how to open this dialog box, see the procedures in Using Frame and

Background Properties on page 313.
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Frame and Background Right-Click Menu

When you right-click a chart background, a menu of options opens. The options for the
background and frame elements are described in the following table.

Element Option Description

Background Background Color Enables you to specify the color of the
background, using the Color dialog box.
For instructions, How to Change the Color
of the Background on page 315.

Show legend Controls the display of the legend on the
background. When selected, it displays
the legend. When cleared, it suppresses
the display of the legend.

More Frame and Opens the Frame & Background dialog box.
Background Options | For more information, see Frame &
Background Dialog Box on page 299.

Frame Frame Color Enables you to specify the color of the
frame, using the Color dialog box. For more
information, see Color Dialog Box on page
46.

Show 3D Controls the depth of the frame. The value
On renders the frame in 3D depth. The
value Off renders the frame in one
dimension.

For instructions, see How to Set 3D Depth
on a Bar Chart on page 345.

More Frame and Opens the Frame & Background dialog box.
Background Options | For more information, see Frame &
Background Dialog Box on page 299.
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Using Frame and Background Properties

How to:
Change the Color of the Frame

Change the Color of the Background

The following sections contain procedures for customizing frame and background properties.
The options for the following procedures are found in the Features group of the Format tab.

Procedure: How to Change the Color of the Frame

The default color of the frame in a chart is determined by the Document Theme selected on
the Options window. For more information, see Changing User Preferences on page 25. The
following image shows a chart with the default frame color.

3% 7%
28% 19%
42%
Cluantity Sold
B Divorced Married B Single M Unmarried partners
B Widowed

This procedure describes how to change the color of the frame.
1. Create a chart.

2. Access the Frame & Background dialog box in one of the following ways:

1 Ribbon: On the Format tab, in the Features group, click Frame & Background.
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1 Right-Click Menu: Right-click the chart, and select More Frame & Background Options.

The Frame & Background dialog box opens.

3. On the Frame tab, in the Fill area, click the Color icon. Note: Solid fill must be selected
for the Color icon to appear.

The Color dialog box opens. Select a new color for the frame. For more information on
the Color dialog box, see Color Dialog Box on page 46. You can also set the depth angle
and depth radius for the frame, as well as set a shadow for the frame.

4. Click OK.
The chart displays the new frame color.

The following image shows the same chart with a new frame color.

B Divorced 0 Married B Single B Unmarried partners
B Widowed
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Procedure: How to Change the Color of the Background

The default color of the background of a chart is determined by the Document Theme selected
on the Options window. For more information, see Changing User Preferences on page 25.
The following image shows a chart with the default background color.

100

80

60

Quantity Sold

40

20

Divorced Married Single Unmarried partners Widowed
Marital Status

Create a chart.
Open the Frame & Background dialog box in one of the following ways:
1 Ribbon: On the Format tab, in the Features group, click Frame & Background.

4 Right-Click Menu: Right-click the background of the chart, and select Background
Color.

The Frame & Background dialog box opens.

3. On the Background tab, in the Fill area, click the Color icon.

The Color dialog box opens. Select a new color for the background. For more information
on the Color dialog box, see Color Dialog Box on page 46.

4. Click OK.

The chart displays the new background color.
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In the following image, the chart now has a background color.
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Formatting a Gauge Chart

In this section:

Format Gauge Dialog Box

Gauge Elements Right-Click Menu
Using Gauge Properties

A gauge chart, is a circular chart, that indicates the current position of a single data value
within a given spectrum. A gauge chart shown in the following image.

46.15629M

Dollar Sales

You can change the appearance of a gauge chart by using the gauge chart options found
on the Format Gauge dialog box.
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Format Gauge Dialog Box

318

Whether you access gauge options from the ribbon, or the right-click menu, you are presented
with the Format Gauge dialog box of options for formatting a gauge chart. Such options

include setting and styling a title for the gauge chart, setting tick marks, enabling and styling
color bands, as well as setting advanced options, such as the gauge start and stop angle.

The Format Gauge dialog box contains the following tabs:
4 General Options

< Axis Scale & Labels

4 Tick Marks

< Bands

4 Advanced
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Use the General Options tab to set general gauge options. The General Options tab is shown
in the following image.

@Format Gauge X
zeneral Options General Options
Axis Scale & Labels Gauges per row 2=
Tick Marks
Background Style Green Bevel -
Bands
Gauge Meedle
Advanced

Style Screwdriver -

Color _EJ
Border Color !J

Gauge Tite

Show title

Position Above -

style 54

Gauge value
Show value
style [

" 0K ®cancel 2 Apply

The General Options tab contains the following options:

d Gauges per row. Enter or select how many gauges appear on each row. The default
setting displays two gauge charts. A maximum of 32 gauge charts can appear on each
row.
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4 Background Style. Select from a drop-down menu a style for the background. The
options are:

;|

d

;|

;|

;|

Green Bevel (default)
Grey Bevel
Gold Bevel
Grey Bevel 2
Gold Bevel 2
Thin Black
Thin Black 2
Grey Bevel 3
Grey

Blue Bevel
Grey Flat

Turquoise Bevel

Gauge Needle

1 Style. Select a style from a drop-down menu of options to be applied to the gauge needle.
The options are:

;|

d

;|

d

;|

Thin

Thick

Normal (default)
Screwdriver

Pencil

-1 Color. Click this icon to open the Color dialog box, where you can select a color for the
gauge needle. Note: If you are working with a gauge chart with more than one series,
then you use the Format Series dialog box to format the color of the gauge needle and
its border.

-1 Border Color. Click this icon to open the Color dialog box, where you can select a color
for the gauge needle border. Note: If you are working with a gauge chart with more than
one series, then you use the Format Series dialog box to format the color of the gauge
needle and its border.
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Gauge Title

4 Show title. (Default) Displays a gauge title appear for each gauge. Clear this option to
suppress the title.

4 Position. Select a position for the gauge title. The options are:
4 Above (default)
4 Center
4 Below

4 Style. Click this icon to open the Style dialog box, where you can style text.

Gauge value
4 Show value. (Default) Clear this option to suppress the gauge value.

4 Style. Click this icon to open the Style dialog box, where you can style text.
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Use the Axis Scale & Labels tab to set the axis scale and label properties for the gauge
needle. The Axis Scale & Labels tab is shown in the following image.

@Furmat Gauge =
General Options Axis Scale & Labek
Axis Scale & Labels Scale
Tick Marks Automatic Minimum
Bands Value
Advanced

Automatic Maximum

Value

Labels

Show Labels
Style Labels @

Format Labels General -

" OK @'Can::el 2 apply

The Axis Scale & Labels tab contains the following options:

Scale

4 Automatic Minimum. (Default) Sets the engine to automatically supply the minimum
value on the scale. Clear this option to manually set the minimum value by entering a
number into the Value text box.

4 Value. Enter the minimum value in this text box if you have not selected Automatic
Minimum.

<4 Automatic Maximum. (Default) Sets the engine to automatically supply the maximum
value on the scale. Clear this option to manually set the maximum value by entering a
number into the Value text box.
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4 Value. Enter the maximum value in this text box if you have not selected Automatic
Maximum.

Labels

4 Show Labels. (Default) Displays labels next to the axis. Clear this option to suppress
labels.

4 Style Labels. Click this icon to opens the Style dialog box, where you can style text.

4 Format Labels. Select from a drop-down menu of present formats that can be applied
to the labels. When a custom format is selected, the format must be defined using a
custom format pattern. For a list and description of the characters that you can use in
a custom format, see the table in Formatting Data Labels on page 242.

4 Custom Format. Text field to enter the custom format that you want to use.
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The Tick Marks tab contains options to format tick marks on a gauge chart. The Tick Marks
tab is shown in the following image.

@Fnrmat Gauge <
General Options Tick Marks
Axis Scale & Labels Major Ticks
Tick Marks Automatic Grid Step
Bands VYalue
Advanced Tick Color !J

Tick Mark Length  |0.15

Miror Ticks

Automatic Grid Step

Value

Tick Color !J

Tick Mark Length  0.05

" OK @ Cancel 2. apply

The Tick Marks tab contains the following options:

<4 Automatic Grid Step. (Default) Automatically calculates the number of major grid steps
in a gauge chart. Clear this option to manually set the value by entering a number in the
Value text box.

4 Value. Enter the value in this text box if you have not selected Automatic Grid Step.

< Tick Color. Click this icon to open the Color dialog box, where you can select a color for
the tick marks.

4 Tick Mark Length. Enter a value for the relative length of major tick marks in a gauge
chart. The valid range is from 0.0 to 0.5. If you set the smallest value, major tick marks
do not appear.
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The Bands tab contains options to format the color of the scale background on a gauge
chart. The Bands tab is shown in the following image.

@Furmat Gauge =
General Options Bands
Axis Scale & Labels Band 1 - R
emaove
Tick Marks
Minimum Value 0.0
Bands
P Maximum Value | 20.0

Border Color !J

Fill
() Mo fill
i@ Solid fill
Colar !J
Transparency 0= =

" OK S cancel & Apply

The Bands tab contains the following options:
4 Band 1. Opens a drop-down menu of available bands.

4 Add. Adds the band selected from the drop-down menu of bands to the gauge chart.
You can create up to five bands for a gauge chart.

4 Remove. Removes the band selected from the drop-down menu of bands to the gauge
chart.

<4 Minimum Value. Enter a minimum value to a quality band in the gauge chart.
<4 Maximum Value. Enter a maximum value to a quality band in the gauge chart.

4 Border Color. Opens the Color dialog box, where you can edit the color of the gauge
band border.
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Fill

4 No fill. Removes fill from the quality band.

4 Solid fill. (Default) Applies a solid color to the quality band.

4 Color. Click this option to open the Color dialog box, where you can select the color for

the quality band.

4 Transparency. Move the slider to make the band opaque (0%) or transparent (100%).

The default is 0%.

The Advanced tab contains options to set additional properties for the gauge needle. It is
shown in the following image.

@Fnrmat Gauge

General Options

Axis Scale & Labels

Tick Marks

Bands

Advanced

Advanced

[7] Descending Axis
Show Zero Label

[7] Gauge Center by Quality

Gauge Start Angle  220.0

Gauge Stop Angle  320.0
Relative Inner Radius 0.7

Relative Thickness 0.1

|:| Same Size Gauges

The Advanced tab contains the following options:

o 0K 5 Cancel 2, apply

<4 Descending Axis. Select this option to draw the gauge scale in descending order. When
this option is cleared (default), the gauge scale is drawn in ascending order.
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4 Show Zero Label. (Default) Displays the zero label appear on the axis scale. Clear this
option to start the gauge at a another value.

4 Gauge Center by Quality. Select this option to have the center of the gauge needle
appear in the same the color as the band it is pointing to.

41 Gauge Start Angle. Enter a value to rotate the gauge start angle to a specified number
of degrees. Values can range from O to 359 degrees. The default is 220 degrees.

41 Gauge Stop Angle. Enter a value to rotate the gauge stop angle to a specified number
of degrees. Values can range from O to 359 degrees. The default is 320 degrees. Setting
a start angle to O, and a stop angle to 180, creates a semi-circle.

4 Relative Inner Radius. Enter a value to define the inner radius of the gauge bands and
labels relative to the outer background of the gauge. Smaller values, such as 0.0, place
the inner radius closer to the center of the gauge. A maximum value of 1.0, places the
inner radius close to the gauge outline.

41 Relative Thickness. Enter a value to define the relative thickness of the gauge bands.
Values can range from 0.0 to 1.0.

1 Same Size Gauges. This option applies to multi-category gauge charts. If you are working
with three or more gauges per row, you can select this option to have the gauges display
in the same size.

Gauge Elements Right-Click Menu

When you right-click a gauge chart, a menu containing the More Gauge Options becomes
available. Select this option to open the Format Gauge dialog box.
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Using Gauge Properties

The following sections contain procedures for gauge properties. The Gauges option can be
found on the Format tab, in the Features group. Note: This option is only available when
you are working with a gauge chart.
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Procedure: How to Set the Number of Gauges Per Row

If you have multiple gauges on a chart, you might want to specify how many gauges appear
on each row. In the following example, a maximum of two gauges per row has been set.

Age : Infant Age : Preschool

Create a gauge chart that has multiple values.
2. Open the Format Gauge dialog box in one of the following ways:
4 Ribbon: On the Format tab, in the Features group, click Gauges.
1 Right-Click Menu: Right-click the gauge chart and select More Gauge Options.

The Format Gauge dialog box opens.

3. On the General options tab, in the Gauges per row field, enter or select the number of
gauges that you want to appear on one row.

4. Click OK.

The gauges now appear on one row.
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After changing the setting from the default of 2 gauges per row to 3 gauges per row, all
the charts now appear on one row.

Age : Infant Age : Preschool Age : School Age
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Procedure: How to Set the Minimum and Maximum Axis Scale Values

The following image shows a gauge chart with the scale values automatically supplied by
the chart engine.

Quantity Sold : Stereo Systems

1. Create a gauge chart.
The following image shows a gauge chart with default settings.
2. Open the Format Gauge dialog box in one of the following ways:
1 Ribbon: On the Format tab, in the Features group, click Gauges.
4 Right-Click Menu: Right-click the gauge chart, and select More Gauge Options.

The Format Gauge dialog box opens.

3. On the Axis Scale & Labels tab, in the Scale area, either accept the minimum and
maximum values for the scale automatically supplied by the chart engine, or enter your
own in the Value fields.

4. Click Apply.
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The gauge scale reflects the selections that you have made.

The following image shows the changes that were applied to the axis scale of the gauge
chart in the preceding image. The automatic minimum value was cleared and a value
of 20000 was set. The automatic maximum value was cleared and a value of 60000
was set.

Guantity Sold : Stereo Systems

Procedure: How to Style Axis Labels
1. Create a gauge chart.

2. Open the Style dialog box in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, click Gauges to open the Format
Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab.
In the Labels area, click the Style Labels icon.

4 Right-Click Menu: Right-click an axis label, and click Style.
The Style dialog box opens.
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Select your styling options.
4. Click OK.
The scale labels reflect the style selections that you have made.

The following image shows a gauge chart with the axis labels in bold red Courier font.

Cluantity Sold : Stereo Systems

Procedure: How to Format Axis Labels
1. Create a gauge chart.

2. Access the menu of available format options for axis labels in one of the following ways:

4 Ribbon: On the Format tab, in the Features group, click Gauges to open the Format
Gauge dialog box. In the Format Gauge dialog box, open the Axis Scale & Labels tab.
In the Labels area, open the Format Labels drop-down menu.

1 Right-Click Menu: Right-click an axis label, and point to Format.

The menu of available format options opens.
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3.

Select your format option.

Note: If you select a custom format (for example, User Pattern, or Use Pattern /100),
from the Format Labels menu on the Format Gauge dialog box, the Custom Format menu
becomes available. When you select a custom format, it must be defined using a custom
format pattern. For a list and description of the characters that you can use in a custom
format, see the table in Formatting Data Labels on page 242.

Click OK.
The scale labels reflect the format selection that you have made.

Procedure: How to Rotate Axis Labels

1.
2.
3.

334

Create a gauge chart.
Right-click an axis label.

On the right-click menu, point to Rotate, then select the degree to which you want the
labels rotated.

The following image shows a gauge chart with the axis labels rotated 45 degrees.

Guantity Sold : Stereo Systems
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Procedure: How to Set Gauge Tick Marks

This procedure describes how to set the grid step, tick color, and tick length for the major
and minor tick marks.

The following image shows a gauge chart with default tick marks.
1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:
4 Ribbon: On the Format tab, in the Features group, click Gauges.
<4 Right-Click Menu: Right-click the gauge chart and select More Gauge Options.

The Format Gauge dialog box opens.

3. On the Tick Marks tab, for the Automatic Grid Step, either accept the value automatically
supplied by the chart engine, or enter your own, in the Value fields.

4. Click the Tick Color icon, to open the Color dialog box, where you can select a color for
the tick mark.

5. For the Tick Mark Length, either accept the value automatically supplied by the chart
engine, or enter your own, in the Value fields.
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The following image shows the same gauge chart. The major ticks marks have been
changed to red from black. They are now.30 in length, double their original size of.15.
The minor tick marks are now blue instead of black. Their size has also been increased.
They are now.10 in length, instead of.05.

Dollar Sales

A4

20M 30M
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Procedure: How to Set Gauge Color Bands

The following image shows the gauge chart without color bands.

Quantity Saold : Married

Create a gauge chart.

Open the Format Gauge dialog box in one of the following ways:

1 Ribbon: On the Format tab, in the Features group, click Gauges.

4 Right-Click Menu: Right-click the gauge chart, and select More Gauge Options.
The Format Gauge dialog box opens.

3. Set the minimum and maximum value for each band that you want to appear on the
gauge chart.

4. Set the color of the fill and border for each color band.

Note: The gradient fill option is not available for color bands.

5. Click OK to close the Format Gauge dialog box.

The bands are formatted accordingly.
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The following images shows a gauge chart with color bands.

Cluantity Sold : Married

Procedure: How to Match Needle Center Color to Band Color (Gauge Center by Quality)

338

This option matches the needle center color to the color of the band that the needle is
pointing to.

1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:
1 Ribbon: On the Format tab, in the Features group, click Gauges.
4 Right-Click Menu: Right-click the gauge chart and select More Gauge Options.
The Format Gauge dialog box opens.

3. On the Bands tab, set the minimum and maximum value for each band that you want
to appear on the gauge chart

4. Set the color of the fill and border for each color band.
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Note: The gradient fill and transparency options are not available for gauge needles.

On the Advanced tab, select Gauge Center by Quality.
Click OK to close the Format Gauge dialog box.
The color of the center of the gauge needle now matches the color of the band.

The following image shows a gauge chart with the center of the gauge needle in the
same color as the band it is pointing to.

Quantity Saold : Married

Procedure: How to Style a Gauge Needle

This procedure explains how to change the gauge needle from the Normal style to the Pencil
style.

1. Create a gauge chart.

2. Open the Format Gauge dialog box in one of the following ways:

d Ribbon: On the Format tab, in the Features group, click Gauges.
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4 Right-Click Menu: Right-click the gauge chart, and select More Gauge Options.

3. The Format Gauges dialog box opens.

4. Inthe General Options tab, in the Gauge Needle section, from the Style drop-down menu,
select Pencil.

5. Click OK.
The gauge needle changes to a pencil.

The following image shows a gauge chart styled with a pencil.

Quantity Sold

Procedure: How to Set Gauge Needle Colors in a Multi Series Gauge Chart

You cannot change the fill color and border color of the needles in a multi-series gauge chart
through the General Options tab of the Format Gauge dialog box. You can do so through the
Format Series dialog box. However, you can still use the General Options tab to change the
style of the needle.
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The following image shows gauge charts with two series of data.

MNorthEast SouthWest
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Create a gauge chart with more than one measure.

On the Series tab, from the Series drop-down menu, select the series that you want to
style.

3. In the Properties group, click Style.

The Format Series dialog box opens.

4. On the Fill tab, select the fill and color options for the gauge needle for the selected
series.

5. On the Border tab, select the Show Border Color option, if you want the gauge needle
to have a border. You can select the color for the border, as well.

Click Apply.
Repeat steps 2 through 5 for each series gauge needle that you want to style.
When you are finished, click OK to close the Format Series dialog box.

The color of the gauge needles and their borders changes accordingly.
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The following image shows the same gauge chart with the needles with new colors, The
Show Border Color option has been enabled with the default color of black for the border
color.
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Formatting Page Headings and Page Footings

How to:
Add a Page Heading and Page Footing to a Chart
Control the Rendering of a Page Heading and Page Footing

Page headings and page footings supply context and key information about a chart, such
as its purpose, audience, and author. Page headings and page footings also enhance visual
appeal.

Procedure: How to Add a Page Heading and Page Footing to a Chart
The procedure uses sample values, but you can supply values that apply to your own charts.
This feature is available in Query Design view, Live Preview, and Document view.
1. Create a chart.
2. With your chart open, on the Home tab, in the Report group, click Header & Footer.

The Header & Footer dialog box opens.
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Tip: Another way to access the Heading & Footing dialog box is to click the arrow next
to the Header & Footer button. Doing so opens a drop-down menu from which you can
select the heading or footing that you want to work with. After you make your selection,
the Header & Footer dialog box opens, and the heading or footing that you selected is
active.

3. Click the tab for the page heading or page footing, depending on which you want to add.

By default, the Page Heading tab is selected. In this procedure, accept the default to
add a page heading first.

4. Click inside the design area of the dialog box, and type the text for the page heading.

For example, the text for a sample page heading might be Customers By Occupation.

5. Using the styling options, apply styling to the page heading text.

In this example, the heading is styled in 14 pt. bold Helvetica with center alignment.

Click Apply to save the changes that you have made, without closing the dialog box.
To add a page footing, click the Page Footer tab.

For this procedure, you are going to add one of the supplied quick text options, followed
by some text of your own.

8. Click the down arrow next to the preformatted text button, and click Created by from the
drop-down list, as shown in the following image.

ERETTI
Draft
Page ¥ of %
Confidentil
Datke b
Time ¥

| Createdby ) |

9. Complete the text by typing the applicable value within the supplied text, for example,
Sales Manager.

Change the styling as you want.

E B

Click OK to save the page heading and page footing and close the Header & Footer
dialog box.

The chart contains the page heading and page footing that you added and styled.
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Procedure:

344

The following image shows the chart that you formatted.

Customers By Occupation
2%
2e 19%
5% —
8% —
19%
L ——
17% \ A 2%
6%
Customers
B Adminstrative B Engineering B Executive Managemert Finance
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Services and Support Student
Created By Sales Manager

12 To make changes to either the page heading or page footing, return to Design view.
Right-click the header or footer, and click Edit from the drop-down menu.

How to Control the Rendering of a Page Heading and Page Footing

You can control the way in which a page heading and page footing are rendered on a chart
at run time.

1. Create a chart.

2. Open the Header & Footer dialog box, as described in How to Add a Page Heading and
Page Footing to a Chart on page 342.

3. Click the Text options for chart lm T button.

A drop-down menu, with two options for rendering the page heading and page footing,
opens.

Tip: Your selection for a page heading also applies to a page footing, and vice versa.

4 Create Header and Footer as text, renders the heading and footing as text elements
that are separate from the chart image. This is the default value.
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4 Embed Header and Footer in the chart, renders the heading and footing text as part
of the chart image.
4. Select Embed Header and Footer in the chart.

The heading and footing text are rendered as part of the chart image.

5. Click OK to save your selection and close the Heading & Footing dialog box.

Using Additional Formatting Features

How to:

Set 3D Depth on a Bar Chart
Rotate a Chart

Display Reference Lines

Display Annotations

Procedure: How to Set 3D Depth on a Bar Chart

You can apply a 3D-effect to a 2D-chart. Nete: If you find that the depth of the 3D effect
makes it difficult to distinguish the values on the Y-axis scale, then you can turn this option
off. This procedure explains how to set the 3D effect for a default vertical bar chart.
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The following image shows a bar chart before the 3D effect is applied.
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1. Create a 2D chart.
2. |In Live Preview, apply the 3D effect in one of the following ways:

K Ribbon: On the Format tab, in the Features group, click 3D Effect.
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1 Right-Click Menu: Right-click the frame of the chart, point to Show 3D, and select
On, as shown in the following image.
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The 3D effect is applied to the chart, as shown in the following image.
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Procedure: How to Rotate a Chart

You can rotate bar, line, and area charts to change the orientation of the data.

The following image shows a vertical chart before it is rotated.
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1. Create a chart.

2. On the Format tab, in the Features group, click Rotate.
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The chart is rotated 90 degrees clockwise. The following is an example of the same
chart above, now rotated.
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Quantity Sold

Procedure: How to Display Reference Lines

Reference lines draw attention to specific data locations on a chart. You can add up to three
horizontal (X axis) and three vertical (Y axis) reference lines to a chart.

1. Create a chart.

2. On the Format tab, in the Features group, click Reference.

3. In the drop-down menu that opens, select one of the following:
X Add Reference Line to Y axis

1 Add Reference Line to X axis
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The Reference Line dialog box opens, as shown in the following image.

ity Reference Line o ox

Bjcolor | —weight ~ | ——o style -

@ Value () Field
Value:

Text:
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" OK 4y Reset {8) Cancel

Create the reference line using either a static value that you set or a dynamic field that
you select from your data source.

To create a reference line by value:
a. Select the Value option.

b. Inthe Value text field, type the value that you want to distinguish with the reference
line.

c. Go to step b.
To create a reference line by field:
a. Select the Field option.

b. From the Field drop-down menu, select the field that you want to distinguish with
the reference line.

a. Go to step b.

In the Text field, type the text for the reference line.

In the Position drop-down menu, select the position for the reference line on the chart.
The options are:

4 Above Center (default)

d Above Left

[

Above Right

L

Below Center
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-

d

Below Left
Below Right

7. Click the Style button to set the style for the reference line. The options are:

-

d

-

-

Solid (default)
Dots

Many Dots
Dashed
Dashed Dots
Long Dash

Mixed Dashes

8. Click the Color button to open the Color dialog box, where you can select a color for the
reference line and the text.

9. Click the Weight button to select the weight of the reference line. The options are:

-

d

-

1px - Light (default)
2px - Medium
3px - Heavy

10. Click OK to save the options that you have selected, and close the Reference Line dialog
box.

The reference line is added to the chart.
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The following image shows a bar chart with a Y-axis reference line. The reference line
was added by typing 120 in the Value field, and Top Selling Product in the Text field.
The reference line uses the default Above Center setting for position. It is formatted as
a red, dotted line, of medium weight.
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Procedure: How to Display Annotations

Annotations are explanatory notes or comments. You can add up to eight annotations on a
chart.

1. Create a chart.
2. On the Format tab, in the Features group, click Annotate.

3. In the drop-down menu that opens, click Add an annotation.
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The Annotation dialog box opens, as shown in the following image.

I [T 1 -
[ Annotation 1 @
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In the text input field, type the text for the annotation.

In the Position drop-down menu, select the position for the annotation on the chart. The
options are:

o

A

o

Top Left

Top Middle
Top Right
Middle Left
Middle Right
Bottom Left
Bottom Middle
Bottom Right

6. Click OK to save the options that you selected, and close the Annotation dialog box.

The annotation is added to the chart.

7. Click Run to generate the report.
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The following image shows a chart with an annotation in the middle right position.
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Creating and Customizing Documents

Designing documents in Document view

allows you to add text, images, active Topics:

form controls, reports, and charts to 1 Accessing Document View
create documents that can be used to

generate presentation-ready reports - Building a Document

based on your data.

Document view combines the features
of report building with the ability to style
and present customized documents.
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Accessing Document View

How to:

Access Document View to Build a New Document

Access Document View by Opening an Item From the Splash Screen
Access Document View by Opening a Report From the Quick Access Toolbar

Access Document View From the Document Button on the Home and View Tabs

In Document view, you can:

1 Build a new document.

' Open an existing document.

1 Generate a new document from an existing single report.

A blank InfoAssist canvas in Document view is shown in the following image.
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Drag-and.drop.-fields..onto.the

—
B Document
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canvas or into the query pane
to begin building your report.
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Procedure: How to Access Document View to Build a New Document
You can access Document view from the InfoAssist splash screen to create a new document.

Note: The splash screen must be set to display when you start InfoAssist in order to run
this procedure. You use the Options window to set the splash screen to display. For more
information, see Changing User Preferences on page 25.

If InfoAssist is configured to start in Document mode, rather than with the splash screen,
then you can begin this procedure at step 3.

1. Open InfoAssist, as described in Accessing InfoAssist on page 22.

The splash screen appears, as shown in the following image.
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2. Select Build a Document.
An Open dialog box opens.

3. Select a data source to begin building your document.

Note: Documents can be built using more than one data source. The source you select
here is the one you will begin with, but you can add more at any time. For more
information on adding additional data sources, see Data Tab on page 62.

4. Click OK.

InfoAssist opens a new canvas in Document view.
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Procedure: How to Access Document View by Opening an Item From the Splash Screen

358

You can access existing documents in Document view from the InfoAssist splash screen.

Note: The splash screen must be set to display when you start InfoAssist in order to run
this procedure. You use the Options window to set the splash screen to display. For more
information, see Changing User Preferences on page 25.

1. Open InfoAssist, as described in Accessing InfoAssist on page 22.

The splash screen appears.

2. Click Open Existing Item, as shown in the following image.
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An Open dialog box opens.

3. Select one of the documents. Documents are represented by the Document icon.
4. Click OK.
InfoAssist opens the document in Document view.

Note: If you select a single report in step 3, InfoAssist opens the report in either Query
Design view or Live Preview. To view a copy of the report in Document view, see How to
Access Document View From the Document Button on the Home and View Tabs on page
359.
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Procedure: How to Access Document View by Opening a Report From the Quick Access Toolbar

You can access documents in Document view from the InfoAssist Quick Access Toolbar.

1. With InfoAssist open, click Open existing item @ from the Quick Access Toolbar.
An Open dialog box appears.

Select one of the documents, which are represented by the Document ﬂ icon.
Click OK.
InfoAssist opens the document in Document view.

Note: If you select a single report in step 2, InfoAssist opens the report, in either Query
Design view, or Live Preview. To view a copy of the report in Document view, see How
to Access Document View From the Document Button on the Home and View Tabs on
page 359.

Procedure: How to Access Document View From the Document Button on the Home and View
Tabs

With InfoAssist open in Live Preview or Query Design view, you can access Document view
by clicking the Document button in the Design group. The Design group appears on both the
Home and View tabs.

Accessing Document view by clicking the Document button creates a copy of the current
single report as a document. You can use this method to promote My Content to Document
view.

You can also access Document view in Reporting Objects by following this procedure.

Note: When a Reporting Object is promoted to Document view, any reports and charts that
the Reporting Object has are added to the canvas.

1. With an InfoAssist report open, click either the Home tab, or the View tab.
2. In the Design group, click Document.

InfoAssist enters Document view.
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The Document icon is highlighted in the Design group and in the left corner of the
Navigation taskbar. The following image shows the highlighted Document icon.
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Note: The single report you started with still exists in the original view. Selecting
Document view while a single report is open does not convert the report to a document.
It makes a copy of the report, with the copy becoming a document and the original
remaining unchanged.

You can switch between the new document and the original report using the Switch
Report button. The Switch button is found on the View tab, in the Report group and on
the Status bar. You can also switch between the document and the report using the
reports button on the status bar. For more information on switching between reports,
see View Tab on page 78.

360
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Building a Document

In this section:

Inserting Reports From Multiple Data Sources
Inserting a New Report

Inserting a New Chart

Inserting an Existing Report

Creating a Document From a Single Report
Inserting Text and Images

Editing Components in a Document

Document view allows you to build multiple reports and charts on the same canvas. The
styling, design, and report building functionality of Live Preview and Query Design view is
available in Document view.

In addition, there are many other features that simplify building documents. You can build
and insert multiple reports in the form of reports and charts into documents. You can also
insert images and text for presentation and organizational purposes.

Inserting Reports From Multiple Data Sources

Procedure:

How to:

Insert Two Reports From Two Different Data Sources

With InfoAssist opened in Document view, you can insert multiple charts and reports onto
the canvas. These reports can be from different data sources. With documents, you have
the option to add additional data sources to the document.

In order to insert reports from different data sources, the document must have multiple data
sources loaded. For more information on adding and switching between data sources, see
Data Tab on page 62.

Note: You cannot use multiple data sources when working with a Reporting Object.

How to Insert Two Reports From Two Different Data Sources
A document can display multiple reports from multiple data sources in the same document.
1. With InfoAssist open in Document view, insert a chart or report.

2. If your document has only one data source, insert additional data sources.
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362

For more detailed instructions on inserting multiple data sources, see Data Tab on page
62.
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3. Switch to a data source different than the one used in step 1.
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For more detailed instructions on switching to a different data source, see Data Tab on
page 62.
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4. |Insert a chart or report using this new data source, following the instructions given in
Inserting a New Report on page 363.

Your document is now populated with reports that have data from different data sources.
You can add as many data sources as you need.

Inserting a New Report

How to:

Insert a Report With the Insert Tab
Insert a Report With Drag and Drop
Insert a Report With Double-Click
Insert a Report With Right-Click

With InfoAssist opened in Document view, you can insert multiple charts and reports onto
the canvas. The procedures in the following sections detail how to insert reports into
documents.

In Document view, you can insert a report in the following ways.
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Procedure:

Procedure:

364

4 Use the Insert tab.

<4 Double-click a data source field.

4 Right-click a data source field.

< Drag and drop a data source field onto the canvas.

Note: When you use the Insert tab, double-click a data source field, or right-click a data
source field, a report placeholder is inserted in the upper-left corner of the canvas.

Dragging and dropping a data source field onto the canvas inserts the place holder at the
location you dropped it.

The following procedures describe how to insert new reports. For more information on how
to edit existing reports, see How to Style and Customize a Report on page 382.

How to Insert a Report With the Insert Tab

The Insert tab is only available to insert reports in Document view. For more information on
the Insert tab, see Insert Tab on page 47.

1. With InfoAssist open in Document view, click the Insert tab.
2. In the Reports group, click Report.
A report placeholder appears in the upper-left corner of the canvas.

You can now add fields to the report using the canvas and the Resources panel. For
more information on how to use the Resources panel to add additional fields to the
report, see Understanding the Resources Panel on page 99.

How to Insert a Report With Drag and Drop

You can insert a report by dragging data source fields from the Resources panel onto the
canvas in Document view. To insert a report, make sure that Report is selected on the Format
tab, in the Destination group. This option is also on the Home tab, in the Format group.

1. With InfoAssist open in Document view, click the Format tab.
2. In the Destination group, click Report.

Note: You can also click Report from the Home tab, in the Format group.

3. Select a data source field from the Data pane in the Resources panel and drag it onto
the canvas. Make sure that you drop the data source field onto an open area of the
canvas and not on top of another chart or report.
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A report with the selected data source appears in the Results panel, as shown in the
following image.
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4. You can now add fields to the report using the canvas and the Resources panel. For
more information on how to use the Resources panel to add additional fields to the
report, see Understanding the Resources Panel on page 99.

Procedure: How to Insert a Report With Double-Click

You can double-click a data source field in the Resources panel in Document view. To insert
a report, make sure that no report is actively selected on the canvas and Report is selected
on the Format tab, in the Destination group. This option is also on the Home tab, in the
Format group.

Note: You cannot insert a new report by a double-click if a report is actively selected. If a
report is selected, click the canvas to deselect the report and make the canvas the active
object.

1. With InfoAssist open in Document view, click the Format tab.
2. In the Destination group, click Report.

Note: You can also click Report on the Home tab, in the Format group.

3. Double-click a data source field in the Data pane of the Resources Panel.
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Procedure:

366

A report with the selected data source appears in the Results panel, as shown in the
following image.
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You can now add fields to the report using the canvas and the Resources panel. For
more information on how to use the Resources panel to add additional fields to the
report, see Understanding the Resources Panel on page 99.

How to Insert a Report With Right-Click

You can insert reports by right-clicking a data source field in the Resources panel in Document
view. To insert a report, make sure that no report is actively selected on the canvas and
Report is selected on the Format tab, in the Destination group. This option is also on the
Home tab, in the Format group.

Note: You cannot insert a new report by a right-click if a report is actively selected. If a report
is selected, click the canvas to deselect the report and make the canvas the active object.

1.
2.

With InfoAssist open in Document view, click the Format tab.
In the Destination group, click Report.

Note: You can also click Chart on the Home tab, in the Format group.

Right-click a data source field in the Data panel.

A menu opens.

Select from the following menu options:
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4 Sum

4 Sort

-1 Across

< Include as Coordinated
4 Filter

4 Slicers

A report with the selected data source appears in the Results panel.

Inserting a New Chart

How to:

Insert a Chart With the Insert Tab
Insert a Chart With Drag and Drop
Insert a Chart With Double-Click
Insert a Chart With Right-Click

With InfoAssist opened in Document view, you can bring multiple charts and reports onto
the canvas. The procedures in the following sections describe how to insert charts into
documents.

In Document view, you can insert a chart in the following ways:

4 Use the Insert tab.

4 Double-click a data source field.

<4 Right-click a data source field.

4 Drag and drop a data source field from the Resources panel onto the canvas.

Note: When you use the Insert tab, double-click a data source field, or right-click a data
source field, a chart placeholder is inserted in the upper-left visible portion of the canvas.

Dragging and dropping a data source field onto the canvas inserts the place holder at the
location you dropped it.

The following procedures describe how to insert new charts. For more information on how
to edit existing charts, see How to Style and Customize a Chart on page 384.
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Procedure: How to Insert a Chart With the Insert Tab

The Insert tab is only available to insert charts in Document view. For more information on
the Insert tab, see Insert Tab on page 47.

1. With InfoAssist open in Document view, click the Insert tab.
2. |n the Reports group, click Chart.
A chart placeholder appears in the upper-left corner of the canvas.

You can now add fields to the chart using the canvas and the Resources panel. For more
information on how to use the Resources panel to add additional fields to the report,
see Understanding the Resources Panel on page 99.

Procedure: How to Insert a Chart With Drag and Drop

You can insert a chart by dragging data source fields from the Resources panel and dropping
them onto the canvas in Document view. To insert a chart, make sure that Chart is selected
on the Format tab, in the Destination group. This option is also on the Home tab, in the
Format group.

1. With InfoAssist open in Document view, click the Format tab.
2. In the Destination group, click Chart.

Note: You can also click Chart on the Home tab, in the Format group.

3. Select a data source field from the Data pane in the Resources panel and drag it onto
the canvas. Make sure that you drop the data source field onto an open area of the
canvas and not on top of another chart or report.
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A chart placeholder with the selected data source appears in the Results panel, as
shown in the following image.
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4. You can now add fields to the chart using the canvas and the Resources Panel.

For more information on how to use the Resources panel to add additional fields to the
report, see Understanding the Resources Panel on page 99.

Procedure: How to Insert a Chart With Double-Click

You can double-click a data source field in the Resources panel in Document view. To insert
a chart, make sure that no report is actively selected on the canvas and Chart is selected
on the Format tab, in the Destination. This option is also on the Home tab, in the Format
group.

Note: You cannot insert a new chart by a double-click if a report is actively selected. If a
report is selected, click the canvas to deselect the report and make the canvas the active
object.

1. With InfoAssist open in Document view, click the Format tab.

2. In the Destination group, click Chart.
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Note: You can also click Chart on the Home tab, in the Format group.

3. Double-click a data source field in the Data pane of the Resources Panel.

A chart placeholder with the selected data source appears in the Results panel, as
shown in the following image.
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4. You can now add fields to the chart using the canvas and the Resources panel. For more
information on how to use the Resources panel to add additional fields to the report,
see Understanding the Resources Panel on page 99.

Procedure: How to Insert a Chart With Right-Click

370

You can insert charts by right-clicking a data source field in the Resources panel in Document
view. To insert a chart, make sure no report is actively selected on the canvas and Chart is
selected on the Format tab, in the Destination group. This option is also on the Home tab,
in the Format group.

Note: You cannot insert a new chart by a right-click if a report is actively selected. If a report
is selected, click the canvas to deselect the report and make the canvas the active object.

1. With InfoAssist open in Document view, click the Format tab.
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2. In the Destination group, click Chart.

Note: You can also click Chart on the Home tab, in the Format group.

3. Right-click a data source field in the Data panel.

A menu appears.

4. Select from the following menu options:
-4 Include as Category Axis. For dimension (non-numeric or date) fields.
41 Include as Legend Series. For dimension (non-numeric or date) fields.
4 Filter. For all types of fields.
-1 Slicers. For all fields.

4 Coordinated. The Coordinated field container contains a common sort field for
creating multiple reports and charts that are burst into separate page layouts. Each
value for a coordinated sort field appears on a separate page.

A chart placeholder, with the selected data source, appears in the Results panel.
The chart placeholder turns into a live preview of the chart once the X-axis and Y-axis
data fields are selected.

Inserting an Existing Report

How to:

Insert an Existing Report With the Insert Tab

With InfoAssist opened in Document view, you can insert existing charts and reports onto
the canvas from the Insert tab. The following procedure describes how you can insert reports
into new documents and documents that are already populated with reports, text, and
images.

Procedure: How to Insert an Existing Report With the Insert Tab

You can create a document in the Custom Reports section of the domain and use Standard
Reports items as Existing Report components. You cannot use other Custom Report items
as components.

1. With InfoAssist open in Document view, click the Insert tab.
2. In the Reports group, click Existing Report.
An Open dialog box appears.
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3. Browse to the report that you want to insert and click OK.
The report appears in the upper-left corner of the canvas.
Hovering the mouse over an existing report displays the report title as a tooltip.

Note: You cannot edit an existing report that is inserted into a document.

Creating a Document From a Single Report

You can take a single report created in Live Preview or Query Design view and convert it into
a document, displaying it in Document view.

When you convert a single report into a document, the original report is preserved and a
copy of that report is opened as a document in Document view. You can then add additional
reports, charts, images, and text.

Inserting Text and Images

How to:
Insert Text

Insert an Image

With InfoAssist opened in Document view, you can bring text and images onto the canvas.
The following procedures describe how you can insert text and images into new documents
and documents that are already populated with reports, text, and images.

Note: You can only do this in Document view.

The following procedures detail how to insert text and images. For more information on how
to edit existing text and images, see Editing Components in a Document on page 374.

Procedure: How to Insert Text
1. With InfoAssist open in Document view, click the Insert tab.

2. In the Objects group, click Text Box.
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A text component appears in the upper-left corner of the canvas with default text, as
shown in the following image.
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3. Double-<click, or right-click, the text component to edit the text.

For more information on editing and styling the text, see How to Edit Text on page 386.

Procedure: How to Insert an Image
1. With InfoAssist open in Document view, click the Insert tab.
2. In the Objects group, click Image.

An Open dialog box appears.

3. Browse to the desired image and click OK.

The selected image appears in the upper-left corner of the canvas.
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Editing Components in a Document

How to:

Resize a Component

Move a Component

Align Components

Style and Customize a Report
Style and Customize a Chart
Edit Text

Delete a Component

The reports, controls, and text in a document can be edited, moved, resized, and deleted.
Each of these components has a context menu which can be accessed by right-clicking the
component.

Images can be moved, resized, and deleted, but they have no context menu and cannot be
edited. Right-clicking a image brings up the option to delete it.

Procedure: How to Resize a Component
You can resize a component in the following ways:
4 Using the component sizing handles.
4 Changing the height and width on the Layout tab, in the Size & Arrange group.

4 Accessing the options on the Size tab in the Size and Position dialog box.
The resize feature is available for all components that can be added to a document.

1. Open or create a document with at least one report, text component, control, or image.
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2. Resize the component in one of the following ways:

4 Sizing Handles: Select the component and drag the sizing handles that appear
around it, as shown in the following image. As you manually increase the height and
width of the component, the new values appear in the corresponding text boxes in
the Size & Arrange group of the Layout tab.
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1 Ribbon: You can use the ribbon in one of the following ways:

4 Select the component in the document. On the Layout tab, in the Size & Arrange
group, enter values in the Height and Width fields.

4 On the Layout tab, in the Size & Arrange group, click the dialog box launcher
on the lower-left side of the group, to open the Size and Position dialog box.
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4 Right-Click Menu: Right-click the component and select Size and Position. The Size

and Position dialog box opens.

42r Size and Position

From the Size and Position dialog box, open the Size tab, as shown in the following
image.

Size i
Position Size
Height 3.67 Width | 4.86
Scale
Height 100 - oy, Width 100 -5 oy
AutoFit
Auto Overflow
[ Lok Aspect Ratio
v K (S Cancel 2. Apply

Use the Height and Width options to change the position of the selected component.
You can adjust the pixel size of the object with the Size options or the scale
percentage of the object with the Scale options.

You can lock the aspect ratio using the Aspect Ratio button, which is available when
working with charts, images, and text boxes while working in Document view. With
the aspect ratio locked, changing the width automatically changes the height to keep
the component to scale, and changing the height automatically changes the width.

Note: The Auto Overflow option is only available while working with reports in Document
view through the Size & Arrange group. With Auto Overflow set, you cannot manually set
the height and width of a report. The area of the report expands automatically to show
all data.

The AutoFit option is only available for charts through the Size & Arrange group. With
AutoFit set, the chart size becomes dynamic. This means that other applications can

override the size of the chart when the chart is embedded.
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When two objects are selected, the Relative Position button sets the bottom-left corner
of the component that is higher on the page to the upper-left corner of the one that is
lower. Once a relationship is created, arrows appear to show that relationship while both
items are still selected.

Procedure: How to Move a Component

You can move a component by clicking it, or by accessing the Position section of the Size
and Position dialog box. This feature is available for all components that can be added to
a document.

You can also align components with each other so that their horizontal or vertical position
matches. For more information, see How to Align Components on page 378.

1. Open or create a document with at least one report, text component, control, or image.
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2. Select the component and move it by using one of the following methods:
4 Use the mouse to drag the component anywhere on the canvas.
or
< Right-click the component and click Size and Position.

4 On the Size and Position dialog box, click the Position tab, as shown in the
following image.

az» Size and Position e
s Position
Position Position on page
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" OK 8 cancel _% Apply

4 Use the Horizontal and Vertical options to change the position of the selected
component.

Procedure: How to Align Components

You can align components with each other so that their horizontal or vertical positions match.
You must have multiple components selected to use the align options.

The alignment is anchored by the component that is in the farthest position of the selected
alignment. For example, if you select two components and click Align Left, the components
align horizontally with the component farthest to the left.

1. Open or create a document with at least two components.

2. Select a component.
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3. Select a second component by holding the Ctrl key and clicking a component.

Note: You can select multiple components simultaneously by holding the Ctrl key and
with the left mouse dragging a selection box around the components. When you release
the mouse, sizing handles appear around each component that you selected.

Sizing handles appear around the components, as shown in the following image.
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4. Align the components using one of the following methods:

4 Right-click one of the selected components and select an alignment option from the

Align drop-down menu, as shown in the following image.
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4 Access the alignment options from the Align drop-down menu. The menu is available

on the Layout tab, in the Size & Arrange group, as shown in the following image.
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Procedure:

382

The selected components align, as shown in the following image.
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5. Click anywhere in the canvas to deselect the components.

How to Style and Customize a Report

When you select a component, you can perform various functions on the component, such
as moving and resizing it, as explained in How to Move a Component on page 377. After
clicking a component, you can use the ribbon to affect all settings of the selected component,
except for fields. You can double-click or right-click a component to select individual fields
to edit through the context menu or Field tab.

In addition to reports, you can style and customize charts and text. For more information on
charts, see How to Style and Customize a Chart on page 384. For more information on text,
see How to Edit Text on page 386.

Note: Images cannot be edited.
1. Open or create a document with at least one report.
2. Select the report.

Sizing handles appear around the border.
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Note: The groups of the Field tab are unavailable

3. Right-click the report, and click Edit Report, as shown in the following image.
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Note: You can also activate the report by double-clicking it. This action provides the
same functionality as right-clicking and then clicking Edit Report.

4. You can now select fields within the report. Select a field by clicking it in the canvas.
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Note: The groups on the Field tab are now available, as shown in the following image.
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Note: You can also select a field within the report by clicking the field in the Query pane
of the Resources panel. Make sure that the report that contains the field you would like
to edit is selected on the canvas.

You can now edit the selected report using commands available through the context
menu or the ribbon.

For more information on styling and customizing reports, see Creating and Customizing
Reports on page 135.

Procedure: How to Style and Customize a Chart

384

When you select a component, you can perform various functions on the component, such
as moving and resizing it, as explained in How to Move a Component on page 377. After
clicking a component, you can use the ribbon to affect all settings of the selected component,
except for fields. You can double-click or right-click a component to select individual fields
to edit through the context menu or Field tab.

In addition to charts, you can style and customize reports and text. For more information on
reports, see How to Style and Customize a Report on page 382. For more information on text,
see How to Edit Text on page 386.

Note: Images cannot be edited.
1. Open or create a document with at least one chart.
2. Select the chart.
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Sizing handles appear around the border, as shown in the following image.

Note: The groups of the Field tab are unavailable.

El & Run

Layout View Fi=id

(1o 1]

Weekend, (Shipped)
8 Holiday, {Shipped)
a Menth (Shipped)

Quantity,Sokd M
Revenue d
8 MsrP

Discount
Cost

Days Delayed
B, customers o Video Production 23
Age
Latitude
Longitude

S

Quarnty S0t

W W ruen W s m T
LE= s rascsan

3. Right-click the chart, and click Edit Chart, as shown in the following image.
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Note: You can also activate the chart by double-clicking it. This action provides the
same functionality as right-clicking, and then clicking Edit Report.

WebFOCUS InfoAssist User's Manual 385



Building a Document

4. You can now select fields within the chart. Select a field by clicking it in the canvas.
Note: The groups on the Field tab are now available, as shown in the following image.
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Note: You can also select a field within the chart by clicking the field in the Query pane
of the Resources panel. Make sure that the chart that contains the field you would like
to edit is selected on the canvas.

You can now edit the selected chart using commands available through the context
menu or the ribbon.

For more information on styling and customizing charts, see Creating and Customizing
Charts on page 181.

Procedure: How to Edit Text

When you select a component, you can perform various functions on the component, such
as moving and resizing it, as explained in How to Move a Component on page 377. After
clicking a component, you can use the ribbon to affect all settings of the selected component,
except for fields. You can double-click or right-click a component to select individual fields
to edit through the context menu or Field tab.

In addition to editing text, you can style and customize reports and charts. For more
information on reports, see How to Style and Customize a Report on page 382. For more
information on charts, see How to Style and Customize a Chart on page 384.

Note: Images cannot be edited.
1. Open or create a document with at least one text component.

2. Select the text.
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Sizing handles appear around the border, as shown in the following image.
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Note: You can also activate the context menus by double-clicking the text. This actions
provides the same functionality as right-clicking, and then clicking Edit Text.

A cursor appears over the text.
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4. Click anywhere in the text box and begin entering text.
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6. Using the menu options, you can style the text and insert quick text.
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The text component menu options are as follows:

-

d

-

[

Font. Opens a list of available fonts for the selected text.
Size. Opens a list of available text sizes for the selected text.
Bold. Formats the selected text in bold.

Italic. Formats the selected text in italics.

Underline. Underlines the selected text.

Text color. Opens the Color dialog box where you can select a color for the selected

text.

Cut. Cuts the selected text.

Copy. Copies the selected text to the clipboard.

Paste. Pastes the selected text from the clipboard.
Date. Opens a list of date quick text in various formats.

Time. Opens a list of time quick text in various formats.

page #. Opens a list of page number quick text in various formats.

Procedure: How to Delete a Component

The following procedure applies to all components in Document view.

1. Open or create a document with at least one component.

2. Right-click the component and click Delete.

The component is deleted from the canvas.

Note: You can also delete a component by clicking it and pressing the Delete key.
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Creating Active Technologies Reports, Charts,

i and Dashboards With InfoAssist

This topic describes how to create a
report, chart, or dashboard that is
enabled for Active Technologies using
InfoAssist.

These reports, charts, and dashboards
use the full capabilities of Active
Technologies. They are also referred to
as active reports, charts, and
dashboards.
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Creating an Active Technologies Report

In this section:

Active Technologies Report Menu Options
Configuring Active Technologies Report Options
How to:

Create an Active Technologies Report

An active report is a self-contained report that is designed for offline analysis, meaning it
contains all the data and JavaScript within the output file. Using an active report, you can:

< Interact with the data, using analysis options similar to those found in an Excel workbook,
without any connection to a server. Analysis options include filtering, sorting, charting,
and much more.

4 Work offline without any additional plug-ins or programs. An active report is a self-contained
report, meaning it contains all of the data and JavaScript within the HTML output file.
Packaging the data and the interactive functions in the HTML file also makes the output
highly compressible for email and transparent to security systems.

1 Save the report on a local machine with active report functionality. Since no connection
to a server is required to view the data or use the analysis options, a user can save and
use the report anywhere.

An active report using Adobe® Flex® includes most of the capabilities available in the HTML
version of active reports in a user-friendly report format. An active report delivered as a self-
contained Adobe Flash file (.SWF files that are Adobe® Flash® Player compatible) allows for
faster analysis of large data sets and interaction with the active report.

Procedure: How to Create an Active Technologies Report

392

1. With InfoAssist open in Report view, on the Format tab, in the Output Types group, click
active report.

2. Create a report.

Run the report.
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The following image shows an active report with the available menu options for the
Product Category column.
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Active Technologies Report Menu Options

Menu options for an active report are described in the following table.

Option Definition
Sort Ascending Sorts the column in ascending order.
Sort Descending Sorts the column in descending order
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Option

Definition

Filter

Filters the data. Options are:

d

;|

d

Equals

Not equal

Greater than

Greater than or equal to
Less than

Less than or equal to
Between

Contains

Contains (match case)
Omits

Omits (match case)

Calculate

Calculation types that you can apply to the column:

d

;|

d

;|

Clear
Clear all
Count

Count distinct, which counts the number of distinct values
within a field.

For numeric fields you can also apply:

;|

d

;|

Sum
Avg
Min
Max
% of Total
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Option Definition

Chart Creates a chart from the report. Options are Pie, Line, Bar, and
Scatter.

Rollup Lists the fields available to create a Rollup table.

Pivot (Cross Tab)

Lists the fields available to create a Pivot table.

Visualize Adds or removes visualization bars to the selected column. The
Visualize option is available for numeric data columns.
Hide Column Suppresses the display of the selected column in the report.

Show Columns

Lists the names of the columns that are hidden in the report,
allowing you to individually restore a column.

Select the name of a specific column in the hidden columns list
to restore that column to the report.

Freeze Column

Freezes the report at a particular point so that columns to the
left of the freeze point remain in view while the user scrolls
through the other report columns.

Note: If the report can be fully viewed in the browser window,
freeze is not applied. The Freeze column option is not available
for expandable report (Accordion) views.

Unfreeze All

Unfreezes the columns.

Grid Tool

Opens the Grid tool which you can use to change the column
order, select multiple columns to sort ascending or descending,
hide and show columns, add a calculation result to a column,
and add subtotals in the active report.

Chart/Rollup Tool

Opens the Chart/Rollup Tool which you can use to select multiple
group fields to generate the chart or rollup table. The Chart/Rollup
Tool contains a list of columns available in the active report to
add to Group By and Measure fields. Click and drag the columns
into the field that you want.
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Option

Definition

Pivot Tool

Opens the Pivot Tool which you can use to select multiple group
fields to generate the chart or pivot table. The Pivot Tool contains
a list of columns available in the active report to add to Group
By, Across, and Measure fields. Click and drag the columns into
the field that you want.

Show Records

Opens the Show Records menu option to list the number of
records available for display per page in the report. Select a
number (for example, 10) to display, per page. Default displays
the number of records (lines) per page that is specified in the
WebFOCUS report procedure.

Comments

Options to display comments under cells or hide indicators for
comments in the active report output.

Send as E-mail

Sends report as email.

Note: To use this feature you must have ActiveX enabled in your
browser security settings.

This feature is only supported in Internet Explorer.

Save Changes

Saves changes.

Note: To use this feature you must have ActiveX enabled in your
browser security settings.

This feature is only supported in Internet Explorer.

Export Exports all records or filtered only records to HTML, CSV, XML.
Note: To use this feature you must have ActiveX enabled in your
browser security settings.

Print Prints all records or filtered only records.

Window Displays reports in a cascade or separate tabs.

Restore Original

Restores the active report to its default state specified in the
report procedure.
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Configuring Active Technologies Report Options

In this section:
General Tab
Menu Options Tab
Colors Tab

Advanced Tab

You can configure active report options, including menu options, based on user role through
the active report options dialog box.

You access the dialog box on the Format tab, in the Features group, by clicking the active
report options button. The button is available when active report, active Flash, or active PDF
is selected as the output type.

The active report options dialog box contains the following tabs:
4 General
4 Menu Options

1 Colors

L

Advanced
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General Tab

Use the General tab to set common properties specific to active reports. The General tab
is shown in the following image.

[l Active Report Options -

General General
Menu Option:

Display
Colars Window | Cascade -
Advanced

Freeze Columns | None -
Page Options

Records Per Page | g7

1

Page Information
[¥] pisplay Page Information

Alignment

Location | Top Row

1

Chart Options

1

Chart Engine | Legacy

Legend Collapsible

Bottom Left -

" OK 5 cancel 2 Apply

The General tab contains the following options:

Display. This area contains options to set the window to cascade or tabs, and options to
freeze columns.

d Window. Select the window setting. The options are Cascade and Tabs.

4 Freeze Columns. Select the columns you would like to freeze. You can also select None.
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Page Options. This area contains options to set the number of records per page, enable
the display of page information, edit the alignment, and set the location of the page
information.

4 Records Per Page. Select the number of records that you would like to display per page.
The options are:

;|

d

;|

d

;|

d

All
10
20
30
40
50

-1 Display Page Information. Select this option to display page information. Clear this
option to disable the display of page information.

4 Alignment. Click the appropriate button to set the alignment of the page information.
Options are Left, Center, and Right.

-1 Location. Select the location for the page information. The options are Top Row and
Bottom Row.

Chart Options. This area contains options that pertain to charts.

41 Chart Engine. Select the chart engine to determine the set of charts that you can create.
The options are:

d

Standard. Uses the Active Technologies default chart engine. This option is available
for output format types AHTML, FLEX, and APDF.

Dynamic. This setting is the default for the output format types AHTML and FLEX.
For AHTML, this uses the current Flash charts by default on browsers with Flash Player
that may not support the functionality in the new JavaScript charts, such as older
releases of Internet Explorer. These charts will automatically switch to the new
JavaScript charts on browsers that do not support Flash, such as Safari® on the iPad.

HTMLS5. Uses the new JavaScript charts for the output format type AHTML. These
charts will work in both connected and disconnected mode. The current AHTML default
four JavaScript charts will not be available at run time.

Flash. Uses the default four Adobe Flex charts when output format is FLEX or APDF.
These are the existing charts that work in both connected and disconnected mode.
No additional chart types will be available at run time.
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4 Legend (check box). Select this option to collapse the legend if necessary. Clear this
option if you do not want the legend to collapse. This is for active Flash and active PDF
only.

4 Legend (menu). Select the location for the legend. This is for active Flash and active
PDF only. The options are:

4 Bottom Left
4 Bottom Center

4 Bottom Right
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Menu Options Tab

Use the Menu Options tab to select a user type and select which options to display in the
menu. The Menu Options tab is shown in the following image.

[l Active Report Options %
Eivid Menu Options
Menu Options
User Type: | Power -
Colars
FE e [¥] Show Records [¥] Filter
[V] Freeze [¥/] Calculations
[¥] Hide /Unhide [¥] Chart
[V] Export [¥] visualize
[¥] Sorting [¥] Roliup
[#] Pivot [¥] Comments
[¥] Window Type [#] Restore Original
[7] Send as Email [¥] 5ave Changes
[¥] Print [¥] Accordion
[¥] Advanced Tools [#] Grid Tool

o OK 5 Cancel 2 Apply

The Menu Options tab contains the following options:
4 User Type. The options are Power, Analyst, Basic, and Custom.
4 Power. This is the default user type and enables all functionality.

4 Analyst. This user type has the following functionality: Show Records, Freeze,
Hide/Unhide, Export, Sorting, Pivot, Filter, Calculations, Chart, Visualize, Restore
Original, Save Changes, and Accordion.
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4 Basic. This user type has the following functionality: Show Records, Freeze,
Hide/Unhide, Sorting, Filter, Calculations, Visualize, and Restore Original.

4 Custom. If you select a combination of options that does not match one of the existing
user types (Power, Analyst, Basic), the User level name that appears in the User Type
field is Custom. This is not a default user type or a selectable user type. It is used
to show that options for this user do not match any of the existing user types.

4 Show Records. Can show all records or specific numbers of records.
-1 Freeze. Can freeze and unfreeze columns.

4 Hide/Unhide. Can hide and show columns.

4 Export. Can export data as HTML, .CSV, or Excel (XML) formats.

1 Sorting. Can sort data in ascending and descending order.

4 Pivot. Can pivot data.

4 Window Type. Can show window as cascade or tabs.

4 Send as Email. Can send report as email.

-4 Print. Can print all records or filtered-only records.

41 Advanced Tools. Can access the Chart/Rollup, Pivot, and Grid tools.
- Filter. Can open the Filter Selection dialog box.

- Calculations. Can perform the following calculations Sum, Avg, Min, Max, Count, Distinct,
% of Total.

41 Chart. Can convert report to pie, line, bar, or scatter chart.
-1 Visualize. Can add data visualization bars to report.

4 Rollup. Can perform rollup on data.

4 Comments. Can add comments.

41 Restore Original. Can restore original data.

1 Save Changes. Can save changes.

4 Accordion. Can produce accordion report.

-4 Grid Tool. Can open Grid Tool dialog box.
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Colors Tab

Use the Colors tab to select colors for various objects on the report. The Colors tab is shown
in the following image.

[l Active Report Options X
General Colors
Menu Options
Page
Caolors Font g Background |gm
Advanced Row Selection
Hower Selected
Visualization
Positive | gl Megative g
Calculations
Font pm Background g
Menu
Maormal
Font Background g
L} Border
Haower
Font g Backaround

o OK £5) Cancel 2 Apply

The Colors tab contains the following options:

Page. This area contains options to set the colors for the font and background for the page
text.

1 Font. Opens the Color dialog box, where you can select the font color.

1 Background. Opens the Color dialog box, where you can select the background color
for the page text.
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Row Selection. This area contains options to set the colors that appear when you hover
over or select a row on the report.

4 Hover. Opens the Color dialog box, where you can select the color that the row becomes
when you hover the mouse over the row.

41 Selected. Opens the Color dialog box, where you can select the highlight color that the
row becomes when you use the highlight option.

Visualization. This area contains options to set the colors for the data visualization bars.

4 Positive. Opens the Color dialog box, where you can select the color for a positive data
visualization bar.

4 Negative. Opens the Color dialog box, where you can select the color for a negative data
visualization bar.

Calculations. This area contains options to set the colors for values in a calculation.
4 Font. Opens the Color dialog box, where you can select the font color for the calculation.

41 Background. Opens the Color dialog box, where you can select the background color
for the calculation.

Menu. This area contains options to change the color of the menu.
4 Normal

4 Font. Opens the Color dialog box, where you can select the color for the text of the
options on the column menus.

4 Background. Opens the Color dialog box, where you can select the background color
for the column menus.

4 Border. Opens the Color dialog box, where you can select the color for the border of
the column menus.

- Hover

4 Font. Opens the Color dialog box, where you can select the color for the text of the
options on the column menus when you point to them.

4 Background. Opens the Color dialog box, where you can select the background color
that appears behind options on the column menus when you point to them.
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Advanced Tab

Use the Advanced tab to control active cache, password protection, and report expiration
settings. The Advanced tab is shown in the following image.

[fli Active Report Options W
General
Advanced
Menu Options
Active Cache
Colors :
Rows Retrieved 100 wl
Ady d
wares Security
Password
[7] Expiration
i@ Date Days
YYMMDD

" OK (5 cancel 2 Apply

The Advanced tab contains the following options:

active cache. Enables reports to cache the data in a binary file and return the data to the
output window in pre-set increments.

4 Rows Received. Select the number of rows retrieved in the output. The options are:

4 100 (default)

4 500

4 1000

4 2000

4 3000

4 4000

4 5000

Security. This area allows you to set a password to access the report and enable expiration
by date or by days.
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Creating an Active Technologies Chart

In this section:
Active Technologies Options for Charts
How to:

Create an Active Technologies Chart

An active report is a report that is designed for offline analysis. For more information, see
Creating an Active Technologies Report on page 392.

Procedure: How to Create an Active Technologies Chart
1. Create a chart.

2. On the Format tab, in the Output Types group, click active report, active Flash, or active
PDF.

3. Generate the chart.

The following image shows an HTML5 pie chart that shows the sum of the values in the
Quantity Sold field by Region.

6%

25%

29%

Quantity Sold

W MidEast M MorthEast M MorthWest B SouthEast SouthWest
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Active Technologies Options for Charts

Options for an active chart are described in the following table.

Option

Definition

Group By (X)

Changes groups by the horizontal sort field.

Add (Y) Adds vertical sort field.
Export to Exports to Excel, Word, and PowerPoint.
Top Displays the top values. Options are Top 3, Top 5, Top 10, and

Clear Top.

Chart/Rollup Tool

Opens the Chart/Rollup Tool which you can use to select multiple
group fields in the chart or rollup table generated. The Chart/Rollup
Tool contains a list of columns available in the active report and

Group By and Measure sort fields. Click and drag the columns into
the desired sort field.

Pie Views data as a pie chart.
Bar Views data as a bar chart.
Line Views data as a line chart.
Scatter Views data as scatter chart.

Advanced Chart

Opens the Chart/Rollup Tool.

Original Chart Restores the active chart to the chart type specified in the report
procedure.
Sum Applies the following options to the Measure field: Sum, Avg, Min,

Max, Count, and Distinct.
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Creating an Active Technologies Dashboard

In this section:

Active Technologies Dashboard Prompts

Target Reports

Using Multiple Reports as Targets and Sources

How to:

Add an Active Technologies Dashboard Prompt to a Dashboard
Change the Filter Condition

Add Multiple Prompts to a Dashboard

Cascade Prompts

You can create an active dashboard by inserting active dashboard prompts into a document
to act as filters on the reports of the dashboard. You can also cascade (chain) prompts to
populate based on the selections of the previous prompts. The output format of the active
dashboard must be active report, active Flash, or active PDF in order to add active dashboard
prompts.

Active Technologies Dashboard Prompts

408

The active dashboard prompts group contains buttons to click to insert active dashboard
prompts into your dashboard. This group is only visible when the output format of the
dashboard is set to active report, active PDF, or active Flash. You access the active dashboard
prompts on the Format tab, in the Output Types group. The active dashboards prompts group
is shown in the following image.

I.”:l_.' . = u-l ..E.'J & Run
-~ —
Home Insett  Format Dats  Slicers  Layout  View  Fazld

= B a B @ Yy O &p=

Image sk Checkbox Radio Text
rt ) Bukton

Repork Chart

Repatts ks Active Dashboard Prompks

The following are the types of active dashboard prompts that you can use to apply filters to
an active dashboard:

4 Drop Down. Inserts a drop down prompt placeholder in the upper-left corner of the
canvas.
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d

List. Inserts a list prompt placeholder in the upper-left corner of the canvas.
Checkbox. Inserts a check box prompt placeholder in the upper-left corner of the canvas.

Radio Button. Inserts a radio button prompt placeholder in the upper-left corner of the
canvas.

Text. Inserts a text area prompt placeholder in the upper-left corner of the canvas.

Target Reports

When you bind a field to an active dashboard prompt the default target report is the report
from which you dragged the field. You can add or remove target reports from an active
dashboard prompt through the active dashboard properties dialog box. For more information
on using the active dashboard properties dialog box, see Using Multiple Reports as Targets
and Sources on page 411.

A report must meet one of the following requirements to be a target report:

-

d

The report contains a field with the same name as the source field (actual field name or
AS name).

The Master File of the report has a field with the same name as the source field.

If a report is eligible to be a target report because the field has the same user-entered title
and the title is changed, the report is automatically removed as a target.

Procedure: How to Add an Active Technologies Dashboard Prompt to a Dashboard

This procedure describes how to begin to create a dashboard by creating one report and
binding a single prompt to one of the fields of the report.

1.
2.

Open InfoAssist in Document view.

On the Format tab, in the Output Types group, select an active output type (active report,
active Flash, active PDF).

On the Inserts tab, in the Reports group, click Report.

A placeholder appears on the canvas.

Drag and drop fields onto the canvas, or into the Query pane, to create the report and
start building the dashboard.

On the Insert tab, in the active dashboard prompts group, select a dashboard prompt
to insert into the document.

For example, the following image shows a radio button prompt added to the dashboard.
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An active dashboard prompt appears in the upper-left corner of the canvas. If you have
left the report in the upper-left corner of the canvas, then you will have to drag the prompt
off the report, as shown in the following image.

|
Product @ Option 1
Region Catepo Ootion 7
MidEast Stereo Systems S
Televisions o) Opton 3 =
Yideo Plavers " Option 4
MorthEast Stereo Systems i
» ) Option 5
Televisions
]

Yideo Plavers
SouthEast Stereo Systems
Televisions

Yideo Plavers

6. Select the report and bind one of its data source fields to the prompt in one of the
following ways:

4 Query pane: Select the report. From the Query pane, drag the field that you want to
bind to the prompt onto the prompt.

<4 Report on the canvas: Right-click the report and click Edit Report. The report
becomes editable. Highlight the column that contains the data that you want and
drag and drop it on the prompt.

Once you have bound the field to the prompt, the values of the field appear in the prompt.

Note: Once an active dashboard prompt is added to the canvas, the document is locked
in an active output format. You cannot change out of active report, active Flash, or active
PDF format if there are prompts present on the canvas. To switch to a non-active output
format, all prompts must be removed.
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The following image shows an active dashboard in which the Product Category field of
the report has been bound to a radio button prompt.

@ [All] Product
- oy Cyst Region Catepo
| Stereo Systems
v MidEast  Stereo Systems
) Televisions Televisions
| | | .
) Video Players Video Plavers
~ Video Product MorthEast  Stereo Systems
71 Video Producton Televisions
. Yideo Plavers
SouthEast Stereo Systems
Televisions
Yideo Plavers

The following image shows an example of a dashboard at run time. The active report
has a radio button prompt bound to the Product Category field. Since it is a radio button,
and Televisions is selected, only Regions that have sold televisions appear on the report.

| [Al 3 of & records, Page 1 of 1

I Stereo Systems

i Televisions

MidEast  Televisions
MorthEast Televisions

SouthEast Televisions

I Video Players

Using Multiple Reports as Targets and Sources

How to:
Build a Dashboard With Multiple Reports as Targets and Sources
Change the Field

You can add multiple reports and charts to a dashboard. Each report can have multiple
prompts associated with it.
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Procedure: How to Build a Dashboard With Multiple Reports as Targets and Sources

412

The following procedure describes how to set up active dashboard prompts for two reports
on a dashboard. In the example that is used, the first report contains information about the
categories of electronics products sold in various regions. The Region field will be bound to
a group of radio buttons. Each radio button will represent a particular region in which the
electronics are sold. When you select a radio button for a region, for example, NorthEast,
the report will be filtered by your selection.

The second report contains information about the gender and age group of electronics
consumers. The Gender field will be bound to a drop-down list. The list will display the values,
male and female. When you select a gender from the drop-down list, the report will be filtered
by your selection.

1. With InfoAssist open in Document view, and at least two reports on the canvas, add two
active dashboard prompts, as described in How to Add an Active Technologies Dashboard
Prompt to a Dashboard on page 409.
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The following image shows a dashboard with the region report and the gender report
described in the introduction. Next to the region report is a radio box. Next to the gender
report is a drop-down list prompt. The prompts are not yet bound to any report fields.

@ Opton 1 -
© Option 2 : Latexc
) MidEast Stereo Systems
L = Televisions B
() Option 4 Video Plavers
@ Option 5 i Video Production 2
MorthEast  Stereo Systems 10
Televisions 1
Video Players 10
Video Production 1
SouthBast  Stereo Systems 10
Televisions 5
VYideo Players
Option 1 -
Catepo Fe
Stereo Systems Female Thirties
Young Adult
Male Thirties
Young Adult
Televisions Female Teen
Thirties
Young Adult
Male Thirties
Youne Adult
Yideo Players Female Thirties
Young Adult
Male Thirties
Young Adult
Video Production Female Thirties
Male Young Adult

2. Rightclick the active dashboard prompt to which you want to bind a field and click
Properties.
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414

For example, in the following image, the right-click menu for the radio button prompt is
open.

Catepo
Stereo Systems

Televisions f

Video Plavers
Yideo Production 2
| MorthBast  Stereo Systems 10
" " Televisions 1
Video Players 10
Yideo Production 1
SouthBast  Stereo Systems 10
Televisions ]
Video Players

The active dashboard properties dialog box opens, as shown in the following image.

The Prompts list displays the two prompts (radiobuttons_1 and combobox_1) that were
added to the dashboard in step 1. The prompt titled radiobuttons_1 is highlighted
because it was selected in step 2.

44" Active Dashboard Properties

L4 Prom pk Soul

Prompts Source Targets
radiobuttons_1 Report Candidate Reports Targets
combobox_1 | |z|
Condition
| Equal to |Z|
Include All

— T a—
Cancel s Apply

3. From the Report drop-down menu, select the report that contains the field to which you

want to bind an active dashboard prompt.
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In this example, shown in the following image, the radio buttons list (radiobuttons_1)
has been selected as the prompt for the region report (table_1).

4’ Active Dashboard Properties

X4 Prompl Source & Targets = Cascades
Prompts Source Targets
radiobuttons_1 Report Candidate Reports Targets
combobox_1 :
H -
-
| table_2 7
Condition
| Equal to EI
Include Al

~ Cancel <= Apply

The next step describes how to bind the Region field from the region report to the radio
buttons list to filter that report.

4. From the Field drop-down menu, select the field to which you want to bind the active
dashboard prompt.
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In this example, the Region field has been selected for the radio buttons list
(radiobuttons_1), as shown in the following image.

44" Active Dashboard Properties

Prompts Source Targets
radiobuttons_1 Report Candidate Reports Targets
combobox_1 |E|
Field
g o
Quantity,Sold - @
C Product,Category 5
Equal to -
Indude all

The following image shows Region as the selected field for the radio buttons list. The
region report (table_1) is a target report because it is the one from which you selected
the field. In addition, table_2, the gender report, now appears in the Candidate Reports
list.

44" Active Dashboard Properties

Prompts Source Targets
radicbuttons_1 Report Candidate Reports Targets
combobox_1
table_1 EI Mame MName
B wble_2 B wble_1
Field @
Region B
Condition
| Equal to EI
Indude all

5. Click OK.
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The prompt is now bound to the field on the dashboard.

In the following image, the radio buttons list is bound to the Region field. It displays all
regions by which a user can filter the report.

- A
@ [All] -
™) Central 2 Latesa
MidEast Stereo Systems )
0 MidEast Televisions &
™) MorthEast Video Plavers B
©) NorthWest = Yideo Production 2
MorthEast  Stereo Systems 10
D) SouthEast Televisions 1
7 SouthWest Video Players 10
Video Production 1
71 West
. SouthBast  Stereo Systems 10
Televisions b
Video Players
Option 1 -
Catego snide pe
Stereo Systems Female Thirties
Young Adult
Male Thirties
Young Adult
Televisions Female Teen
Thirties
Young Adult
Male Thirties
Young Adult
Video Plavers Female Thirties
Young Adult
Male Thirties
Young Adult
Yideo Production Female Thirties
Male Young Adult
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The following steps describe how to bind the Gender field in the gender report (table_2)
to the drop-down list prompt.

6. Right-click the next active dashboard prompt to which you want to bind a field and click
Properties.
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For example, in the following image, the drop-down list prompt on the gender report is

selected.

i@ [All] -~

i) Central 32 Catepo

) MidEast Ste te

© MidEast e
Televisions fn

™) MorthEast Video Players

i© NorthWest 1 Video Production 7

@ SouthEast MorthEast  Stereo Systems 10
Televisions 1

™ SouthWest Video Players 10

i) West bl Video Producton 1

SouthEast Stereo Systems 10

Televisions B
Video Players B

Catega pe
Stereo Systems Female Thirties
5;- Size and Pasitian. .. Young Adult
A Delete Male Thirties
Young Adult
Televisions Female Teen
Thirties
Young Adult
Male Thirties
Youne Adult
Yideo Plavers Female Thirties
Young Adult
Male Thirties
Young Adult
Video Production Female Thirties
Male Young Adult
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The active dashboard properties dialog box opens again, as shown in the following

image.

=
¥ Cascades

Prompis

radiobuttons_1
combobox_1

Source Targets
Report Candidate Reports
Condition

| Equal to

Include Al

sz Apply

Notice that combobox_1, the prompt selected on the dashboard, is selected in the

Prompts list.

From the Report drop-down menu, select the report that contains the field to which you

want to bind an active dashboard prompt.
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In this example, shown in the following image, the drop down list (combobox_1) has
been selected as the prompt for the gender report (table_2).

44" Active Dashboard Properties

:l Prompk Sou

A
' Cascades

Prompts Source

Targets
radicbuttons_1 :
— Candidate Reports Targets
bobox_1 Re:port
 table_2 =
table_1 -

Fi 3

Condition
| Equal to EI

Indude all

= o
Cancel a Apply

The next step describes how to bind the Gender field from the gender report to the drop
down list to filter that report.

From the Field drop-down menu, select the field to which you want to bind the active
dashboard prompt.
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In this example, the Gender field has been selected for the drop-down list (combobox_1),
as shown in the following image.

44" Active Dashboard Properties

Prompk Source & Targets

Prompts | |Source | |Targets
radiobuttons_1 Report Candidate Reports Targets
combobox_1
| table_2 E|
Field
- °
Product,Category - @
C Age Group i
Equal to -
Indude all

Once the Gender field has been selected, table_2 (gender report) appears in the Target
list and table_1 (region report) appears in the Candidate Reports list.

7]

44 Active Dashboard Properties

H Prompt Saurce

Prompts | |Source | |Targets
radiobuttons_1 -
= Repart Candidate Reports Targets
combabox_1 =
| table_2 [*] [reme Mame
=l table_1 El table_2
Field @
- Gender IEE
Condition
| Equal to |E|
Include All
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Note: To move a report from the Candidate Reports list box to the Targets list box,
select it and click the Add to List arrow. To remove a report from the Targets list box,
select it and click the Remove from List arrow. You can select multiple reports by holding
down the Ctrl key and clicking each one.

9. Click OK.
The prompt is now bound to the field on the dashboard.

In this example, the drop-down list is bound to the Gender field. A user could filter the
gender report by male or female.

The following image shows the final dashboard with two reports and two prompts.

@ [Al]
i MidEast
) MorthEast

i SouthEast

12 of 12 records, Page 1 of 1 = 24 of 24 records, Page 1 of 1
Product Quantity Product
Region ¥ Category ¥ Sold ¥ @Category ¥ Gender ¥ Age Group ¥
MidEast  Stereo Systems 4,607 Stereo Systems Female Teen
Televisions 3,246 Thirties
Yideo Players 5,043 Young Adult
Yideo Production 055 Male Teen
MorthEast Stereo Systems 8,735 Thirties
Televisions 5,578 Young Adult
Yideo Players 9,057
Yideo Production 1,738
SouthEast Stereo Systems 7431
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In this example, the region report has been filtered by the NorthEast region and the
gender report has been filtered by Female.

© [Al]

i) MidEast
i@ MorthEast
i) SouthEast

4 of 12 records, Page 1 of 1

Product
Region ¥ Category ¥

Quantity

12 of 24 records, Page 1 of 1

Product

¥ Gender ¥ Age Group ¥

MorthEast Stereo Systems
Televisions 5,578
Yideo Players 9,057
Video Production 1,738

Teen
Thirties
Young Adult
Teen
Thirties
Young Adult

Televisions Female

Video Players Female Teen
Thirties
Young Adult
Teen
Thirties
Young Adult

Yideo Production Female

Procedure: How to Change the Field
You can change the field to which the active prompt is bound.

1. With InfoAssist open in Document view, bind an active prompt to a field, as described
in Using Multiple Reports as Targets and Sources on page 411.

2. Right-click the active dashboard prompt that you want to configure, and click Properties.

The active dashboard properties dialog box opens.

424 WebFOCUS



7. Creating Active Technologies Reports, Charts, and Dashboards With InfoAssist I

3. From the Field menu, select a different field, as shown in the following image.

4§’ Active Dashboard Properties

Prompts Source Targets
radiobuttons_1 -
= Candidate Reports Targets
bobox_1 Repart
table_1 IZ| Mame
B wble_1
Field D
Redqion -
Region - D
Conditon
| Equal to |Z|
Include Al

— —
Cancel s Apply

A warning message alerts you that changing the source field for the prompt will remove
the existing prompt and any children prompts from the cascades. The warning message
is shown in the following image.

Active Dashboard Properties

"\_ Changing the source field for control ChedBox_1 will remove Chedks:
.*® . and any children controls from the existing cascades.
Click OK to continue.
Click Cancel to keep the aoriginal source field.

4. Click OK to close the warning.
5. Click OK to close the active dashboard properties dialog box.

The active dashboard prompt is updated with the new source field.
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In the following example, the check box prompt is updated with electronics products,
as shown in the following image.

[AlL] Product
ot Cust Region Catepo
ereo Systems
. MidEast Stereo Systems
Televisions Televisions
Video Players Video Plavers

E  HorthEast Stereo Systems

Video Producton L.
Televisions
Yideo Plavers

SouthEast Stereo Systems

Televisions

. o Video Players

Procedure: How to Change the Filter Condition

1. With InfoAssist open in Document view, bind an active dashboard prompt to a field, as
described in How to Add an Active Technologies Dashboard Prompt to a Dashboard on
page 409.

2. Rightclick the active dashboard prompt that you want to work with, and from the right-click
menu, select Properties.

The active dashboard properties dialog box opens.

3. From the Condition drop-down menu, select the filter condition for the active dashboard
prompt. The options are Equal to, Not equal to, Less than, Less than or equal to, Greater
than, and Greater than or equal to.

4. Click OK.

The filter condition is applied to the active dashboard prompt.

Procedure: How to Add Multiple Prompts to a Dashboard

1. With InfoAssist open in Document view, and at least one report on the canvas, add at
least two active dashboard prompts, as described in How to Add an Active Technologies
Dashboard Prompt to a Dashboard on page 409.
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The following image shows a dashboard with a list prompt and a radio button prompt.

Option 1
Option 2
Option 3
Opton 4
Option 5

@ Option 1
“) Opton 2
“1 QOpton 3
71 Opton 4

71 Option 5

o

m

1

Product

Catepo
Stereo Systems

Televisions

Video Plavers

Video Production

Region
Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West
Central
MidEast
MorthEast
Morth'West
%“outhEast
SouthWest
West
Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West
Central
MidEast
MorthEast
Morth'West
We=st

Quantity
Sold

14

7
10
14
10

2
10

N T T ™ TR T T TSR (R - = IR

2. Bind the fields to prompts that you have added, as described in How to Add an Active
Technologies Dashboard Prompt to a Dashboard on page 409.
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In the following image, the list prompt has been bound to the Product Category field and
the radio button prompt has been bound to the Region field. The two prompts work
independently of each other to filter the dashboard in different ways.

[ALL] <] @ -
Stereo Systen () Central S|l Catepo
Televisions | @ MidEast Stereo Systems
Yideo Players

—| @ MorthEast
Wideo Produc - il
—— - 5 e

Televisions

Video Plavers

Video Production

Region
Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West
Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West
Central
MidEast
MorthEast
MorthWest
SouthEast
SouthWest
West
Central
MidEast
MorthEast
MorthWest
West

el e e - L T SR O - - e
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The following image shows the dashboard indicating the quantity of stereo systems sold

for all regions.

[All]
Televisions
Video Players

Video Production

i@ Al
i) Central Quuntity
) MidEast =
) MorthEast  Stereo Systems Central 11,143
) MNorthWest MidEast 4,607
@ SouthEast NorthEast 8,735
- NorthWest 7,287
@ SouthWest arthwes ,
- SouthEast 7,431
) West
SouthWest 1,832
West 6,638

The following image shows the dashboard indicating the electronics products sold in

the NorthEast region.

Stereo Systems

Televisions
Yideo Players
Yideo Production

[Al]

4 of 28 records, Page 1 of 1

Central Product

Category

1 MidEast Region w

MarthEast  Stereo Systems  MorthEast 8,735
™1 MorthWest Televisions MorthEast 5,578
) SouthEast  Video Players  NorthEast 9,057
® SouthWest Yideo Production MorthEast 1,738
0) West

Procedure: How to Cascade Prompts

When you have more than one prompt on the canvas, you can cascade prompts to populate

based on the selections of

the previous prompts. Cascading prompts have a parent-child

relationship, in which the parent filters the available options of the child.

An active prompt can be the parent of more than one other prompt, but cannot be a child

of more than one prompt.

1. With InfoAssist open in

Document view, bind at least two active prompts to fields, as

described in Using Multiple Reports as Targets and Sources on page 411.
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In the following image, a report has been created to show the quantity of electronics

sold by states within a region. Two prompts, a radio button to select the region, and a
check box to select the state, have been added to the report. The objective is to be able
to select a region, and then cascade down to the state level.

@ Central
i) MidEast
) MorthEast
7 MorthWest
) SouthEast
) SouthWest

i West

[ AK
[ AL
[ AR
[ Az
O ca
[ co
B cr
[ pC
[=] DE
E L
[ GA
[ HI
[ 1A
[ I
i
[ IN
[ ks
O Ky
O LA
] Ma
[F] MD

»

m

Catepo

Stereo Systems

Televisions

Video Players

Region
MorthEast

SouthEast

MorthEast

SouthEast

MorthEast

SouthEast

State

Code

mAERE

MY

GA

sC

ME

MY

ZCoES

Quantity

Sold

e L R R R e - L= IR - R L R L B

2. Right-click the active dashboard prompt that you want to configure, and click Properties.

The active dashboard properties dialog box opens.

3. Click Cascades.
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By default, a cascade named Cascadel appears in the Cascades section of the active
dashboard Properties dialog box.

3 You can click the Create a new cascade “* button to create a new cascade.

' You can click the Delete selected cascade ~ button to delete the selected cascade.

The following image shows that the Region field is associated with the radio button
prompt and the State Code field is associated with the check box in the Available Prompts
list.

44" Active Dashboard Properties

i, -
K Prompt Source & Targets

Cascades ES ~ Available Prompts Selected Prompts - v
Cascadel Name Field

@ radiobuttons_1 | B Region
E( checkbox_1 B State,Code

o

— e
Cancel ws Apply

4. Select the cascade to which you want to add prompts.

5. From the Available Prompts list box, select the prompt that you want to add.
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6. Click the Add to List arrow to move the selected prompt to the Selected Prompts list
box, as shown in the following image.

44’ Active Dashboard Properties

Prompt Source & Targets

Cascades = A Available Prompts Selected Prompts - b
Cascadel Hame Field

@ radiobuttons_1 | © Region
M checkbox_1 £ State,Code

Cancel i Apply

Note: You can remove prompts from the Selected Prompts list box by selecting them
and clicking the Remove from List arrow.

7. Add any additional prompts you want to be part of the cascade by repeating steps 5
and 6.

By default, the hierarchy of the prompts is determined by the order in which they are
added to the Selected Prompts list. The cascade of the prompts is from top to bottom.
The prompts that come first in the Selected Prompts list are the parents of the lower
prompts.
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8. You can change the hierarchy of the prompts by selecting a prompt in the Selected
Prompt list box and clicking the Move Up and Move Down arrows, as shown in the
following image.

%" Active Dashboard Properties

:} Prampk So
Cascades H A Available Prompts Selected Prompts s -
Cascadel Name Field

@ radiobuttons_1 | Bl Region
g checkbox_1 B State,Code

“Cancel . Apply

9. Click OK.

The cascade is created.

10. Run the report.
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The following image shows the report with the region radio box and the state check box.
i) MorthEast AL
) SouthEast cT

45 of 45 records, Page 1 of 1

State Quantity
FL g={a ]y w Region v Code ¥ Sold
GA  Stereo Systems MorthEast CT 7
LA Ma 1,073
ME 1,009
e HH 355
ME [{N] 1,307
S NY 3,443
NH RI 116
b VT 715
HM SouthEast AL 1,131
NY FL 1,651
°C M5 704
VT MM 430
SC 1,107
Televisions MorthEast CT 475
Ma 649
ME 575
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The following image shows the dashboard output with the region prompt cascading down
to the state level.

i@ MorthEast cT

3 of 45 records, Page 1 of 1

© SouthEast - L Product State Quantity
[\ Category v FHRegion w Code w Sold ¥
HH  Stereo Systems MorthEast MA
by Televisions MorthEast  MA
NY Yideo Players  MorthEast MA
Rl
VT

Note: If you set up more than one cascade, the cascade that you interact with last is
the one that filters the report.
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Using Slicers

You can use InfoAssist to create slicers,
dynamic filters that you can use with
reports, charts, dashboards, and 4 Creating Slicers
documents.

Topics:

< Filtering With Slicers
- Edit Slicers Dialog Box
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Creating Slicers

How to:
Create a Slicer
Add a Field to an Existing Slicer Group

Add a Hierarchy as a Slicer Group

You can create slicers by dragging fields to the Slicers tab or through the context menu of
a field. When you create a slicer group, it appears on the Slicers tab, as shown in the following
image.

W

Home Inssri Format Slicers  Layout  View  Fisld

L T
e Preview — [an

» Cle

;) IIpdake Preview S T mn

Options f Record Lirnik B Group 1

You can use slicers to dynamically filter reports at design time in InfoAssist. You can
dynamically filter reports at run time when they are included in an InfoMini application. For
more information on InfoMini, see Building InfoMini Applications on page 455.

Procedure: How to Create a Slicer
1. Click the Slicers tab.
2. Create a new slicer by using one of the following methods:
' Click the New Group button to create a new slicer group.

Select a field from the Data pane and drag it onto the Drag Fields Here to Create
Slicers text on the Slicers tab.

Note: You cannot drag and drop parent-child hierarchies onto the Slicers tab.
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The field is added to the new group.
or

4 Right-click a field in the Data pane, point to Slicers, and then click New Group, as
shown in the following image.

'IT'| B = =

Home Inz=ri Format 3 View  Fizld

Premview 500

¥ Lpdat : Run Tirme m:

Ophions o Recard Linit

= @ WF_RETAIL -} Drag and drop fields onto the
= 4 Dimensions canvas or into the query pane
= 4 Geography =

to begin building your report.

# £ Region 5
= ¥ Product

Surn
Sart

= & Time (Sales & acos
& H Year,(§ Filter

Slicers | New Group
H B Year, (Srere=

= 4 Time (Delivery)
& B Year,(Delivery)
1= 4 Time (Estimated Delivery)
& B Year,(Estimated Delivery)
= 4 Education
# E Education Type

F
!

4! Existing Group

The field is added to the new group, as shown in the following image.

M

Home Ipsart  Format Scers Layout  Miew  Fizld
& Mew Group Reqgion
# Clear Slicers

Fun Tirne

i Ilpdate Pre

Options 2 Record Limit El Group 1
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Procedure: How to Add a Field to an Existing Slicer Group

1.
2.

Click the Slicers tab.

Add a field to an existing slicer group using one of the following methods:

1 Select a field from the Data pane and drag it onto an existing slicer group.
or

1 Right-click a field in the Data pane, point to Slicers, and then click Existing Group, as
shown in the following image.

TR s "

Home Insert Format Data -

>

= @ WF_RETAL Drag and drop fields onto the
= 4 Dimensions canvas or into the query pane

= 4 Geography 0 1A
o to begin building your report.

= 4@ Product
8 Product,Category
= 4 Time (Sales)
£l Year {Salec
= G Tme (shif & Sum
B Year, 44 Sort
= i Time (Del E Across
B Year,
[ —— T Fiker .
a vear [0 P, Hew Group
= 4@ Education G
B Education Type
8 ID_SHIPFACT
8 ID_SHIPMENT
8 ID_SALES

m

Select an existing group from the menu, as shown in the following image, and then
click OK.

Add Slicer x
| Group 1 B

The field is added to the existing group.

Procedure: How to Add a Hierarchy as a Slicer Group

440
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Note: You cannot drag and drop parent-child hierarchies onto the Slicers tab.
1. Click the Slicers tab.
2. Add a hierarchy as a slicer group using one of the following methods:
4 Select a hierarchy from the Data pane and drag it onto an existing slicer group.

The hierarchy is added as a new group, not as a slicer in the existing group. The new
group is given the same name as the hierarchy.

or
' Click the New Group button to create a new slicer group.

Select a hierarchy from the Data pane and drag it onto the Drag Fields Here to Create
Slicers text of the Slicers tab.

The hierarchy is added to the new group, as shown in the following image. The name
of the new group changes to the name of the hierarchy automatically.

= @ WF_RETAL -]|}§ Drag and drop fields onto the
= % Dimensions canvas or into the query pane
= @ Geoorophy =[] to begin building your report.
B Regi
= 4@ Product =
B Product,Category
= i Time (Sales)
B Year,(Sales)

Note: Hierarchies cannot be added to existing slicer groups. If a hierarchy is dragged
onto an existing slicer group, a new group is created automatically.

There is no right-click context menu for hierarchies. To add a hierarchy as a slicer group,
you must drag and drop it into a new slicer group.

Filtering With Slicers

In this section:
How Slicers Cascade Together
How to:

Change the Relationship Operator in a Slicer

Once you add slicers to an InfoAssist report, you can use them to filter the report. You can
select values from the slicers menus, change the number of records that appear, create
new slicer groups, clear existing slicer groups, and update the report preview.
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Procedure:

442

Slicers that are not selected have their values filtered by the selected slicers. Only values
that meet the criteria for previously selected slicers will appear in the menu for the next
slicer. Slicers are not filtered in the order they appear in the slicer group, but by the order
they are selected. Cascading of slicers is only valid for hierarchies.

How to Change the Relationship Operator in a Slicer

For alpha fields, the available operators are:

a

a

equal to

not equal to

For numeric and date fields, the available operators are:

a

a

N B O U O U U o

equal to

not equal to

in range

not in range

greater than

less than

greater than or equal to

less than or equal to
With at least one slicer added to the report, click the Slicers tab.
Click the operators button on the slicer for the operation you want to change.

A list of operators (numeric) appears in the menu, as shown in the following image.

Note: Alpha fields just flip between equal and not equal.

= @ WF_RETAIL -
= i Dimensions
= B Geography
= B Region
B State,Code
= 4 Product
£ Product,Category
= 8 Time (Sales)

m

NorthEast  Stereo Systems
Televisions

Video Players

Video Production
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3. Select the operator that you want from the menu. You can rest the mouse on an operator
to display a tooltip describing the operation.

'ﬁ?]lhﬂ*- El

Home Inzert Format Data 5 Layout View Fizld

i

=1 @ WF_RETAIL -
= 44 Dimensions
= & Geography
= © Region
o State,Code
= & Product
£ Product,Category
= 4 Time (Sales)
B Year, (Sales)
= & Time (Shipped)
B Year, (Shipped)

i

NorthEast  Stereo Systems
Televisions
Video Players

Video Production

How Slicers Cascade Together

How to:

Cascade Slicers

Slicers cascade within a hierarchy (cube or dimension builder-based), rather than in the order
of user interaction, eliminating potential performance issues.
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The following image illustrates a dimension builder-based hierarchy.

Dimension Builder

FE L NPy | _
Marne  Format | Expr
= [ J) w_retailfw_retai
wd! Measure Groups
= [ Dimensions
=@ Product
. El-3% Product
' = PRODUCT_CATEGORY A4OY
= PRODUCT_SUBCATEG ASOY
= MODEL AsOY
= PRODUCT_NAME A150Y
= @ Time (Sales)
5 33 Time (Sales)
= TIME_YEAR I6
= TIME_QTR 16
= TIME_MTH 16
= TIME_DAY 16

444
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Procedure: How to Cascade Slicers

Controls with fields from the same hierarchy are cascaded together. In the following example,
a report has been created that shows the quantity of products, by category, sold each year.

Catepo
Stereo Systems 2007

1

2

4

2008 1
2

3

2009 1
2

4

2010 1
2

4

Televisions 2007 1
2

4

2008 1
2009 1
2

3

2010 1
2

Video Plavers 2007 1
2

1. Create a report.

2. Create multiple slicer groups, as described in How to Create a Slicer on page 438.

WebFOCUS InfoAssist User's Manual 445



Filtering With Slicers

In the following example, two groups have created for this report. They are Product and
Time (Sales). Both are from hierarchies, so they will cascade.

E) | (™ Run

Layout View Field
Pr : ry Product,Sub
Run Time

Record Limit Time (Sales)

El Region -
1= 4 Product
= B Product,Category
 Product,Subcat

Year Quantity

In the next example, Televisions is selected as the first control for the Product group.

Format D Slicers | Layout View Field

Preview Product,Category Product,Subcategory

Run Time

o \ Product,Category S

Options [ Record Limit F| Steren Systems
P Live

@ @ Region " Video Players
= 4 Product video Production
= B Product,Category
# B Product,Subcat

= B Year,(Sales)
# E Quarter,{5ales]
= % Time (Shipped)

™ Cancel
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Once you click OK, the new control appears in the drop-down menu, as shown in the
following image.

Format = 5 Layout View

Preview m: Produc . Product,Subcategory

. ]
e = = Televisions = :

Record Limit [

W Live Preview (500 Records)

= @ WF_RETALL i
= 4 Dimensions EI Year Quantity
= % Customer Sold
B il
= 8 F‘.eglan Stereo Systems 2007 25

s

The 1 prior to the decimal point indicates that this is the first cascade you have interacted
with. The 1 after the decimal point indicates that it is the first control in that cascade.

In the next example, Flat Panel TV is selected as the second control for the Product
group, as shown in the following image. This is filtered to only show subcategories for
Televisions.

Layout  View

ear Slices

%W Update Preview

Options L]

Personal TV

=] “ WF_RETALL Universal Remote Controls

1= 4§ Dimensions
= customer
# F Regon
= 4 Product
# B Product,Category
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Flat Panel TV appears in the Product Subcategory drop-down menu, as shown in the
following image.

iy | WO £l & Run

Home Format Data Slicers  Layout  View

*" New Group
’ Preview mn Product,Category 11 Product,Subcategory

o Cexr Bl reicvsons [ [UERIR FietPanei v ﬂ _ﬂ —
S
Ty Update Preview

Options Fa Record Limit Fa Product Time (Sales)
% Live Preview (500 Records)

= @ WF_RETALL
= 4 Dimensions
= % Customer
£ Region

Product Year Quantity
Sold

The number 1.2 indicates that this is the second control for the first cascade.

Now, a second group, Time (Sales) is created. It has two controls, the first is Year
(Sales), the second is Quarter (Sales), as shown in the following image.

Time (Sales)

3. Filter the report using the controls in the slicer groups that you created.

In the following example, the report has been filtered to show the number of flat panel
televisions that were sold in the first quarter of 2007.

B " = & Run

Home Format Data Slicers  Layout View

Preview m: Product,Category®! Product,Subcategory ™2 Quarter,|
"

O/ CEERENG A - Ca—

Record Limit ™0 Product fa Time (Sales)

Product Year Quantity
= & Dimensions Category (Sales) Sold
= i Customer Televisions 2007 1,715

Note: The order of a cascade is dynamic. For example, if you selected Camcorder from
Product Subcategory first, then the Product Category control would have a value of Video
Production.
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Edit Slicers Dialog Box

In this section:
General Tab
Record Limit Tab
Group Tab

You can access the Edit Slicers dialog box by clicking the edit button next to the group labels
on the Slicers tab, as shown in the following image.

Home Inszrt Format Data Slicers  Layout View  Fizld

Preview 500 = Reqgion 11

Year, (5 .
o I MorthEast | 2006
b ate Presvie ST e mn = :
| |_||:||:|.;|t|;: Prewiew

Options L5 Record Limit 2 Group 1 B

- -
- e gl |u]

2 Foata
= & WF_RETAIL - ———
= 4§ Dimensions Regi -
ﬂ c oh egion Category
= =
=oarapny T MorthEast  Stereo Systems
= Region s
B State, Code :ls Eans
= 4 Product - . -
11 Product,Ca Video Production
= & Time (Sales)

The Edit Slicers dialog box contains the following tabs:
J General
' Record Limit

4 Group # (tab for each slicer group)
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General Tab

Use the General tab to show or hide the Options group and to automatically update the
Interactive preview. You can also reorder or delete existing groups on this tab. The General
tab is shown in the following image.

. Edit Slicers

General

Record Limit Show Options group
[] Auto Update Preview

Group 1

Group Order
Edit Group Order - w

Group Hide & Exdude

1A Group 1 [

The General tab contains the following options:

4 Show Options group. Select this option to display the Options group on the Slicers tab.
The Options group is shown in the following image.

e Group

Clear Slicers

L
-
-
T

Update Presvies

Dptions i
The Options group contains the following options:
J New Group. Adds a new slicers group to the Slicers tab.

4 Clear Slicers. Clears all selected values from existing slicers.
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4 Update Preview. Updates the design time canvas with any changes that have been
made.

1 Auto Update Preview. Enables auto updating of the canvas.

Edit Group Order. Select a group, then use the up and down arrows to change its
position.

1 Hide & Exclude. Select a group, then select this option to delete the group.

Record Limit Tab

Use the Record Limit tab to show or hide the Record Limit group, the Preview control, and
the Run Time control, as shown in the following image. You can also use this tab to select
the number of preview and run-time records that will be shown.

.+ Edit Slicers

Esino Record Limit

Show Record Limit group

Group 1 Preview

Records

Show Preview control

Run Time

Records

Show Fun Time control

The Record Limit tab contains the following options:
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4 Show Record Limit group. Select this option to display the Record Limit group on the
Slicers tab. The Record Limit group is shown in the following image.

Preview 500 ﬂ

Fun Time mn

Record Limik £l

The Record Limit group contains the following menus:

1 Preview. Use this menu to control how many records are displayed in the design-time
preview.

d Run Time. Use this menu to control how many records are displayed at run time.

d Show Preview control. Select this option to display the Preview menu in the Show
Record Limit group on the Slicers tab. You can set the default number of records to be
shown at design time with the Records menu in the Preview section.

4 Show Run Time control. Select this option to display the Run Time menu in the Show
Record Limit group on the Slicers tab. You can set the default number of records to be
shown at run time with the Records menu in the Run Time section.
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Group Tab

Use the Group tab, shown in the following image, to change the name of the group, change
the order of the slicers in the group, and set a required option for slicers. Selecting a slicer
and clicking the Remove from List button deletes the slicer.

. Edit Slicers O x
E2eT Group Properties
Record Limit Group MName |Grnup 1 |

Slicers

W

Edit Slicer Order & w

Slicer Required
B Product,Category

The Group tab contains the following options:
J Group Name. Use this field to enter or edit the name of a Slicer group.
1 Edit Slicer Order. Select a slicer, then use the up and down arrows to change its position.

1 Required. Select this option to set a slicer to be required. A slicer that is set to required
must have a value selected before the report can run. A required slicer is indicated by
an asterisk (*), as shown in the following image.

Previcw 500 = Product, Cateq:

= -

Run Time mn

Record Limit l Group 1
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Building InfoMini Applications

InfoMini applications are built from an
InfoAssist report and contain a subset
of InfoAssist functionality available at run 4 Understanding InfoMini Applications
time.

Topics:

<4 Creating an InfoMini Application
You can build an InfoMini application and

provide the run-time user with the option
to interact with and edit the report.

WebFOCUS InfoAssist User's Manual 455



Understanding InfoMini Applications

Understanding InfoMini Applications

In this section:

Using the InfoMini Button

When you create a report in InfoAssist, you have the option to activate InfoMini. You can
run a report with InfoMini activated, which creates an InfoMini application. An InfoMini
application contains a subset of the functionality available in a full InfoAssist report. You
can limit or expand the functionality that is available to the user at run time when you build
the report in InfoAssist.

An InfoMini application opens in its own browser window when it is run from within InfoAssist
to test. An InfoMini application does not open in its own browser window in the Business
Intelligence (BI) Portal or in any other application that you build yourself.

An InfoMini application has many of the components an InfoAssist report has, with the
following exceptions:

4 The main menu is not accessible.
4 The New, Open, and View code buttons on the Quick Access Toolbar are not available.

- Certain tabs and groups are unavailable or limited. For more information, see Interactive
Mode on page 458 and Edit Mode on page 459.

4 The status bar is not accessible.
4 The navigation taskbar is not accessible.
4 InfoMini does not support referencing existing procedures and Reporting Objects.

There are two items on the Quick Access Toolbar that are exclusive to an InfoMini application.
They are:

- Interactive button

< Edit button

For more information on the available components and their functionality, see InfoAssist
Application Window on page 30.
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Using the InfoMini Button

In this section:
Interactive Mode

Edit Mode

The InfoMini button can be found on the Format tab, in the Destination group. You can click
the InfoMini button to activate the InfoMini option. With the InfoMini button active, you can
run a report to open the InfoMini application.

To deactivate the InfoMini option, click the InfoMini button again. There must be at least
one option selected from the InfoMini button menu for InfoMini to be activated.

You can set the options available to the user at run time from the menu on the InfoMini
button. If you select an option from the menu when the InfoMini button is inactive, the
InfoMini option is activated. The options are:

4 Home tab

4 Format tab

- Slicers tab

4 Insert tab

1 Data tab

- Slicer tab (Edit)
4 Layout tab

- Series tab

1 Resources/Field tab
4 Run Immediately.
4 Save

When you select an option from the menu, a check mark appears next to the option. The
check mark indicates the option is available for the user at run time within the InfoMini
application. If you select a checked option to clear it, the check mark disappears, and the
option is no longer available through the InfoMini application. If you clear all of the options
from the menu, InfoMini is deactivated.

The menu of the InfoMini button is divided into three sections:

4 A section for options available in Interactive mode.
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d A section for options available in Edit mode.

4 A section with the option to make the Run Immediately button and the Save button
available.

The Run Immediately option is set by default. It enables reports to run immediately when
InfoMini first launches. You might want to clear this option so that the user can choose a
format and pick slicers before running a report.

When the Save option is selected you can pick up your analysis in InfoMini at the same
point. For more information on the options you can make available in Interactive mode, see
Interactive Mode on page 458. For more information on the options you can make available
in the Edit mode, see Edit Mode on page 459.

Interactive Mode

Interactive mode is the default mode when an InfoMini application runs. You can access
Interactive mode from the Quick Access Toolbar of an InfoMini application. The Resources
panel is not available in Interactive mode. If no options are selected from the InfoMini button
when the application runs, the tool still opens in Interactive mode with no ribbon options
available.

The following options can be activated in Interactive mode:
<4 Home tab
<4 Format tab
- Slicers tab

From the Home tab, you can access the Format, Filter, and Report groups, with the following
exceptions:

<4 The Report and Chart buttons, which are on the Home tab, in the Format group in
InfoAssist, are not available in an InfoMini application.

4 The Design group, which is on the Home tab in InfoAssist, is not available in an InfoMini
application.

For more information on the functionality of the available groups on the Home tab, see Home
Tab on page 39.

From the Format tab, you can access the Output Types group, with the following exceptions:

<4 The Destination, Navigation, and Features groups, which are on the Format tab in
InfoAssist, are not available in an InfoMini application.

4 The Other button, which is on the Format tab, in the Chart Types group in InfoAssist, is
not available in an InfoMini application.
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4 The InfoMini button, which is on the Format tab, in the Destination group in InfoAssist,
is not available in an InfoMini application.

For more information on the functionality of the available groups on the Format tab, see
Format Tab on page 50.

From the Slicers tab, you can access the Options, Record Limit, and Slicer Group groups,
with the following exceptions:

<4 The New Group option, which is on the Slicers tab, in the Options group in InfoAssist, is
not available in the Interactive mode of an InfoMini application.

Note: The New Group option is available on the Slicers tab, in the Options group in an
InfoMini application in Edit mode.

4 The Update Preview option, which is on Slicers tab, in the Options group in InfoAssist,
is not available in an InfoMini application.

<4 The Preview list, which is on the Slicers tab, in the Record Limit group in InfoAssist, is
not available in an InfoMini application. It only appears in Edit mode in a document.

For more information on the functionality of the available groups on the Slicers tab, see
Using Slicers on page 437.
Edit Mode

You can access the Edit mode from the Quick Access Toolbar of an InfoMini application.
The Resources panel is available in Edit mode.

In addition to the tabs that are available in Interactive mode, the following options can be
activated in Edit mode:

4 Insert tab (documents only)
<4 Data tab

d Slicer tab (Edit)

4 Layout tab

1 Series tab

4 Resources/Field tab

From the Insert tab, you can access the Reports, Objects, and active dashboard Prompts
(for active HTML, active PDF, and active reports only) groups. The Existing Reports button,
which is available in the Reports group, is not available in an InfoMini application. For more
information on the functionality of the available groups on the Insert tab, see Insert Tab on
page 47.
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From the Data tab you can access the Calculation, Filter, and Data Source groups, with the
following exceptions:

4 The Join group, which is on the Data tab in InfoAssist, is not available in an InfoMini
application.

<4 The Add option, which is on the Data tab in the Data Source group in InfoAssist, is not
available in an InfoMini application.

For more information on the functionality of the available groups on the Data tab, see Data
Tab on page 62.

From the Slicers tab, you can access the Options, Record Limit, and Slicer Group groups,
with the following exceptions:

4 The Update Preview option, which is on the Slicers tab, in the Options group in InfoAssist,
is not available in an InfoMini application.

<4 The Preview list, which is on the Slicers tab, in the Record Limit group in InfoAssist, is
only available in Document view.

For more information on the functionality of the available groups on the Slicers tab, see
Using Slicers on page 437.

From the Layout tab, you can access the Page Setup and Report groups. For more information
on the functionality of the available groups on the Layout tab, see Layout Tab on page 76.

From the Series tab, you can access the Select, Properties, Line, and Pie groups. For more
information on the functionality of the available groups on the Series tab, see Series Tab on
page 95.

From the Resources/Field tab, you can access the Filter, Sort, Break, Style, Format, Specific,
Visibility, and Links groups. For more information on the functionality of the available groups
on the Field tab, see Field Tab on page 85.
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Creating an InfoMini Application

How to:

Activate InfoMini

Enable and Disable InfoMini Application Options
Test an InfoMini Application

Interact With an InfoMini Application

To create an InfoMini application in InfoAssist, build a report as you normally would, then
activate InfoMini and add the functionality you want the user to have available to them at
run time. For more information on what functionality is available to InfoMini applications,
see Understanding InfoMini Applications on page 456.

Procedure: How to Activate InfoMini
1. With an InfoAssist report open, click the Format tab.

2. To activate InfoMini, do one of the following:

< In the Destination group, click InfoMini, as shown in the following image.

I_E Chart

Destination

Note: At least one option from the InfoMini menu must be selected in order to
activate InfoMini. By default, the Format tab, Slicers tab, and Save option are selected
on the menu when you activate InfoMini in a new report. For more information on
enabling InfoMini options, see How to Enable and Disable InfoMini Application Options
on page 462.

< In the Destination group, on the InfoMini menu, click one of the following options:
4 Home tab
- Format tab
4 Slicers tab
- Data tab
4 Slicer tab (Edit)

WebFOCUS InfoAssist User's Manual 461



Creating an InfoMini Application

Procedure:

Procedure:

Procedure:

462

4 Layout tab
4 Resources/Field tab
4 Save

The InfoMini button is highlighted and the InfoMini mode is activated. For more
information about running an InfoMini application, see How to Test an InfoMini Application
on page 462.

How to Enable and Disable InfoMini Application Options

You can choose which options will be available at run time in an InfoMini application. By
default, the Format tab, Slicers tab, and Save option are selected on the menu when you
activate InfoMini in a new report. For more information about the functionality of each option,
see Understanding InfoMini Applications on page 456.

1. With an InfoAssist report open, click the Format tab.
2. Click the InfoMini button and select the options you want available from the menu.

InfoMini does not have to be active for you to access the menu. When you select an
option from the menu, InfoMini is activated.

How to Test an InfoMini Application

1. With an InfoAssist report open, activate InfoMini as described in How to Activate InfoMini
on page 461.

2. Enable the options that you want, as described in How to Enable and Disable InfoMini
Application Options on page 462.

3. Run the report.

An InfoMini application opens in a new window.

How to Interact With an InfoMini Application

With an InfoMini application open, you can edit the application using the functionality that
was enabled in InfoAssist. You have access to Interactive and Edit mode options, depending
on which options were enabled. For more information on the options in Interactive mode,
see Interactive Mode on page 458. For more information on the options in Edit mode, see
Edit Mode on page 459.

You have the ability to alter the InfoMini application at run time using the Interactive and
Edit modes. Changes to the application are not reflected on the canvas dynamically and you
must run the report to see the updates.
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1. Run areport with InfoMini activated, as described in How to Test an InfoMini Application
on page 462.

An InfoMini application opens in a new window.

2. By default, the ribbon is hidden in an InfoMini application. To display the ribbon, do one
of the following:

1 Click one of the tabs, as shown in the following image.

-  Run ‘B Tnteractve B Edit

phieme, Format Slicers i @

1

Stereo Systems West 13,017,422.95
Televisions ‘West 42,979,027.83
Video Players West 16,491,444.00
Yideo Production ‘West 9,281,163.62

-

' Click the Show Ribbon button, as shown in the following image.

= & Run m @ Edit

Home Format  Slicers il @
Product

Catepory Region Revenue

Stereo Systems West 13,017,422.95 E
Televisions West 42.979,027.83

Video Players West 16,491,444.00

Video Production West 9,281,163.62 |
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3. To use the InfoMini application in Interactive mode, click Interactive, as shown in the
following image.

- & Run m @ Edit

Home Format Slicers ~ @
Product N
Category Region Revenue

Stereo Systems West 13,017,422.95

Televisions West 42,979,027.83

Video Players West 16,491, 444,00

Video Producton West %,281,163.62 _

The tabs that are enabled appear on the ribbon. For example, in the preceding image,
the Home, Format, and Slicers tab were enabled in InfoMini and appear on the ribbon.
The available options on these tabs provide the same functionality as they do in
InfoAssist. You can use this embedded functionality to change the report at run time.
For more information on the tabs and options that can be enabled in Interactive mode,
see Interactive Mode on page 458.

For example, in the following image, active report has been selected as the output format
for the report.
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The following image shows the active report at run time.

P < Run B Interactive B Edit

Home Format  Slicers

LS Active I Active Excel PowerPoint
Repaort

4 of 4 records, Page 1 of 1

lategory ¥ Region ¥ Revenue ¥

Ctereo Systems  West  13,017,422.95
Televisions West 42.979,027.83
[ideo Players West 16,451,444.00
[ideo Production West 9,281,163.62
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4. To use the InfoMini application in Edit mode, click Edit, as shown in the following image.

- Crun  Einteractive & Edip

Home Format Slicers

Product
Region Catepory Revenue
Central Stereo Systems 3,027,276.42
Televisions 10,131,328.0%
Yideo Players 3,835,578.36

Video Production 2,166,5%1.20
MidEast Stereo Systems 1,254,014.44
Televisions 4,256,202.11
Yideo Players 1,653,244.82
Video Production 896,178.80
MorthEast  Stereo Systems 2,381,435.14
Televisions 7,452,259.1%
Yideo Players 2,980,605.73
Video Production 1,723,425.57
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The tabs that are enabled appear on the ribbon, as shown in the following image. The
available options on these tabs provide the same functionality as they do in InfoAssist.
You can use this embedded functionality to change the report at run time. For more
information on the tabs and options that can be enabled in Edit mode, see Edit Mode
on page 459.

& Run B Interactive 2! Edit

Home Format Data Slicers  Layout  Field

Fpata
Product
= i WF_RETAL I.';] Region Category Revenue
= @ genmons Central Stereo Systems 3,027,276.42
= C;si;om?r Televisions 10,131,328.0%
+ egion
Video Players 3,835,578.36
= & Product

Video Production 2,166,591.20
MidEast Stereo Systems 1,254,014.44
Televisions 4,256,202.11
Yideo Players 1,603,244.82
Video Production B%6,178.80
MorthEast  Stereo Systems 2,381,435.14
Televisions 7,452,259.19
Yideo Players 2,980,606.73
Video Production 1,723,425.57

B Product,Category
= 4 Time (Sales)
B ‘Year,(Sales) -

2 ¥ Filter

WebFOCUS InfoAssist User's Manual 467



Creating an InfoMini Application

For example, the following image shows a slicer group that has been created for this

report in the InfoMini application.

’ & pun 3 Edit

Home Format Data 3 Fizld

o[- T
Bl wovee [

Product

= 4 Dimensions (=

B Product,Category
= 4 Time (Sales)

Category

Central Stereo Systems
£ egion
Video Players
= % Product

Video Production
MidEast Stereo Systems

B Year,(Sales) Televisions
= 4 Time (Shipped) Video Players

B Year,(Shipped) Video Production
= & Time (Delivery) MorthEast  Stereo Systems

Revenue

3,027,276.42

10,131,328.0%

3,835,578.36
2,166,591.20
1,254,014.44
4,256,202.11
1,653,244.82

896,178.80
2,381,435.14

5. After making your changes, click Run to see an updated version of the report.

For example, the following image shows the report run with Region as the slicer in the

InfoMini application.

Home Format Data S Layout  Fizld

Run Time m: |_ F!.E!gilj 1.1 :

Recard Lirnit

= @ WF_RETALL
= & Dimensions E

Revenue

MorthEast  Stereo Systems 2,381,435.14

e G:“‘-'R aphy Televisions 7,452,259.1%
+ egion
Videa Players 2,980,605.73
= 4 Product ==

B Product,Category
= 4 Time (Sales)

B Year,(Sales)
= 4 Time (Shipped)

B Year,(Shipped)
= & Time (Delivery)
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Video Production  1,723,425.57
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6. Click Save to save the application.

You can reopen a saved InfoMini application in InfoMini or, if you have access, open
the report in InfoAssist.
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Glossary

B

This is a glossary of key concepts in this

Topics:
manual.

4 Key Concepts
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Key Concepts
accordion report
Report output that is expandable for each vertical sort field.
active dashboard prompts

Controls from Active Technologies that act as filters on the reports of the document,
such as text box, image, drop down, list, check box, radio button, and text field.

active dashboard properties dialog

A dialog box of options to add active form controls to reports in a document.
active report

A report that is designed for offline analysis.
aggregation value

A value assigned to a numeric measure field in a report.
annotation

Explanatory note or comment.
axis

A reference line drawn on a chart.
axis labels

Labels generated automatically based upon the scale of the axis. They appear along the
axis.

axis title

Descriptive text that provides meaningful information about the data measured by an
axis.

background
The area the appears behind the frame of a chart.
cascade controls

Controls that have a parent-child relationship, in which the parent filters the available
options of the child. An active form control can be the parent of more than one other
control, but cannot be a child of more than one control.
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color bands

Basic design elements of a chart. Color bands come in a pair, with each band uniquely
colored. They appear in a continually repeating pattern behind a series on a chart. The
contrast of colors is designed to make a chart easier to read.

color mode

The mode that controls how color is applied to a series (measure field) on a chart. The
possible settings are By Series (default) and By Group.

data labels
Descriptive names that identify specific data points within a series.
dimension filtering
An option to display dimension filters at the top of a report.
feeler line
A line that connects the data label to a chart.
Format Grid Lines dialog box

A dialog box of options to format horizontal and vertical gridlines, color bands, and frames
on a chart.

Format Axis dialog box
A dialog box of options for formatting for both vertical and horizontal axes.
Format Gauge dialog box

A dialog box of options for formatting a gauge chart. Such options include setting and
styling a title for the gauge chart, setting tick marks, and color bands, as well as advanced
settings, such as setting the gauge start and stop angle.

Format Labels dialog box

A dialog box that contains options for editing data labels.
Format Series dialog box

A dialog box that contains options to format the fill and border of each series on a chart.
frame

The area of a chart that contains all of the basic chart elements, such as the plot points,
gridlines, legend, and chart title. The frame appears as a rectangle.

gridlines

Lines that run horizontally and vertically to enhance the readability of a chart. Gridlines
can be major or minor.
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legend

A chart element that displays each series that appears on a chart.
markers

Visual elements found on line charts that represent data points on a chart.
quadrant lines

Horizontal and vertical lines that cross to divide a chart into four sections.
reference line

A line designed to draw attention to specific data locations on a chart. A maximum of
three horizontal (X axis) and three vertical (Y axis) reference lines can be added to a
chart.

ring label
Descriptive name for a concentric ring found on a ring chart.
series
A group of data points that are plotted on a chart
stack measures
An option to stack all measures on a report.
trendline

A line drawn between any two points on a data series that shows the direction that the
values of the data series are going in.
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3D chart types 195

3D charts 195

3D depth
removing from a bar chart 345

A

accessing document view
from document button 359
opening an existing item 358

accordion reports 177
active dashboard 408

active dashboard prompts group 49

active report options dialog box
Advanced tab 405
active report Options dialog box 397, 401, 403
Colors tab 403
Menu Options tab 401
active reports Options dialog box
General tab 398
Active Technologies
for charts 406

adding to reports 145
Advanced Filter dialog box 68
aggregation options in reports 166

aggregation values 233

annotations
displaying 352
application button 30

application main menu 31

application window 30
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area chart types 190

area charts 189

axis
manually setting 296
right-click menu 291
setting advanced properties 298
using properties 293

axis labels
custom format characters 288
deleting 293
formatting 284, 295
horizontal axis labels 284
rotating 294
secondary axis labels 285
staggering 293
vertical axis labels 285

axis titles
adding 297

B

bar chart types 185
bar charts 183
Break group 90
bubble charts 194

C

Calculation group 62

cell padding in reports 152
chart

adding a page heading and a page footing 342

475



Index

chart (continued)
controlling the rendering of a page heading and
page footing 344
frame and background 299
pyramid 197
rotating 348
chart frame and background
formatting 298

Chart Types group 60

charts
3D 195
area 189
bar 183
bubble 194
chart elements 204
chart formatting tools 204
chart outputs 203
combination 198
creating a basic chart 199
creating a combination chart 202
creating a dual-axis chart 202
creating a multi-axis chart 203
creating an advanced chart 200
creating and customizing 181
displaying annotations 352
funnel 197
gauge 197
gauge thermometer 197
horizontal bar charts 185
horizontal box plot 197
library of advanced charts 199
line charts 188
Live Preview 205
multi-axis 191
pareto 197
pie 186
polar 193
reference lines 349
removing 3D depth 345
right-click menu 206
selecting 183
special 197
spectral map 197
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charts (continued)
stock 196
using Active Technologies 406
vertical bar charts 184
vertical box plot 197
visualizing data with 182
XY plot 191

color bands
setting 282

Color dialog box 46

color mode
by group 241
by series 241
Color Mode
By Group setting 216
By Series setting 216

color-banded rows of data in reports 148
column totals in reports 163
combination charts 198

creating a new procedure 23

D

data labels
associated dialog boxes 243
changing the position 255
custom format characters 249
formatting 242
right-click menu 253
showing 254
using properties 254

Data pane
adding fields to a report 104

Data Panel group 79

Data Source group 72

Data tab 62, 64, 68, 72
Calculation group 62
Data Source group 72
Display group 72
Filter group 68

WebFOCUS



index}

Data tab (continued)
Join group 64

Design group 41
Destination group 54
Detail (DEFINE) dialog box 63

Display group 92, 99

Document view
accessing 356

documents
accessing Document view 356
aligning components 378
associate a field with a prompt from the active
technologies dashboard properties dialog box
412
building 361
building a new 357
building in document view 355
cascading prompts 429
changing the filter condition 424
creating from a single report 372
deleting a component 389
editing component 374
editing text 386
insert a chart with right-click 370
inserting a chart 367
inserting a chart with double-click 369
inserting a chart with drag and drop 368
inserting a chart with the Insert tab 368
inserting a report 363
inserting a report with double-click 365
inserting a report with drag and drop 364
inserting a report with right-click 366
inserting a report with the Insert Tab 364
inserting an existing report 371
inserting an existing report into a document with
the Insert tab 371
inserting an image 373
inserting reports from multiple data sources
361
inserting text 372
inserting text and images 372
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inserting two reports from two different data

sources 361

moving a component 377

resizing a component 374

set target reports 409

styling and customizing a chart 384
styling and customizing a report 382

E

Edit Slicers dialog box 449
Edit Title dialog box 211
Excel output for reports 138

F

Features group (charts) 58

Features group (reports) 57

field formats
alphanumeric 154
changing in reports 154
date 155
date-time 156
numeric 155
percent sign 156
field images 101
Field tab 85, 86, 89, 90, 91, 92, 93
Break group 90
Display group 92
Filter group 86
Format group 91
Links group 93
Sort group 89
Style group 91
Filter group 42, 68, 86

filtering with slicers 441

Format Axis dialog box 285, 286, 287, 288, 290

Advanced tab 290
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Format Axis dialog box (continued)
Labels tab 288
Scale tab 286
Title tab 287
Format Gauge dialog box 318, 319, 322, 324,
325, 326
Advanced tab 326
Axis Scale & Labels tab 322
Bands tab 325
General Options tab 319
Tick Marks tab 324
Format Grid Lines dialog box 268, 269, 271, 272,
273
Color Bands tab 271
Frames tab 273
Major Grid Lines tab 268
Minor Grid Lines tab 269
Quadrant Lines tab 272
Format group 39, 41, 91
Home tab 41
Format Labels dialog box 243, 244, 246, 247,
248, 250, 251
Advanced tab 246
Funnel Labels tab 251
General Options tab 244
General Options tab (stack chart) 247
Pie Labels tab 248
Pie Title tab 250
Format Legend dialog box 256, 257, 259, 260
Advanced tab 260
Legend Options tab 257
Markers & Labels tab 259
Format Series dialog box 209, 211
Border tab 211
Fill tab 209
Format tab 50, 51, 54, 56, 57, 58, 60, 61
Chart Types group 60
Destination group 54
Features group (charts) 58
Features group (reports) 57
Labels group (charts) 61
Navigation group (reports 56
Output Types group 51
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Frame & Background dialog box 299, 300, 302,
304, 306, 307, 308, 310, 312

Advanced tab for 3D charts 308
Background tab 310
Frame Edge tab for 2D charts and 2D charts
with 3D effects 302
Frame Edge tab for pie charts 306
Frame tab for 2D charts and 2D charts with 3D
effect 300
Frame tab for pie charts 304
right-click menu 312
Wall and Floor tabs 307

frame and background
using properties 313

freezing column titles in reports 175

funnel charts 197

G

gauge
using properties 328
gauge chart
right-click menu 327
gauge charts 197, 318
Format Gauge dialog box 318

gauge thermometer 197

gridlines 267, 274, 276, 277, 278, 279, 282
deleting 282
displaying horizontal minor 276
displaying vertical major 277
displaying vertical minor 278
formatting 267
major 267
minor 267
right-click menu 274
setting the color, weight, and style 279
using properties 274
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H

headings and footings 145, 148
styling in a report 148

Help 25, 30

Home tab 39, 41, 42
Design group 41
Filter group 42
Format group 39, 41
Report group 42
horizontal box plot charts 197

horizontal major gridlines
displaying 275
HTML5 53

I

InfoAssist
accessing 22
introducing 15

InfoAssist Basic 17, 23
accessing 23

InfoAssist interface
application button 30
application window 30
Help 30
Layout canvas 31
main components 30
navigating 29
Navigation taskbar 31
Output window 31
Query Design pane 31
Quick Access Toolbar 30
Resources panel 30
Results panel 30
ribbon 30
status bar 31

InfoAssist Options dialog box 24

InfoMini 18, 23
accessing 23
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Insert tab 47, 48, 49
active dashboard prompts group 49
Objects group 48
Report group 48

inserting a chart 367

J

Join dialog box 65
Join group 64

L

Labels group (charts) 61
layout canvas 31

Layout canvas 119

Layout tab 76, 77
Page Setup group 76, 77
Report group 77
Size & Arrange group 77
legend
right-click menu 261
legends
controlling the orientation 264
formatting 256
hiding 262
positioning 262
specifying background color 265
specifying border color 266
using properties 262

limiting column variables in reports 159

line chart types 189

line charts 188, 220
applying a smooth effect 220

Line group 97
Line Style dialog box 253
Links group 93
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List view 80

Logical view 79

M

major gridlines 267

marker

changing the appearance of 222
markers

connecting or hiding a series line 221

mathematical equations 219
minor gridlines 267

multi-axis charts 191

N

Navigation group (reports) 56
Navigation taskbar 31, 131

o

Objects group 48
Options group 74
Options window 26

Output Types group 51

Output window 31, 121, 123, 124, 125
cascade 123
output format options 125
output target options 121
output view options 123
switch output 125
tile horizontally 124
tile vertically 125

Output Window group 83
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P

page and line breaks in reports 159

page footing
adding to a chart 342

page heading
adding to a chart 342

page headings and page footings
formatting 342

Page Setup group 76, 77

pareto charts 197

Personal InfoAssist 16, 22
accessing 22

pie chart types 187
pie charts 186

Pie group 98

pie slices
expanding 225
hiding 226

polar charts 193

pop-up titles in reports 165
Properties group 95
pyramid charts 197

Q

Query Design pane 31, 81, 103, 108, 207
1x4 81
areas 2x2 81
filter area 103
right-click options 108
right-click options for charts 207
tree 81

Query Panel group 81
Quick Access Toolbar 30, 35
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R reports (continued)
traffic light conditional styling by constant 149
traffic light conditional styling by field 151
visualization bars 165
recalculating compute results in a report 170 Reports

Live Preview 205
Resources panel 30, 99, 101, 105

ranking fields in reports 158

reference lines 349

repeated sort values in reports 168 field images 101

Report group 42, 77, 84 using Query Design pane in 105
_ Results panel 30, 115, 116

Report Style dialog box 45 using Query Design pane in 116

reports ribbon 30

accordion reports 177

aggregation options for measure data 166
cell padding 152

color-banded rows of data 148 S
column totals 163

creating an active technologies report 392
custom features 157

row totals in reports 164

scatter charts 192

customized output 170 secondary axes options
Excel output 138 Format Secondary Axis dialog box 291
freezing column titles 175 Section 508 accessibility 19

headings and footings 145
limiting column variables 159
OLAP reports 171 Select group 95
page and line breaks 159
pages on demand 176

Select a data source dialog box 73

selecting a data source 23

pop-up titles 165 series 208, 214, 217, 218, 227, 229, 231, 239,
ranking fields 158 2{11, 242.

recalculating compute results 170 chang!ng the title 239

repeated sort values 168 changing the type 218
report-level styling 139 color mode 241

row totals 164 dfaletlng 242

stacked measures 178 dialog boxes 208

Style group 143 filtering values in 229

styling 135, 139 formatting 208

styling column titles 142 formatting the fill and border 218
styling data 142 hiding.fields 231

styling headings and footings 148 reversing the order of 227

styling rows with alternate colors 148 rlght—c!|ck menu 214
subheadings and subfootings 164 selecting 217

subtotals 160 using properties 217

table of contents 173 Series tab 95, 97, 98, 99

Display group 99
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Series tab (continued)
Line group 97
Pie group 98
Properties group 95
Select group 95

Show/Hide group 78
Size & Arrange group 77

Size and Position dialog box 376, 378

slicers
Edit Slicers dialog box 449
filtering with 441
using 437

Slicers tab 74, 75
Group Number group 75
Options group 74
Record Limit group 74

Sort group 89

sorting fields 229

special charts 197

spectral map charts 197

stacked measures in reports 178

status bar 31, 133

stock chart types 197

stock charts 196

Structured view 80

Style dialog box 252

Style group 91

subheadings and subfootings in reports 164
subtotals in reports 160

Summary Field (COMPUTE) dialog box 63

-

ticks
setting 280
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Traffic Light Condition dialog box 211
traffic light conditional styling by constant in reports
149

traffic light conditional styling by field in reports 151
traffic light conditions
applying with drill-down to numeric measure field
(by constant) 235
applying with drill-down to numeric measure field
(by field) 238
trendlines
adding 219

U

user preferences
changing 25
environment and styling 27
format 27
layout 26
start up options 26
view 27

v

vertical box plots charts 197

View tab 78, 79, 81, 83, 84
Data Panel group 79
Output Window group 83
Query Panel group 81
Report group 84
Show/Hide group 78

visualization bars in reports 165

X

XY plot chart types 194
XY plot charts 191
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Reader Comments

In an ongoing effort to produce effective documentation, the Documentation Services staff
at Information Builders welcomes any opinion you can offer regarding this manual.

Please use this form to relay suggestions for improving this publication or to alert us to
corrections.ldentify specific pages where applicable.You can contact us through the following

methods:
Mail: Documentation Services - Customer Support
Information Builders, Inc.
Two Penn Plaza
New York, NY 10121-2898
Fax: (212) 967-0460
Email: books_info@ibi.com
Web form: http://www.informationbuilders.com/bookstore/derf.html|
Name:
Company:
Address:
Telephone: Date:
Email:
Comments:
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